Register to reply

Determining resistance of oscilloscope.

by peripatein
Tags: determining, oscilloscope, resistance
Share this thread:
peripatein
#1
Apr26-13, 04:32 PM
P: 818
Hi,
I'd appreciate some help in determining the internal resistance of the oscilloscope Agilent DSO1002A. Based on the user's guide the input impedance is: 1 Mohm 1% || 18 3 pF, but another reference I have for some unexplained reason states it should be 50 ohm. Which is correct?
Phys.Org News Partner Physics news on Phys.org
Mapping the optimal route between two quantum states
Spin-based electronics: New material successfully tested
Verifying the future of quantum computing
mfb
#2
Apr26-13, 05:23 PM
Mentor
P: 11,617
Some oscilloscopes let you choose between 1 MOhm and 50 Ohm impedance.
Maybe the other reference suggested to use 50 Ohm (externally)?
peripatein
#3
Apr26-13, 05:40 PM
P: 818
How may I ascertain this, whilst having no access to the device itself? I must use this in my calculations.

peripatein
#4
Apr26-13, 05:43 PM
P: 818
Determining resistance of oscilloscope.

It is a simple RC circuit.
berkeman
#5
Apr26-13, 05:53 PM
Mentor
berkeman's Avatar
P: 40,729
Quote Quote by peripatein View Post
Hi,
I'd appreciate some help in determining the internal resistance of the oscilloscope Agilent DSO1002A. Based on the user's guide the input impedance is: 1 Mohm 1% || 18 3 pF, but another reference I have for some unexplained reason states it should be 50 ohm. Which is correct?
Quote Quote by peripatein View Post
How may I ascertain this, whilst having no access to the device itself? I must use this in my calculations.
What do you mean you don't have access? Does that mean you did some experiments with it, and are now writing the report somewhere other than the lab?

Do you have any screenshots from the 'scope and your work? The coupling impedance may be noted somewhere on the screen. Alternately, can you call someone who can look at the 'scope for you? Just have them select that channel's coupling information menu, and it will state which input impedance is selected.
peripatein
#6
Apr26-13, 06:10 PM
P: 818
I mean precisely that - I am currently working on a lab report somewhere other than the lab. It is also the weekend, mind you, so there is no one who could gain access to the device. I am attaching both the sketches of the circuits themselves and some of the graphs generated by the oscilloscope. Hopefully, via these you will be able to answer some of my questions.
Attached Thumbnails
RCL.jpg   RC.jpg   Waveform_2_EY1.jpg  
berkeman
#7
Apr26-13, 06:13 PM
Mentor
berkeman's Avatar
P: 40,729
Quote Quote by peripatein View Post
I mean precisely that - I am currently working on a lab report somewhere other than the lab. It is also the weekend, mind you, so there is no one who could gain access to the device. I am attaching both the sketches of the circuits themselves and some of the graphs generated by the oscilloscope. Hopefully, via these you will be able to answer some of my questions.
You were using 10:1 oscilloscope probes, correct? They assume an input impedance of 1 MOhm into the 'scope's BNC connections. If you switch on the 50 Ohm input impedance option, that will attenuate the input waveform significantly. From the looks of your waveforms, the inputs were set to 1 MOhm.

Or were you directly connecting your test circuits to the 'scope BNC inputs with only coax cable and not 'scope probes?
peripatein
#8
Apr26-13, 06:19 PM
P: 818
To the best of my knowledge we were instructed to use probe 1, i.e. plausibly 1:1 (and not 10:1). Moreover, were it 1 MOhm, would it not function as an open circuit (nearly infinite resistance)? We did use coax cables.
peripatein
#9
Apr26-13, 06:36 PM
P: 818
So are you still inclined to believe it was 1 MOhm?
Furthermore, I would like to estimate the error in time and voltage. Based on the user's guide, the error in time is given as 50ppm whereas the error in voltage is 3% of full scale. Is the error in time then 50 * 10^-6 * resolution? But what is the resolution? 10^-6 sec (based on the graph I previously attached)?
As for the voltage, what is the "full scale"?
berkeman
#10
Apr26-13, 06:37 PM
Mentor
berkeman's Avatar
P: 40,729
Quote Quote by peripatein View Post
To the best of my knowledge we were instructed to use probe 1, i.e. plausibly 1:1 (and not 10:1). Moreover, were it 1 MOhm, would it not function as an open circuit (nearly infinite resistance)? We did use coax cables.
Here is a good intro from Tektrtonix about 'scope probe fundamentals:

http://www.ece.vt.edu/cel/docs/Probe..._Tektronix.pdf

A discussion of 'scope probe loading on circuits starts on page 32.

A 10:1 'scope probe has 9 MOhm in series with the input, to divide against the 1 MOhm input of the 'scope, as you can see in the attached figure from http://zone.ni.com/cms/images/devzone/ph/37d4325357.gif

That's how you get a nice high 10 MOhm input impedance to help avoid loading your test circuit. I don't know what a 1:1 probe would be, except maybe just straight coax. If that's what you used, you will need to look at your test circuit's impedances and the signal generator's output impedance and voltage level, to tell what the input impedance of the 'scope was. You should be able to figure it out from that.

http://zone.ni.com/cms/images/devzone/ph/37d4325357.gif
peripatein
#11
Apr26-13, 06:46 PM
P: 818
And what about the errors (time and voltage)?
berkeman
#12
Apr26-13, 07:21 PM
Mentor
berkeman's Avatar
P: 40,729
Quote Quote by peripatein View Post
So are you still inclined to believe it was 1 MOhm?
Furthermore, I would like to estimate the error in time and voltage. Based on the user's guide, the error in time is given as 50ppm whereas the error in voltage is 3% of full scale. Is the error in time then 50 * 10^-6 * resolution? But what is the resolution? 10^-6 sec (based on the graph I previously attached)?
As for the voltage, what is the "full scale"?
Does the user's guide say anything more specific than just "50ppm"? That sounds like a tolerance on its internal timebase clock. 50ppm is 0.005%, so any time measurements that you made with the 'scope could be off by +/-0.005%.

I think by full scale they mean the Vpp value for the waveform. When you measure that on the scope, the number can be off by +/-3% of its actual value.

BTW, did this scope have a current calibration sticker on it? If it's out of cal, the error in amplitude could be bigger. The timebase might be slightly off too, but for your experiments, any timebase errors are probably negligible.
peripatein
#13
Apr26-13, 07:31 PM
P: 818
First of all, should the error in voltage indeed be 0.03*full scale, and not 0.04*full scale? Could you kindly confirm that provided that 4V were applied? Second, since we used 4V, does that mean that delta V is +/- 0.12V (in case it is 3% of full scale, and not 4%)? Third, what would delta t be then? Would it be 0.005% * 1 microsecond (as inferred from the graph I attached, unless I am not analysing the image properly)?
berkeman
#14
Apr26-13, 07:35 PM
Mentor
berkeman's Avatar
P: 40,729
Quote Quote by peripatein View Post
First of all, should the error in voltage indeed be 0.03*full scale, and not 0.04*full scale? Could you kindly confirm that provided that 4V were applied? Second, since we used 4V, does that mean that delta V is +/- 0.12V (in case it is 3% of full scale, and not 4%)? Third, what would delta t be then? Would it be 0.005% * 1 microsecond (as inferred from the graph I attached, unless I am not analysing the image properly)?
Sorry, what exactly were you measuring?

The % errors multiply your Vpp measurement, and any time measurements you do. The timebase error should be negligible for measurements like this. Human errors in making the measurements, or noise in the setup would likely dominate.
peripatein
#15
Apr26-13, 07:44 PM
P: 818
It might be negligible, but I still need them for MATLAB to plot a graph and yield errors etc.
Is the time measurement the 200 microseconds at the leftmost corner of the plot I attached? If so, does that mean that the error in time measurement would be 0.005%*200*10^-6??
As we used 4V, would the error in voltage be 3% or 4%? I am not sure I am reading the user's guide properly!
berkeman
#16
Apr26-13, 07:51 PM
Mentor
berkeman's Avatar
P: 40,729
Quote Quote by peripatein View Post
It might be negligible, but I still need them for MATLAB to plot a graph and yield errors etc.
Is the time measurement the 200 microseconds at the leftmost corner of the plot I attached? If so, does that mean that the error in time measurement would be 0.005%*200*10^-6??
As we used 4V, would the error in voltage be 3% or 4%? I am not sure I am reading the user's guide properly!
200us/div is not a measurement. What delta-t were you measuring? Maybe a delay from the RC?

I would just use the 3% number on all of the voltages you measure. You should look around at the Agilent website for app notes that talk about DSO accuracy and errors. That will probably make this a lot easier for you. You can even reference the Tek probe app note and any Agilent app notes in your lab report.
peripatein
#17
Apr27-13, 01:57 AM
P: 818
I have looked it up in the user's manual, yet all I could come up with was the 50ppm. I am not exactly sure how to correctly apply that 0.005%! Could you possibly help?


Register to reply

Related Discussions
Falling air resistance, determining g Introductory Physics Homework 4
Determining the frictional resistance. Introductory Physics Homework 1
Determining EMF and Internal Resistance Introductory Physics Homework 6
Circuit for determining the internal resistance of a dry cell Electrical Engineering 1
Determining frequency of sound using a calibrated cathode ray oscilloscope Introductory Physics Homework 3