IP/DNS on kubuntu


by assed
Tags: dns automatic, ip automatic, ip or dns, kubuntu
assed
assed is offline
#1
Feb4-14, 08:07 PM
P: 19
Some suggestions ot solve my problem include set the network to " Obtain IP/DNS adress automatically ". I've seen that in other operational systems this setting is pretty easy to find, but I can't find a way to do it on kubuntu. Can someone tell me how its done. Thanks.
Phys.Org News Partner Science news on Phys.org
Cougars' diverse diet helped them survive the Pleistocene mass extinction
Cyber risks can cause disruption on scale of 2008 crisis, study says
Mantis shrimp stronger than airplanes
Routaran
Routaran is offline
#2
Feb5-14, 11:13 AM
P: 271
You need to set the interface to use DHCP. This is the default setting as far as I know.

To set an interface to use DHCP, you'll need to modify your /etc/network/interfaces
(I am assuming that eth0 is the interface that you are using. If not, you will need to change that to whatever interface you're on)

first make a copy of the file, in case we break something else

then add the following code
auto eth0
iface eth0 inet dhcp
then restart the network manager so that it uses the new settings with the following command
service network-manager restart
EDIT: Given your other post, I would also suggest that you check with the Univeristy's IT department first. There may be a specific reason why you're not able to connect to your network. They will likely be able to tell you why. Once you have that, it is a lot easier to solve.
assed
assed is offline
#3
Feb5-14, 06:21 PM
P: 19
Thanks for the reply.
Didn't have time to check with the IT department and as sometimes they recquire you to leave your computer there for some time with them and I am currently in need of using it I am postponing it and trying some suggestions to solve this, and using other connections when I need.
By the way, I have already tried what you suggested and when I set "eth0" (the way you recommended), I cannot connect to any wired connection. Same way, when I set "wlan0" (which I think is my wireless interface) my computer doesn't detect any wireless connection. Do you know a reason why this is happening? I find it strange because many people suggest it as if it were usual/default.
Thanks again.

Routaran
Routaran is offline
#4
Feb7-14, 09:48 AM
P: 271

IP/DNS on kubuntu


I'd start off by trying to narrow down if the problem was hardware or a software configuration. Download a Ubuntu live CD from another system and try booting your computer from that. If you are able to use the NIC to connect to a network, then we know the problem is some configuration (works on LiveCD but not when you boot from the HDD). If it still doesn't work, then we may possibly be looking at a hardware issue.

I'd also post on the kubuntu support forums.


Register to reply

Related Discussions
Installing Kubuntu on a Virtualbox Computers 3
LaTeX on Kubuntu Linux - Where to install packages? Advanced Physics Homework 1
Kubuntu Live CD Computing & Technology 14
Setting up Kubuntu of my M6811 e-machines laptop Computing & Technology 3