LED voltage indicator for 3.7v lithium ion battery


by shseo0315
Tags: battery, indicator, lithium, voltage
shseo0315
shseo0315 is offline
#1
Apr17-13, 11:40 PM
P: 19
For my project, the Lithium Ion Polymer Battery - 3.7v 2600mAh powers arduino, transmitter and a few other parts. My whole design works on 3.3v.

I'm trying to build a circuit to indicate the status of the battery using LED.

When the voltage of the battery is consumed below 3.0v, I want to light on the Red LED.

I found some link and tried to build a circuit based on it.

http://www.made-by-bacteria.com/foru...php?f=59&t=479

The first one I built, it does not seem to be working for low Vcc like 3.3v.

http://sharingmanual.blogspot.com/20...h-led-bar.html

For this one, I didn't know if I should use the zener with 3.3v breakdown voltage.

Can anyone suggest me how you can go about this? or suggest me a link? Any tips will be appreciated.
Phys.Org News Partner Engineering news on Phys.org
A smart prosthetic knee with in-vivo diagnoses
Old tires become material for new and improved roads
Students take clot-buster for a spin
CWatters
CWatters is offline
#2
Apr18-13, 05:21 AM
P: 2,861
Quote Quote by shseo0315 View Post
I found some link and tried to build a circuit based on it.

http://www.made-by-bacteria.com/foru...php?f=59&t=479

The first one I built, it does not seem to be working for low Vcc like 3.3v.
That one needs a VCC at least greater than the forward voltage drop of the two LEDs. If each has a forward voltage of 2V then you need VCC to be at least 4V and more like 6V as you need some for R3.

Try replacing the Green LED with an ordinary diode (0.7V) and adjust the Rs to suit. The transistor would then switch off when the base falls below 2 x 0.7 = 1.4V. Adjust R1 and R2 to give a base voltage of 1.4V when VCC is say 3V. Adjust R3 to give the right LED current at VCC = 3V.

http://sharingmanual.blogspot.com/20...h-led-bar.html

For this one, I didn't know if I should use the zener with 3.3v breakdown voltage.
That one isn't ideal as it also needs a seperate power supply. 10V is shown on the diagram. I don't think an LM324 works down to 3V but haven't checked.
sherrellbc
sherrellbc is offline
#3
Apr18-13, 08:30 AM
P: 83
As CWatters said, the 3.3V supply would not supply sufficient voltage for this circuit to operate correctly. Think for a moment about the voltages that was be present if you were to apply a 3.3V supply and keep the values from the link (i.e. the divider resistors as 1k and 2k). The base voltage at the transistor would be 1.1V. Now, if you assume active-mode, the emitter of the NPN transistor shown would be approximately 400mV; obviously, this is not going to work considering the result is inconsistent with the configuration. The emitter voltage of the transistor will never go below approximately 2V as the LED is present and demands as much.

If you were to not consider what I mentioned earlier, neither LED will ever turn on to begin with as 3.3V is too little voltage as the previous poster mentioned. If you were to assume the forward voltage drop of each LED were 2V, then you can replace the LEDs with a two 2V supply and two ideal diodes(polarity with current flow downward) in series with the 100 Ohm resistor. In this case, you would actually have current flowing upward backwards through the diodes into the 3.3V supply; this is inconsistent.

shseo0315
shseo0315 is offline
#4
Apr18-13, 10:54 AM
P: 19

LED voltage indicator for 3.7v lithium ion battery


Hi, Thanks for the replies. I appreciate it.

So I understand what you all have said. So I tried to replace the green LED with a diode.
That makes Vb to be aroudn 1.4v to turn on BJT as the reply says.
I used R2=2k, R1=1K2, R3=150ohm. It still is not working.
Since 3.3v cannot be changed as my main power supply, I still need to work on this.

So sherrellbc, what do you mean by replacing two LEDs with two 2v supply and two ideal diodes in series with resistors?
Can you suggest anything to keep this going? I really need to make this circuit work by today.
Maybe Opamp? Zener diode?
Thanks a lot.
sherrellbc
sherrellbc is offline
#5
Apr18-13, 11:00 AM
P: 83
As I mentioned earlier, the 3.3V cannot be used if you are to keep the same bias resistors.

The base voltage at the transistor will be 1.1V in this configuration and be off for all time, thus the red LED will always be off using the resistor values you have chosen.

If R3 is about 30 Ohms the red LED will turn on, but even still the transistor will never turn on. With R3 as 150, the current through the LED is about 4mA.. Most LEDs require about 20mA to be sufficiently bright.
shseo0315
shseo0315 is offline
#6
Apr18-13, 11:19 AM
P: 19
That's understandable. Vb = Vcc * (R2/ R1+R2).
For the BJT to turn on, you need at least 1.4v(Vdiode + Vbeon).

To increase Vb, I will try to use some higher resistance for R2 around 4.7K with R1 fixed as 2k.
Also, as you have mentioned I will lower the resistance of R3 to have enough current around 20mA.
shseo0315
shseo0315 is offline
#7
Apr18-13, 11:51 AM
P: 19
So I have used R1 = 1.8k R2 = 4.7k and R1 = 56ohm
When Vcc is 3.7v, Vb would be around 2.67V, which makes BJT to turn on.
As Vcc decreases, Vb will reach 1.4V and BJT turns off and current only goes through RED LED and light it up.
When Vb is around 1.4V Vcc is around 2V. The current through the LED is Vcc/R = 2/56 = 35mA.
Is there anything wrong with this configuration? because it still does not work.
Thanks a lot.
shseo0315
shseo0315 is offline
#8
Apr18-13, 11:54 AM
P: 19
It is sort of working now. Actually the LED brights up fully at 3.7V and as you decrease power supply, LED light weakens. But I thought it should be turned off when the battery is full. As we decrease voltage, I thought the LED lights up. But why does LED act as some kind of indicater that uses its own brightness to show how much battery is left?
CWatters
CWatters is offline
#9
Apr19-13, 03:58 AM
P: 2,861
Quote Quote by shseo0315 View Post
So I have used R1 = 1.8k R2 = 4.7k and R1 = 56ohm
When Vcc is 3.7v, Vb would be around 2.67V, which makes BJT to turn on.
As Vcc decreases, Vb will reach 1.4V and BJT turns off and current only goes through RED LED and light it up.
When Vb is around 1.4V Vcc is around 2V. The current through the LED is Vcc/R = 2/56 = 35mA.
Is there anything wrong with this configuration? because it still does not work.
Thanks a lot.
With those values I got different figures for the base voltage. (Edit: I mean the base voltage without the transistor fitted)

@3.7V Vb is...

3.7 * 4.7/(4.7+1.8) = 2.67V (which is what you got)

@3.0V Vb is...

3.0 * 4.7/(4.7+1.8) = 2.17V (Which is a bit high)

Quote Quote by shseo0315 View Post
It is sort of working now. Actually the LED brights up fully at 3.7V and as you decrease power supply, LED light weakens. But I thought it should be turned off when the battery is full. As we decrease voltage, I thought the LED lights up. But why does LED act as some kind of indicater that uses its own brightness to show how much battery is left?
So the LED is ON all the time because the base voltage bias is wrong. It's brightness will depend on the supply voltage because R3 isn't a current source.
CWatters
CWatters is offline
#10
Apr19-13, 04:02 AM
P: 2,861
Try making R2 adjustable.
shseo0315
shseo0315 is offline
#11
Apr19-13, 03:20 PM
P: 19
Sorry, I still didn't get this.
First, I have set Ic=20mA
R3 = Vcc / Ic = 3.0V / 20mA = 150ohm
I have set 20mA for Ic. Since B=200, I used Ic/Ib = B to get Ib.
Ib = 0.1mA. then I used Ib = Vb /R2 = 1.4v/R2 = 0.1mA. Then, R2 = 14k

Finally, Vcc * (R2 / R1+R2) = 3.0V * (14k/R1+14K) = 1.4V, Then R1 = 16k

I connected power source 3.7v to Vcc and LED is full bright and R3 burned with smoke immeadiately.

Maybe I'm forgetting something really important. Would you like to give me your number for biased resistors?

Am I understading this incorrectly? Maybe wrong beta value?

This is the datasheet for my BJT. Could you let me know how to read beta value?http://www.datasheetcatalog.org/data...or/mXvurqw.pdf



Thanks a lot.
CWatters
CWatters is offline
#12
Apr20-13, 01:39 PM
P: 2,861
Quote Quote by shseo0315 View Post
Sorry, I still didn't get this.
First, I have set Ic=20mA
R3 = Vcc / Ic = 3.0V / 20mA = 150ohm
I would calculate R3 as follows..

(Vcc - Vd)/Ic
(3-0.7)/0.02 = 115 Ohms

Nearest preferred value is 120 Ohms but 150 Ohms should also work ok.

...and R3 burned with smoke
Check R3=150 Ohms.

The maximium power that R3 will burn is..

Power = V2/R
= 3.7 * 3.7 / 150 = 0.09 W

so unless you are using a very small surface mount resistor I can't see how it can burn up. Check the value is 150 Ohms. Perhaps you used 15 or 1.5 Ohms by mistake?

I haven't looked for other mistakes as I have a bad headache. Will look later.
CWatters
CWatters is offline
#13
Apr20-13, 05:53 PM
P: 2,861
Quote Quote by shseo0315 View Post
Sorry, I still didn't get this.
First, I have set Ic=20mA
R3 = Vcc / Ic = 3.0V / 20mA = 150ohm
I have set 20mA for Ic. Since B=200, I used Ic/Ib = B to get Ib.
Ib = 0.1mA. then I used Ib = Vb /R2 = 1.4v/R2 = 0.1mA. Then, R2 = 14k
I don't follow that bit. You seem to have calculated the base current required to turn on the transistor but you then used the same current flowing in R2 ???

The way most people would approach this is to arrange for the current flowing through R1 & R2 to be much greater than the base current. Say 10 times Ib. That way Vb is controlled by R1 & R2 and not effected by Ib. eg R1 and R2 form a simple voltage divider.

So the rules for setting R1 and R2 in this case are..

1) IR1 ≈ IR2 >> Ib
so VCC/(R1+R2) = 10 Ib
gives R1+R1 < 3000 ...............................................(1)

2) and the main objective..
VCClow * R2/(R2+R1) = 1.4V
so
R2/(R1+R2) = 1.4/3.0...............................................(2)

Substitute 1 into 2
R2/3000 = 1.4/3.0
R2 = 1400 Ohms.
R1 = 1600 Ohms

These aren't preferred values. So I would make R1 = 1500 and make R2 from a 1K fixed and a 500R adjustable in series. That way the exact VCC voltage the LED lights up at can be adjusted.

This circuit burns around 21mA even with the LED off which is quite a lot if it's a small battery.
CWatters
CWatters is offline
#14
Apr20-13, 06:01 PM
P: 2,861
Just had a look at the at the transistor data and the gain for that one appears to be more like 75 at 10mA. Might need to drop R1&R2 further.


Register to reply

Related Discussions
Replacing a lead acid 12 volt battery with a Lithium ion Polymer battery Electrical Engineering 15
Battery Indicator Electrical Engineering 4
need help with replacing a lead-acid sealed battery with a Lithium Ion battery Electrical Engineering 5
Help w/ low battery indicator please! Electrical Engineering 2
Essay on the Lithium ion battery Chemistry 1