Register to reply

Virus that disables system restore and hardware device manager?

Share this thread:
arunbg
#1
May14-07, 01:13 PM
P: 601
Hi,
My PC runs on Windows XP Professional SP2.
Today when I turned on my PC, I found that my desktop appearance had changed, more specifically the start taskbar was the white Windows classic version, not the usual blue XP version. But I didn't take it much seriously, thinking somebody else might have changed settings before me.

But then when I tried to play music in Windows media player, the program signalled an error, stating that my sound card or drivers(Realtek audio) were not properly connected or were malfunctioning. I tried to play in other media players, but was not able to get audio output. So I checked my device manager, to confirm whether the soundcard was detected. I was shocked to find that the list of devices was empty. But almost all other hardware except the sound card, seem to be working fine!

I was now suspecting a virus, although there had been no recent downloads or installations from unknown sources. So I ran a virus scan(Norton) and still nothing showed up.

Then as a last resort, I tried System Restore and got my second shock, when I found that all previous restore points including the ones I set manually, were gone! I have run out of options

Has anyone had any experience or knows of anything similar? Is a reloading of the operating sysytem the only way out?

Thanks in advance.
Phys.Org News Partner Science news on Phys.org
Sapphire talk enlivens guesswork over iPhone 6
Geneticists offer clues to better rice, tomato crops
UConn makes 3-D copies of antique instrument parts
Crosson
#2
May14-07, 01:40 PM
P: 1,295
It sounds like maybe the computer started up in safe mode.

Run the msconfig, go to the startup tab, and make sure a box isnt checked that says "startup in safe mode".
arunbg
#3
May14-07, 02:19 PM
P: 601
As you said, I ran msconfig, and as I thought the selective start option(just to uncheck all those pesky messenger sevices from startup; all drivers were checked) was checked, not diagnostic. For the sake of it, I clicked normal startup, loading all services and drivers(I should have thought of all this ages ago). On restart, voila everything was back to normal again. Well almost, system restore still hasn't got any previous restore points, but atleast all hardware has been detected and are functioning properly
It was as if safe mode was running without the computer(and me) knowing it! With system restore hoodwinked as well, should I still suspect a virus?

BTW, thanks a ton Crosson for your timely help.

Beller
#4
Aug22-10, 12:32 PM
P: 1
Virus that disables system restore and hardware device manager?

I'm afraid it's not something you did.
My lap top just got hte same virus. My device manager has been erased and the computer won't read my restore disk and all my restore points are gone as well.


Register to reply

Related Discussions
Windows System Restore Question Computing & Technology 1
Unable to reverse system restore Computing & Technology 2
I need to do a complete system restore Computing & Technology 1
How does WinXP's System Restore work? Computing & Technology 2