Register to reply

Registry shifter issue concerning LED's (3min20sec)

by thatsmessedup
Tags: 3min20sec, issue, registry, shifter
Share this thread:
thatsmessedup
#1
May24-14, 01:00 AM
P: 5
Please see the youtube video. I am relatively new to d.i.y. electronics and am a little befuddled at this issue I am having with my 74HC595N bit shifter IC.
Phys.Org News Partner Engineering news on Phys.org
Greater safety and security at Europe's train stations
Fingerprints for freight items
On the way to a safe and secure smart home
meBigGuy
#2
May25-14, 03:25 AM
P: 1,084
clock is ringing or grounf is bouncing. Grounds are sloppy. LED causes more switched current so inductance has more effect. Try adding a small capacitor to the clock input or somewhere else to reduce the ringing or ground bounce.
thatsmessedup
#3
May25-14, 01:48 PM
P: 5
I tried adding different value capacitors to the switch and various other places. It either had no effect or made it worse. I tied putting the cap between ground and positive, before and after the switch but nothing seems to fix the issue. Do you have any other suggestions or is this something I will need to have an oscilloscope to figure out?

AlephZero
#4
May25-14, 04:00 PM
Engineering
Sci Advisor
HW Helper
Thanks
P: 7,175
Registry shifter issue concerning LED's (3min20sec)

It would help to see a circuit diagram that shows the two places you connected the LED.

What is the power supply? Is it adequately smoothed?

I wonder if your "wrong" LED position is somehow momentarily shorting out the power supply rails when you press the switch, and the glitch in the supply voltage is causing the chaos in the shift register.
meBigGuy
#5
May25-14, 06:34 PM
P: 1,084
I agree --- I am making blind guesses without a schematic. It is obviously double clocking. Does it clock twice when you press, or once on press and once on release?

Put some more resistance in series with the LED. Again, just blind guessing.

Post a schematic and photo so we don't have to go to youtube.
thatsmessedup
#6
May25-14, 07:05 PM
P: 5
http://i.imgur.com/nrGj2WS.png is a crude schematic.
and a picture http://i.imgur.com/o5B9AHJ.jpg
meBigGuy
#7
May26-14, 03:59 AM
P: 1,084
too lazy to do a real schematic?

1. You need a 0.1 bypass across the shift register VDD and gnd. Don't use leads to connect it. Just put it over the IC.
2. When you have a 10K pulldown, the fall time when you release the button is slow. With 330 it is fast and either rings or is fast enough for the switch bounces to get through.

3. Switches bounce, causing multiple clock pulses. Usually one filters the heck out of them and uses a schmitt trigger to square up the edges. Look up switch bounce.

4. Adding a cap at the LED will do nothing. Add 100 ohms in series with the clock pin and a capacitor to ground at the clock pin. Or, just add a cap at the clock pin with no resistor. Experiment with the cap size. T=RC

Digital logic is very fast. Use the shortest possible ground. (you have a long inductor as a ground and power supply)
thatsmessedup
#8
May26-14, 11:04 AM
P: 5
Thank you meBigGuy. I will try your suggestions. Also, I am not lazy just new to drawing schematics.
thatsmessedup
#9
May26-14, 03:01 PM
P: 5
OK, all is working now! I added a cap between the ground and vcc of the IC and it helped a little. What really did the trick though was moving the vcc pin of the IC to the shared positive rail of all the other components instead of using the rail at the bottom of the breadboard. I am not sure why this fixed the issue but all is 100% working now.

http://i.imgur.com/d9YhUdj.jpg


Register to reply

Related Discussions
Windows registry question Computers 2
Phase Shifter Engineering, Comp Sci, & Technology Homework 2
Level shifter Advanced Physics Homework 1
(beginner) Please help with 3-bit shifter Electrical Engineering 0
Registry Editing Programming & Computer Science 4