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The implementation and application of a 3-phase Inductor using 

the Magnetostatic Solver to calculate the nonlinear inductance

The inductance calculation is an important part of a magnetostatic simulation.  

The inductive properties will, of course, change with the nonlinearities of the 

problem.  The properties and concepts of the inductance calculation are 

described in this example.

This example uses a 3-phase, 3-coil-per-phase inductor to demonstrate how 

the inductance calculation produces meaningful results.  The setup is 

scrutinized and the results are examined.  Then a half-symmetry model is 

examined to familiarize the user with a half-symmetry setup.
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Ansoft Maxwell Design Environment

The following features of the Ansoft Maxwell Design Environment are used to 

create the models covered in this topic

3D Solid Modeling

Primitives:  Box, Rectangle, Region:  Box, Rectangle, Region:  Box, Rectangle, Region:  Box, Rectangle, Region

Surface Operations:  Section Section Section Section 

Boolean Operations: Subtract, Separate Bodies, SplitSubtract, Separate Bodies, SplitSubtract, Separate Bodies, SplitSubtract, Separate Bodies, Split

3D Modeler: Delete Last OperationDelete Last OperationDelete Last OperationDelete Last Operation

Sweep:  Along PathAlong PathAlong PathAlong Path

Duplicate: Along LineAlong LineAlong LineAlong Line

Boundaries/Excitations

Current: StrandedStrandedStrandedStranded

Analysis

MagnetostaticMagnetostaticMagnetostaticMagnetostatic

Results

Inductance MatrixInductance MatrixInductance MatrixInductance Matrix
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Getting Started

Launching MaxwellLaunching MaxwellLaunching MaxwellLaunching Maxwell

1. To access Maxwell, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

Ansoft Ansoft Ansoft Ansoft and then Maxwell 11.Maxwell 11.Maxwell 11.Maxwell 11.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 

following tool options are set : : : : 

1. Select the menu item Tools > Options > Maxwell OptionsTools > Options > Maxwell OptionsTools > Options > Maxwell OptionsTools > Options > Maxwell Options

2. Maxwell Options Window:

1. Click the GeneralGeneralGeneralGeneral Options Options Options Options tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Maxwell window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. Select the menu item Project  > Insert Maxwell DesignProject  > Insert Maxwell DesignProject  > Insert Maxwell DesignProject  > Insert Maxwell Design, , , , or click on the    

icon

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

Select the menu item:  Maxwell > Solution Type > MagnetostaticMaxwell > Solution Type > MagnetostaticMaxwell > Solution Type > MagnetostaticMaxwell > Solution Type > Magnetostatic, or right 

mouse click on MaxwellDesign1 and select SolutionSolutionSolutionSolution Type Type Type Type …………

Creating the 3D Model of a Nonlinear InductorCreating the 3D Model of a Nonlinear InductorCreating the 3D Model of a Nonlinear InductorCreating the 3D Model of a Nonlinear Inductor

The example that will be used to demonstrate the inductance calculation is 

that of a 3-phase transformer with multiple windings in series for each 

phase.

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

Select the menu item 3D Modeler > Units > 3D Modeler > Units > 3D Modeler > Units > 3D Modeler > Units > Select Units: in (inches): in (inches): in (inches): in (inches)
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Create the Core

1. Select Draw > BoxDraw > BoxDraw > BoxDraw > Box to start the drawing procedure:

1. Enter -1, -6, 0 as the starting point of the box

2. Enter 2, 12, 10 to define the dimensions of the box

3. A Properties dialog appears: 

1. Select OKOKOKOK

4. Hold down Ctrl+DCtrl+DCtrl+DCtrl+D or click the      button to view the entire geometry.

2. Select Draw > BoxDraw > BoxDraw > BoxDraw > Box to start drawing the window.

1. Enter -1, 1, 2 as the starting point of the box

2. Enter 2, 3, 6 to define the dimensions of the box

3. A Properties dialog appears:

1. Select OKOKOKOK

3. Select Box2Box2Box2Box2 from the object tree (selected by default after creating it in step 2).

4. Select Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis to create a second window.

1. Axis: ZZZZ

2. Angle: 180 deg180 deg180 deg180 deg

3. Total number: 2222

4. Select OKOKOKOK

5. Select OKOKOKOK

6. Select Box1Box1Box1Box1, and then select Box2Box2Box2Box2 and Box2_1Box2_1Box2_1Box2_1 from the object tree.

Use CtrlCtrlCtrlCtrl or ShiftShiftShiftShift to select multiple items throughout this example.

7. Select 3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract

1. Make sure that Box1Box1Box1Box1 is in the Blank 

Parts box and that Box2Box2Box2Box2 and Box2_1Box2_1Box2_1Box2_1

are in the Tool Parts box (this is true 

if Box1Box1Box1Box1 is selected first).

2. Make sure that Clone tool objects Clone tool objects Clone tool objects Clone tool objects 

before subtractingbefore subtractingbefore subtractingbefore subtracting is deselected.

3. Select OKOKOKOK
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Create the Core (continued)

8. Select Draw > BoxDraw > BoxDraw > BoxDraw > Box to start drawing the gap:

1. Enter -1, -6, 2 as the starting point of the box

2. Enter 2, 12, 0.05 to define the dimensions of the box

3. A Properties dialog appears: 

1. In the value box of Zsize, enter gapgapgapgap and type Enter to accept this 

value.

1. In the Add Variable Add Variable Add Variable Add Variable box that appears, enter 0.05in for the 

value.

2. Select OKOKOKOK

2. Select OKOKOKOK

9. Select Box1Box1Box1Box1 and then Box3Box3Box3Box3 from the Object Tree.

(Use CtrlCtrlCtrlCtrl or ShiftShiftShiftShift to select multiple items.)

10. Select 3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract.

1. Make sure that Box1Box1Box1Box1 is in the Blank 

Parts box and that Box2Box2Box2Box2 and Box2_1Box2_1Box2_1Box2_1

are in the Tool Parts box (this is true 

if Box1Box1Box1Box1 is selected first).

2. Make sure that Clone tool objects Clone tool objects Clone tool objects Clone tool objects 

before subtractingbefore subtractingbefore subtractingbefore subtracting is deselected.

3. Select OKOKOKOK
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Create the Core (continued)

11. Select Box1.Box1.Box1.Box1.

12. Select 3D Modeler > Boolean > Separate Bodies3D Modeler > Boolean > Separate Bodies3D Modeler > Boolean > Separate Bodies3D Modeler > Boolean > Separate Bodies (the E and I parts of the core 

are now separate).

13. Double-click on Box1Box1Box1Box1 in the object tree (a Properties window pops up).

1. Change the name from Box1Box1Box1Box1 to Core_ECore_ECore_ECore_E.

2. Select OKOKOKOK.

14. Double-click on Box1_1Box1_1Box1_1Box1_1 in the object tree (a Properties window pops up).

1. Change the name from Box1_1Box1_1Box1_1Box1_1 to Core_ICore_ICore_ICore_I.

2. Select OKOKOKOK.

15. Select both Core_ECore_ECore_ECore_E and Core_ICore_ICore_ICore_I from the object tree.

1. Find the Attribute window (on the left side, under the project tree by 

default).

2. Click on the Material Value vacuumvacuumvacuumvacuum (a Materials list appears).

1. Find steel_1008steel_1008steel_1008steel_1008 and double-click on this material to accept it (or 

single-click and select OKOKOKOK).

16. The cores are now completely defined.
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Create the Coils

1. Select 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

2. Select Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle.

1. Enter 0, -3.6, 3.5 as the starting point of the rectangle

2. Enter 0, 0.3, -0.8 to define the dimensions of the rectangle

3. A Properties dialog appears: 

1. Select OKOKOKOK

3. Select 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

4. Select Draw RectangleDraw RectangleDraw RectangleDraw Rectangle.

1. Enter 1.5, -6.5, 3 as the starting point of the rectangle

2. Enter -3, 3, 0 to define the dimensions of the rectangle

3. A Properties dialog appears: 

1. Select OKOKOKOK

5. Select Rectangle2Rectangle2Rectangle2Rectangle2 from the object tree.

6. Select 3D Modeler > Delete Last Operation3D Modeler > Delete Last Operation3D Modeler > Delete Last Operation3D Modeler > Delete Last Operation to produce a line.

7. Select Rectangle1Rectangle1Rectangle1Rectangle1 and Rectangle2Rectangle2Rectangle2Rectangle2 from the object tree.

8. Select Draw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along Path

1. A Sweep along pathSweep along pathSweep along pathSweep along path window pops up:

1. Angle of twist: 0deg

2. Draft Angle: 0deg

3. Draft type: Round

4. Select OKOKOKOK

2. Select OKOKOKOK
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Create the Coils (continued)

9. Select Rectangle1Rectangle1Rectangle1Rectangle1 from the object tree.

10. Select Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line

1. Enter 0, 0, 0.

2. Enter 0, 0, 1.925.

1. Total Number: 3

2. Select OKOKOKOK.

3. Select OK.OK.OK.OK.

11. Select Rectangle1Rectangle1Rectangle1Rectangle1, Rectangle1_1Rectangle1_1Rectangle1_1Rectangle1_1,

and Rectangle1_2Rectangle1_2Rectangle1_2Rectangle1_2 from the object tree.

(Use CtrlCtrlCtrlCtrl or ShiftShiftShiftShift to select multiple items.)

12. Select Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line

1. Enter 0, 0, 0.

2. Enter 0, 5, 0.

1. Total Number: 3

2. Select OKOKOKOK.

3. Select OK.OK.OK.OK.

13. Select Rectangle1Rectangle1Rectangle1Rectangle1, Rectangle1_1Rectangle1_1Rectangle1_1Rectangle1_1, and Rectangle1_2Rectangle1_2Rectangle1_2Rectangle1_2 from the object tree.

14. In the Attribute window, type Coil_leftCoil_leftCoil_leftCoil_left in the Name Value.

15. Select Rectangle1_3Rectangle1_3Rectangle1_3Rectangle1_3, Rectangle1_1_1Rectangle1_1_1Rectangle1_1_1Rectangle1_1_1, and Rectangle1_2_1Rectangle1_2_1Rectangle1_2_1Rectangle1_2_1 from the object tree.

16. In the Attribute window, type Coil_midCoil_midCoil_midCoil_mid in the Name Value.

17. Select Rectangle1_4Rectangle1_4Rectangle1_4Rectangle1_4, Rectangle1_1_2Rectangle1_1_2Rectangle1_1_2Rectangle1_1_2, and Rectangle1_2_2Rectangle1_2_2Rectangle1_2_2Rectangle1_2_2 from the object tree.

18. In the Attribute window, type Coil_rightCoil_rightCoil_rightCoil_right in the Name Value.

19. Select all Coil Coil Coil Coil objects from the object tree.

20. In the Attribute window, click on the Material Value vacuumvacuumvacuumvacuum (a Materials list 

appears).

1. Find coppercoppercoppercopper and double-click on this material to accept it (or single-click 

and select OKOKOKOK).
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Create the Terminals and Define the Sources: 

1. Select all the CoilCoilCoilCoil objects from the object tree.

2. Select 3D Modeler > Surface > Section3D Modeler > Surface > Section3D Modeler > Surface > Section3D Modeler > Surface > Section…………

1. Select YZYZYZYZ

2. Select OKOKOKOK

3. Select all the SectionSectionSectionSection sheets (selected by default after the last operation).

4. Select 3D Modeler > Boolean > Separate Bodies3D Modeler > Boolean > Separate Bodies3D Modeler > Boolean > Separate Bodies3D Modeler > Boolean > Separate Bodies

5. Select the extra Sections (1_1 through 9_1) and delete them (by using Delete on 

the keyboard or Edit > DeleteEdit > DeleteEdit > DeleteEdit > Delete from the command menu).

6. Select the sheets Section1Section1Section1Section1, Section2Section2Section2Section2, Section3Section3Section3Section3 from the object tree.

7. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

8. The Current Excitation dialog appears.

1. Base Name: PhaseAPhaseAPhaseAPhaseA

2. Value: ----0.5*0.5*0.5*0.5*MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

9. Select OKOKOKOK

10. An Add Variable dialog appears

1. For the Variable MagMagMagMag::::

Value: 30A30A30A30A

11. Select OKOKOKOK

12. Select the sheets Section4, Section4, Section4, Section4, 

Section5, Section6Section5, Section6Section5, Section6Section5, Section6 from the

object tree.

13. Select Maxwell > Excitations > Maxwell > Excitations > Maxwell > Excitations > Maxwell > Excitations > 

Assign > CurrentAssign > CurrentAssign > CurrentAssign > Current…………

1. Base Name: PhaseBPhaseBPhaseBPhaseB

2. Value: MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

14. Select OKOKOKOK
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Create the Terminals and Define the Sources (continued): 

15. Select the sheets Section7Section7Section7Section7, Section8Section8Section8Section8, Section9Section9Section9Section9 from the object tree.

16. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

17. The Current Excitation dialog appears.

1. Base Name: PhaseCPhaseCPhaseCPhaseC

2. Value: ----0.5*0.5*0.5*0.5*MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

18. Select OKOKOKOK

Create the Region Object

1. Select Draw > RegionDraw > RegionDraw > RegionDraw > Region

1. A Region dialog box opens up.

2. Fill in the information as follows:

Padding Data: SixSixSixSix

X: 400, 400400, 400400, 400400, 400

Y: 100, 100100, 100100, 100100, 100

Z: 150, 150150, 150150, 150150, 150

3. Select OKOKOKOK

2. Select OKOKOKOK



5.2

Example (Magnetostatic) – Inductance Calculation

5.2-12Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

Inductance Calculation Defining Equations

Inductance in a magnetostatic simulation can be defined as

where λ is the flux linkage for an individual coil, and I is the current.

This inductance is the apparent inductance – it defines the ratio of flux linkage to 

current in one coil.

The inductance of a coil can also be defined by the energy storage as

where the energy is determined by the magnetic flux density and field intensity in 

the solution space.

This energy storage calculation is what determines the inductance values in the 

matrix.  The on-diagonal elements (L
11

, L
22

, etc.) are determined by exciting the 

coils individually and finding the energy from the B and H fields for each 

individual case.  The off-diagonal elements (L
12

, L
21

, L
13

, etc.) are determined 

from a combination of the B and H fields from the individually excited cases.  The 

following is the exact defining equation for the inductance calculation

where it is assumed that one ampere is flowing through the respective coils.

For nonlinear materials, the value of the inductance obtained from these 

calculations is only valid for the specific source currents.  If any of the source 

currents change, the characteristics of the field solution will change as well as the 

inductance of each coil (less change when in a linear region, greatest change 

when moving from the linear region to a saturated region).

If only linear materials are used, the value of the inductance will be valid for any 

value of source currents.

Ω⋅= ∫ dHBL j
i

ij

rr

2

2
2

IdHB

IWL

∫ Ω⋅=

×=
rr

L

L

L

++=

++=

2221212

2121111

ILIL

ILIL

λ

λ



5.2

Example (Magnetostatic) – Inductance Calculation

5.2-13Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

Inductance Calculation Methodology

The inductance calculation is performed after the field solution and depends on 

the values of the field solution at every point in the solution space because it 

requires an energy integral in the entire solution space.

After the field solution is completed, the relative permeability values are “frozen”.  

Then, one ampere is sequentially excited in each coil, and a field solution is 

performed with the frozen permeabilities.  With these field solutions, the energy 

integral is performed and the inductance is obtained as described previously.

The inductance obtained in this manner is the inductance per turn^2 (referred to 

as the nominal inductance in the software) and is the apparent inductance 

(determined by the flux linkage/current operating point in the graphic below).

Incremental inductance can be obtained by performing energy perturbation 

techniques (changing the source currents and finding the slope).
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Inductance Calculation Process

Initial Setup

Adaptive Solution

Nonlinear Convergence

(Changing permeability)

Refine Mesh

Converged or Number of Passes

Permeability is Frozen

Inductance Matrix Solution

(Linear solution process)

Matrix Post Processing

Solution Convergence ?
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Inductance Calculation Post Processing

The nominal inductances that are computed by the solver are returned in units of 

Henries/turns^2.  In order to return each inductance in units of Henries, the 

number of turns for each coil must be specified at some point.  Also, the 

inductance matrix can be grouped to represent windings in series, and a factor 

can be included if the winding is made up of parallel branches. These are all 

considered post-processing, and they can help to return meaningful quantities.

The post processed inductances are calculated as follows:

The first step is to find the coil inductances from the nominal inductances by 

multiplying by the number of turns in each coil (or number of turns squared for 

self inductances).

The next step is to group the series inductances by adding up all the inductances 

in the block (i.e. if conductors 1 through N are grouped, then add up the N by N 

block of inductances to obtain the grouped self inductance – the same process is 

followed for grouped mutual inductances).

The final step is to take into account parallel branches by dividing by the number 

of branches squared.  The inductance decreases with parallel branches because 

of the reduced number of turns per branch.

nomijjiij LNNL
_

=
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groupi groupj

ijgroup LL
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bLL groupbranched =
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Create a Solution Setup

1. Select Maxwell > Analysis Setup > Add Solution Setup Maxwell > Analysis Setup > Add Solution Setup Maxwell > Analysis Setup > Add Solution Setup Maxwell > Analysis Setup > Add Solution Setup …………

1. In the General tab:

1. Set Maximum Number of Passes to 10

2. Set Percent Error to 1

2. In the Solver tab:

1. Set Nonlinear Residual to 0.001

3. Select OKOKOKOK

The Nonlinear Residual is important in simulations with nonlinear materials that 

operate outside of the linear region.  Increasing the number will make the 

simulation run faster, decreasing the number will force the nonlinear solver to 

more precisely find the nonlinear B-H operating points within the steel (or other 

nonlinear magnetic material).  

It is often the case with saturated nonlinear materials that theIt is often the case with saturated nonlinear materials that theIt is often the case with saturated nonlinear materials that theIt is often the case with saturated nonlinear materials that the Nonlinear Residual Nonlinear Residual Nonlinear Residual Nonlinear Residual 

will need to be reduced to obtain accurate results.will need to be reduced to obtain accurate results.will need to be reduced to obtain accurate results.will need to be reduced to obtain accurate results.
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Create Matrix Parameters

1. Select Maxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > Matrix…………

1. In the Setup tab, check the boxes to Include all the Sources (or click on the 

word Include to automatically check all the boxes).

2. In the Post Processing tab, set the turns for each source to 30303030

3. Select PhaseA_1, PhaseA_2, PhaseA_1, PhaseA_2, PhaseA_1, PhaseA_2, PhaseA_1, PhaseA_2, and PhaseA_3PhaseA_3PhaseA_3PhaseA_3 and select Group Group Group Group ---->>>>

(Use CtrlCtrlCtrlCtrl or ShiftShiftShiftShift to select multiple items.)

4. Select PhaseB_1, PhaseB_2,PhaseB_1, PhaseB_2,PhaseB_1, PhaseB_2,PhaseB_1, PhaseB_2, and PhaseB_3PhaseB_3PhaseB_3PhaseB_3 and select Group Group Group Group ---->>>>

5. Select PhaseC_1, PhaseC_2, PhaseC_1, PhaseC_2, PhaseC_1, PhaseC_2, PhaseC_1, PhaseC_2, and PhaseC_3PhaseC_3PhaseC_3PhaseC_3 and select Group Group Group Group ---->>>>

6. Rename Group1 to PhaseAPhaseAPhaseAPhaseA

7. Rename Group2 to PhaseBPhaseBPhaseBPhaseB

8. Rename Group3 to PhaseCPhaseCPhaseCPhaseC

9. Leave Branches set to 1 for each Group

This setup says that each source has 30 turns and that the sources on each leg 

are connected in series (as far as the post-processing is concerned).
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Create Matrix Parameters (continued)

We will create a second Matrix Parameter to show what the settings signify.

2. Select Maxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > Matrix…………

1. In the Setup tab, check the boxes to Include all the Sources (or click on the 

word Include to automatically check all the boxes).

2. In the Post Processing tab, set the turns for each source to 15151515

3. Select PhaseA_1, PhaseA_2, PhaseA_1, PhaseA_2, PhaseA_1, PhaseA_2, PhaseA_1, PhaseA_2, and PhaseA_3PhaseA_3PhaseA_3PhaseA_3 and select Group Group Group Group ---->>>>

4. Select PhaseB_1, PhaseB_2,PhaseB_1, PhaseB_2,PhaseB_1, PhaseB_2,PhaseB_1, PhaseB_2, and PhaseB_3PhaseB_3PhaseB_3PhaseB_3 and select Group Group Group Group ---->>>>

5. Select PhaseC_1, PhaseC_2, PhaseC_1, PhaseC_2, PhaseC_1, PhaseC_2, PhaseC_1, PhaseC_2, and PhaseC_3PhaseC_3PhaseC_3PhaseC_3 and select Group Group Group Group ---->>>>

6. Rename Group1 to PhaseAPhaseAPhaseAPhaseA

7. Rename Group2 to PhaseBPhaseBPhaseBPhaseB

8. Rename Group3 to PhaseCPhaseCPhaseCPhaseC

9. Set Branches to 3 for each Group

This setup says that each source has 15 turns in 3 branches of 5 turns each (with 

twice the current in each turn as for the 30 turn case) and that the sources on 

each leg are connected in series (as far as the post-processing is concerned).
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Save the Project

1. Select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As

2. From the Save As window, type in 3phase_inductor3phase_inductor3phase_inductor3phase_inductor

3. Click on the Save Save Save Save button

Check the Validity of the Model

Select the menu item Maxwell > Validation CheckMaxwell > Validation CheckMaxwell > Validation CheckMaxwell > Validation Check, or click on the        icon

The problem won’t solve if there are errors (errors are denoted by a red X), but it 

will solve if all the validations return a green check or a warning (warnings are 

denoted by a yellow triangle, and should be noted, but can often be safely 

ignored).

Analyze 

Select the menu item Maxwell > AnalyzeMaxwell > AnalyzeMaxwell > AnalyzeMaxwell > Analyze, or click on the        icon

This should take about 10 minutes to solve on a standard computer (such as a 

fast laptop or standard desktop), and about 5 minutes on a fast computer.
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Inductance Matrix Solutions

Open up the matrix solution data by selecting Maxwell > Results > Solution DataMaxwell > Results > Solution DataMaxwell > Results > Solution DataMaxwell > Results > Solution Data

The first display that appears (by default) is the non-post processed data for 

Matrix2

Check the box marked Post ProcessedPost ProcessedPost ProcessedPost Processed to see the results.

Notice that the results are symmetric in both axes as we would expect.

Notice that the mutual inductances are negative.  It is important to note that the 

direction of the current used for the mutual inductances is determined by the 

direction of the arrow for each excitation.
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Inductance Matrix Solutions (continued)

Change to Matrix1Matrix1Matrix1Matrix1 solutions by clicking on the pull-down menu with Matrix2.

Notice that the results change to reflect twice the turns and one-third the 

branches (2^2 * 3^2 = 36 times the previous inductance value).

Remember that by increasing the turns, the current in each turn is decreased to 

keep the total ampere-turns constant – this is very important for nonlinear 

materials.  The solutions apply only for this value of current.

If you were to compare the non-post processed results for both matrices, you 

would see that these values are the same.

Change the Solution Type from Inductance to Flux Linkage to see either the Post 

Processed or nominal flux linkage values.
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Results and Interpretations

These results are being obtained from a magnetostatic simulation with arbitrary 

constant current inputs defined for each leg.  The notation used was in terms of 3 

phases, which might imply that this is an AC inductor of some sort.  The modeling 

of AC currents in a magnetostatic simulation can sometimes be valid for 

instantaneous values (of force and inductance), but the requirements are that 

eddy currents do not effect the solution (either a low frequency source or low loss 

materials).  The other two options available in the Maxwell software are eddy 

current simulations (which allows AC sources, but does not allow nonlinear 

materials), and transient simulations (which allows the study of nonlinear and AC 

phenomena).

This type of magnetostatic simulation would also be valuable for an Equivalent 

Circuit Extraction (again, eddy currents should be negligible) - this would require 

each phase to be excited as a variable, and run as a full parametric simulation 

including all phases across all possible current values (at least 5^3 variations to 

see any nonlinear behavior).  Notice that if you do an equivalent circuit extraction 

of the inductance, the flux values automatically take into account the grouping 

and other post-processing values specified in the matrix parameter.

Other magnetostatic results can be obtained from this simulation, such as force 

on the Core_I object and magnetic field in the steel (is it saturating?).

Remember that this simulation uses nonlinear materials, so all of the solutions 

are only valid for this specific set of excitations.  If you were to change the input  

currents, then you will have to solve again to see how the inductance and other 

results change.

Another important note is that although we included 2 matrix parAnother important note is that although we included 2 matrix parAnother important note is that although we included 2 matrix parAnother important note is that although we included 2 matrix parameters, this is ameters, this is ameters, this is ameters, this is 

not necessary to see differently postnot necessary to see differently postnot necessary to see differently postnot necessary to see differently post----processed results.processed results.processed results.processed results. You can edit the post-

processing characteristics of the matrix after having solved the problem, and the 

results will adjust to reflect the changes without needing to resolve.  The only 

time that you would need multiple matrices is if one matrix or the other did not 

include all the coils.  By using two matrices, the inductance calculation was By using two matrices, the inductance calculation was By using two matrices, the inductance calculation was By using two matrices, the inductance calculation was 

performed twice, lengthening the simulation.performed twice, lengthening the simulation.performed twice, lengthening the simulation.performed twice, lengthening the simulation. The point of this example was to 

show that multiple matrix parameters can be defined – not to suggest using 

multiple matrix parameters.
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Create a Symmetry Model

1. Right-click on MaxwellDesign1MaxwellDesign1MaxwellDesign1MaxwellDesign1 in the project tree (this is the design name).

2. Choose CopyCopyCopyCopy from the menu.

3. Right-click on 3phase_inductor3phase_inductor3phase_inductor3phase_inductor in the project tree (this is the project name).

4. Choose PastePastePastePaste from the menu.

5. You now have a new design in your project that has the same setup as the first 

design.

Remember to double-click on the design name to switch from one design to 

the other!

6. Select all the visible objects (except the Region) by typing Ctrl + ACtrl + ACtrl + ACtrl + A when within 

the 3D modeler window (or select them all in the object tree).

7. Select 3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split………… to split the model at the YZ plane.

1. In the Split window that appears, choose the following:

1. Split Plane : YZYZYZYZ

2. Keep Fragments: Positive sidePositive sidePositive sidePositive side

3. Split Objects: Split entire selectionSplit entire selectionSplit entire selectionSplit entire selection

2. Select OK

8. Expect to see some errors and warnings that the sheet objects were deleted.  

There are options in the Split command to keep the sheet objects when splitting 

the solids, but we will not need the sheets for a symmetry simulation.
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Create a Symmetry Model (continued)

9. Select Draw > RegionDraw > RegionDraw > RegionDraw > Region to edit the region object.

1. Change the padding percents as follows:

+X: 800

-X: 0

2. Select OK OK OK OK to accept.

10. The entire geometry is now on the

positive side of the YZ plane.

11. Adjust the visibility by going to

View > Active View VisibilityView > Active View VisibilityView > Active View VisibilityView > Active View Visibility…………

12. In the 3D Modeler tab, find the

RegionRegionRegionRegion object and deselect Visibility.

13. Choose OKOKOKOK to accept.

14. Rotate the geometry to look at the 

split  plane of the core and coils.

15. Type ffff in the 3D modeler to switch to face selection mode (type oooo to switch back 

to object selection) – face selection can also be found in Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces.

16. Select the right-most coil faces on the YZ plane.

(Use CtrlCtrlCtrlCtrl to select multiple items graphically.)

17. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

18. In the Current Excitation dialog, enter the following:

1. Base Name: PhaseA_inPhaseA_inPhaseA_inPhaseA_in

2. Value: ----0.5*0.5*0.5*0.5*MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

19. Select OKOKOKOK to accept the excitation.
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Create a Symmetry Model (continued)

20. Select the next right-most coil faces on the YZ plane.

(Use CtrlCtrlCtrlCtrl to select multiple items graphically.)

21. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

22. In the Current Excitation dialog, enter the following:

1. Base Name: PhaseA_outPhaseA_outPhaseA_outPhaseA_out

2. Value: ----0.5*0.5*0.5*0.5*MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

4. Click Swap DirectionSwap DirectionSwap DirectionSwap Direction so that the arrow

is pointing in the negative X direction.

23. Select OKOKOKOK to accept the excitation.

24. Continue with the next leg by selecting the next 3 

coil faces on the YZ plane.

25. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

26. In the Current Excitation dialog, enter the following:

1. Base Name: PhaseB_inPhaseB_inPhaseB_inPhaseB_in

2. Value: MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

27. Select OKOKOKOK to accept the excitation.

28. Now select the 3 return faces of the middle coil.

29. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

30. In the Current Excitation dialog, enter the following:

1. Base Name: PhaseB_outPhaseB_outPhaseB_outPhaseB_out

2. Value: MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

4. Click Swap DirectionSwap DirectionSwap DirectionSwap Direction so that the arrow 

is pointing in the negative X direction.

31. Select OKOKOKOK to accept the excitation.
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Create a Symmetry Model (continued)

32. Continue to the last leg by selecting the next 3

coil faces on the YZ plane.

33. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

34. In the Current Excitation dialog, enter the following:

1. Base Name: PhaseC_inPhaseC_inPhaseC_inPhaseC_in

2. Value: ----0.5*0.5*0.5*0.5*MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

35. Select OKOKOKOK to accept the excitation.

36. Finish by selecting the 3 return faces of the last coil.

37. Select Maxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > CurrentMaxwell > Excitations > Assign > Current…………

38. In the Current Excitation dialog, enter the following:

1. Base Name: PhaseC_outPhaseC_outPhaseC_outPhaseC_out

2. Value: ----0.5*0.5*0.5*0.5*MagMagMagMag

3. Type: StrandedStrandedStrandedStranded

4. Click Swap DirectionSwap DirectionSwap DirectionSwap Direction so that the arrow 

is pointing in the negative X direction.

39. Select OKOKOKOK to accept the excitation.

Creating Matrix Parameters

Now that the excitations are redefined, the matrix has to be redefined.  The 

matrices were deleted when the old excitations were deleted (which were deleted 

when the sheet objects were deleted during the split operation).

When matrix parameters are defined, a check will be performed for proper 

conduction paths and for terminals correctly defined across a cross-section of the 

conduction paths.  Several errors can appear when defining a matrix, and these 

often have to do with the definition of the conducting objects or the excitation.

The excitations that appear in the matrix setup, are those excitations that are 

pointing into the conductor.  So, for a symmetry model that requires two 

excitations per conductor, only one excitation per conductor will be listed in the 

matrix setup – this excitation will be the one pointing into the modeled conductor.
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Create Matrix Parameters

1. Select Maxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > MatrixMaxwell > Parameters > Assign > Matrix…………

1. In the Setup tab, check the boxes to Include all the Sources (or click on the 

word Include to automatically check all the boxes).

2. In the Post Processing tab, set the turns for each source to 30303030

3. Select PhaseA_in_1, PhaseA_in_2, PhaseA_in_1, PhaseA_in_2, PhaseA_in_1, PhaseA_in_2, PhaseA_in_1, PhaseA_in_2, and PhaseA_in_3PhaseA_in_3PhaseA_in_3PhaseA_in_3 and select Group Group Group Group ---->>>>

(Use CtrlCtrlCtrlCtrl or ShiftShiftShiftShift to select multiple items.)

4. Select PhaseB_in_1, PhaseB_in_2,PhaseB_in_1, PhaseB_in_2,PhaseB_in_1, PhaseB_in_2,PhaseB_in_1, PhaseB_in_2, and PhaseB_in_3PhaseB_in_3PhaseB_in_3PhaseB_in_3 and select Group Group Group Group ---->>>>

5. Select PhaseC_in_1, PhaseC_in_2, PhaseC_in_1, PhaseC_in_2, PhaseC_in_1, PhaseC_in_2, PhaseC_in_1, PhaseC_in_2, and PhaseC_in_3PhaseC_in_3PhaseC_in_3PhaseC_in_3 and select Group Group Group Group ---->>>>

6. Rename Group1 to PhaseAPhaseAPhaseAPhaseA

7. Rename Group2 to PhaseBPhaseBPhaseBPhaseB

8. Rename Group3 to PhaseCPhaseCPhaseCPhaseC

9. Leave Branches set to 1 for each Group

This setup says that each source has 30 turns and that the sources on each leg 

are connected in series (as far as the post-processing is concerned).
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Check the Validity of the Model

Select the menu item Maxwell > Validation CheckMaxwell > Validation CheckMaxwell > Validation CheckMaxwell > Validation Check, or click on the        icon

The problem won’t solve if there are errors (errors are denoted by a red X), but it 

will solve if all the validations return a green check or a warning (warnings are 

denoted by a yellow triangle, and should be noted, but can often be safely 

ignored).

Analyze 

Select the menu item Maxwell > AnalyzeMaxwell > AnalyzeMaxwell > AnalyzeMaxwell > Analyze, or click on the        icon

This should take about 5 minutes to solve on a standard computer (such as a fast 

laptop or standard desktop), and about 3 minutes on a fast computer (half the 

time!).

This half model runs twice as fast – taking advantage of symmetries can have an 

even greater effect on larger models!
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Inductance Matrix Solutions

1. Open up the matrix solution data by selecting Maxwell > Results > Solution DataMaxwell > Results > Solution DataMaxwell > Results > Solution DataMaxwell > Results > Solution Data

2. Check the box marked Post ProcessedPost ProcessedPost ProcessedPost Processed to see the results.

Notice that the results are half the value that we obtained for the full model.  This 

is very important to remember when using these values.  The halved results are 

consistent for other parameters and properties as well (i.e. torque, total energy, 

etc.)

If these values are used to create an Equivalent Circuit Extraction, remember to 

use a scaling factor of 2 to account for the symmetry.

3. Change the Solution Type from Inductance to Flux Linkage.

Notice that these numbers are halved as well.


