Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Any FireFox experts here?

  1. Mar 22, 2012 #1

    NascentOxygen

    User Avatar

    Staff: Mentor

    I had this problem with FF 9 so I upgraded to FF 11 and the problem remains. :grumpy:

    When editing in the Advanced Edit box, there's a toolbar at the top from where one can select colors, smileys, set a subscript, or superscript, etc. None of these is clickable for me. I can pull down the menus for selecting fonts and sizes, but nothing else, and those settings don't make it into my posting, AFAIK. The mouse doesn't even change shape when I rest it on Colors, Smilies, Attachments, Undo, B, I, U, etc. I've memorized a few smilies, so I am still able to insert some into my posts.

    The problem is almost certainly to do with a setting I've made somewhere in the browser preferences. I just can't figure out where. I'm using FF on linux.

    Probably attributable to the same cause, is the fact that I cannot use wolframalpha. If I go to this URL http://www.wolframalpha.com I see a completely blank page. If I click on a precomposed link in someone's post, wolframalpha sits spinning interminably on Computing ....

    Apart from the wolframalpha site, I've noticed no problems in using this FF at any other sites.

    Can anyone clear up this mystery for me https://www.physicsforums.com/images/icons/icon5.gif [Broken]
     
    Last edited by a moderator: May 5, 2017
  2. jcsd
  3. Mar 22, 2012 #2

    robphy

    User Avatar
    Science Advisor
    Homework Helper
    Gold Member

    Is Javascript somehow being disabled?
     
  4. Mar 22, 2012 #3
    You've (accidentally) disabled JavaScript. I tested it in my own browser (Firefox, Linux x86_64 here), and noticed the blank page on Wolfram|Alpha, too. To enable Javascript, click Edit - Preferences. Choose the 'Content' tab and enable 'Enable JavaScript'. If that doesn't solve the problem, you might be using a NoScript plugin or something similar that blocks scripts from running.
     
  5. Mar 22, 2012 #4

    NascentOxygen

    User Avatar

    Staff: Mentor

    Enable Javascript has been ticked all along. Apart from download helper, the only add on is AdblockPlus, so I disabled it.

    Just had a look at EnableJavascript>Advanced settings and I didn't have Raise or Lower Windows ticked. So I ticked it, but that brought no immediate change. Maybe after a restart? Will see tomorrow.

    Thanks.
     
  6. Mar 22, 2012 #5

    NascentOxygen

    User Avatar

    Staff: Mentor

    A restart made no difference. But I found that faking the user agent header to masquerade as an iPhone does allow me to use the mobile site. So I think it's something to do with the user agent header. (I have to fake it to get into another site, and maybe wolframalpha doesn't like me resetting it. I've probably lost a few characters from the string in the process.)

    So I'll reinstall Firefox and get its correct user agent string and hope that works. Thanks for all advice!
     
  7. Mar 26, 2012 #6
    NascentOxygen, I had this same issue for a while. If I remember correctly, what fixed this was to allow popup windows for this website. Depending on if you are mac or pc, go into either mac "preferences" or pc "options" and click "content", click exceptions and add PF. If this doesn't solve the problem, I will try harder to figure out what I did, but I do believe this fixed it for me.
     
  8. Mar 26, 2012 #7

    PAllen

    User Avatar
    Science Advisor
    Gold Member

    Yes, physics forums is the only site I currently need a popup exception for in FF. I do not need it for the WolframAlpha site. I actually do use Noscript and other addons, but have lots of exceptions for those.
     
  9. Mar 26, 2012 #8

    NascentOxygen

    User Avatar

    Staff: Mentor

    Thank you for your suggestion, Ms Music. But popup windows have been allowed all along. (Incidently, at other forum sites I can click on an icon in the toolbar and the menu pops out and I can select from it okay.)

    I notice I get the mobile version of facebook, too, so facebook is practically unusable for me.

    So three issues: no toolbar menus, an empty page at wolframalpha, and bland facebook page. I do think it's something I caused by changing the user agent header. I have run the live CD and obtained the correct original header and set it to back to that, but Firefox is very unforgiving. :devil:

    I don't understand how when sites are given this user agent header they still don't like me! :mad:
    Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
     
  10. Mar 27, 2012 #9

    I like Serena

    User Avatar
    Homework Helper

    Perhaps this is a good time to experiment with other browsers?
    For instance Chrome?
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Any FireFox experts here?
  1. Firefox Plugin (Replies: 5)

  2. Firefox doesn't work (Replies: 12)

Loading...