Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Canon Driver woes

  1. Nov 16, 2008 #1


    User Avatar
    Gold Member

    I don't know where else to turn.

    I've got a Canon SD630 that was working tickety-boo until my XP-reinstall. It used to downlaod my pix right to a date-named folder as soon as I turned my camera on. It was a b eautiful thing to behold.

    Now, after my reinstall, I can't my pictures at all. Any 'get picture' mpthod I use tells me 'The scanner or camera is in use by another progam. Try again later.'

    I've tried
    - rebooting XP in safe mode to defeat any conflicting drivers (when I do this, my camera doesn't come up as a drive at all.)
    - the 'transfer' button on the camera (nothing)
    - looking for drivers online, starting with Canon. They don't even list an XP driver. Though they do list ME and 98 drivers (which didn't work).
    - Driver Detective, which reports that my Distigal Still Camera driver is, in fact, up-to-date.
    - forums to see if other people have had the same problem. So far, I've found lots of people who've had the same problem, but none whose method worked for me.

    Last edited: Nov 16, 2008
  2. jcsd
  3. Nov 16, 2008 #2
    Mmm, could try Picasa, which has an import function that MIGHT help, but I dunno.
  4. Nov 16, 2008 #3


    User Avatar

    Staff: Mentor

    How about windows explorer? I never liked extra software anyway.

    However, if the camer comes up as a drive, then it isn't a driver issue, it is a software issue. It should just be a matter of reinstalling whatever software you were using to automatically retrieve the pictures.
    USB storage is integrated into Win 2k and above. You don't need separate drivers for it.
  5. Nov 16, 2008 #4


    User Avatar

    Staff: Mentor

    My digital camera didn't require software, I just plugged into the USB port, it recognized my camera, and voila.

    It did come with backup software incase there was a need.

    Dave, did you save your installation disc?
  6. Nov 16, 2008 #5
    i would check with the computer manufacturer for USB drivers specific to your machine, especially if it's a laptop computer. laptops are a PITA.

    or switch to ubuntu and import with F-Spot
  7. Nov 16, 2008 #6
    lol @ proton's suggestion of switching an entire OPERATING SYSTEM, to get PICTURES.
  8. Nov 16, 2008 #7


    User Avatar
    Science Advisor
    Homework Helper

    USB is a master slave protocol.
    Cameras can either be master - to allow them to connect directly to a printer, or slave to look like a disc drive. There may be amenu option in the camera to switch it.
    On XP you don't need a driver to connect to a USB disk.

    Possibles are you have lost the ability to mount USB disks somehow, do you have a USB key you an test ? Or more likely, there is an aplication set as the plug and play autostart for that particular camera and the app has been deleted/damaged.

    I can't remember the app to reset autoplay - might be in tweakui.
  9. Nov 17, 2008 #8
    You will also find that putting the SD card directly in the computer will download the pictures a bit faster as well.

    Alternately, I had a SD card crashed losing a bunch of nice shots. If that's the case, the computer may not recognise the camera as well.
    Last edited: Nov 17, 2008
  10. Nov 17, 2008 #9


    User Avatar
    Gold Member

    Yeah, I may have to try that. But I'd really like to get back whatever wizard just automagically downloaded my pix the moment I switched the camera on.

    Yeah, Explorer shows (and even identifies) the camera, but it's empty - no data available.

    Yeah, this has always bugged me. My system at work has always been unable to read my camera at all. The downside to integrating a function so you don't have to install anything else to get it to work - is that it means when it doesn't work, you can't install anything to get it to work.

    Yes, it di for me on my original system (before XP reinstall) too.

    I'll look around, but frankly, it seems to me that if there were driver to get it to work, I'd have found it online somewhere.

    Yes, it connects, but comes up empty.
    (I can still see the pix on my camera, so: no, the camera isn't merely empty)

    No, USB is fine.


    I've been reading about this. I downloaded Autoplay Fixer from Microsoft. To operate, it needs to be pointed at a drive. My camera will not come up as a drive in Autoplay Fixer's window, even though it is listed as a drive in Explorer.

    I'd need to buy a card reader. Great, one more gadget that I need to collect around me when I'm trying to use my laptop. :cry:

    Alternately, I had a SD card crashed losing a bunch of nice shots. If that's the case, the computer may not recognise the camera as well.[/QUOTE]Didn't happen.

    One thing that's strange is that, sometimes when I turn the camera on (I'm not sure what decides when) a dialogue pops asking what application I'd like to run to perform this action (which would be perfect) except the list of applications is empty.
  11. Nov 17, 2008 #10
    i don't find that strange at all, seems the norm. i assume it allows you to browse directories and select the executable for your software.

    the other thing, have you tried starting your camera software before connecting the camera?
  12. Nov 17, 2008 #11


    User Avatar

    Staff: Mentor

    What OS does that computer run? If you are having problems on more than one computer, that points to a camera or disk problem, not a computer software problem. If I'm understanding you correctly, you are seeing a drive letter in windows explorer, but when you click on it, there is nothing on the disk. Do you get a message asking if you want to format it? That's a potential indicator of a problem with the flash disk.
    Try the card on someone else's card reader first. It may be that you've damaged the card and just need to replace it.
  13. Nov 17, 2008 #12


    User Avatar
    Gold Member

    What's strange is that the list is empty.

    There is no camera software. I can't find a driver for it - at least, not online.

    Maybe my assumption is wrong: that any CD that came with the camera would merely provide a driver (in addition to a bunch of other extraneous stuff, but the driver being the critical piece.) Thus, downloaded driver trumps driver from CD.

    I'll hunt down the CD.
  14. Nov 20, 2008 #13


    User Avatar
    Gold Member

    Well, after a few days of back & forth with Canon Tech Support, they suggested I call them. After the usual checks, he immediately targeted my Printer Driver. As soon as I turned it off, my camera worked fine.

    I guess my printer drivers from the CD are a little out of date.
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Canon Driver woes
  1. InterWeb speed woes (Replies: 34)

  2. Driver Software (Replies: 1)

  3. GPS Woes (Replies: 5)

  4. Video Drivers (Replies: 4)

  5. Windows update woes (Replies: 3)