Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Connecting laptop to TV

  1. Feb 7, 2009 #1
    I am trying to connect my laptop to my tv. My laptop has a port (if that's the right word to use here) to connect an S-cable to it, but my TV doesn't (it only takes the red, yellow, and white cables).

    I bought this an adapter to allow my TV to take in S-cables. This is the product description so you know exactly what I got:

    "Use this handy device to connect up to 4 S-video-equipped audio/video components to your TV or home theater receiver. Works with DVD players, VCRs, video-game systems and any other S-video- equipped components.
    Product Features

    * Turns your single S-video connection into 4
    * Converts RCA signal into S-video signal
    * Use selector switch to choose the component you want to use
    * 1/8" stereo audio jack accommodates the use of multimedia speakers or headphones"


    So this is the setup I have:

    I connected the laptop and the adapter with the s-cable. I plugged it into the port on the adapter that says "S In 2". Then I plugged the red, white, and yellow cables into the adapter where it says "Out 1". The other side of that cable goes into the TV where it says "Video In".

    However, the laptop is saying that the TV is not connected. I know my laptop can support multiple monitors though.

    Any tips?


    EDIT: The S video port on my laptop is 7-pinned while the cable is 4-pinned. The port on the adapter is also 4 pinned. Would this make a difference?
     
    Last edited: Feb 7, 2009
  2. jcsd
  3. Feb 7, 2009 #2

    mgb_phys

    User Avatar
    Science Advisor
    Homework Helper

    An S video only has 4pins (color, brightness 2*ground) a PS2 mouse plug has 6 plus a centre notch, are you sure it is an s-video?
     
  4. Feb 7, 2009 #3
    The cable has 4 pins, and the box said s-cable, so it must be an s-cable (although it ALSO said monster cable). The port on the laptop that I'm plugging it into looks like this:

    . . .
    . . . .

    Those are what the holes for the pins look like. It also has two small notches, one at the very top and one at the very bottom. If it makes any difference, I have a compaq presario v2000. Here are its specs regarding ports:

    * PMCIA slot
    * USB 2.0 port
    * Phone line and Ethernet ports
    * Expansion base port (expansion base is sold separately)
    * VGA monitor video output
    * 6-in-1 memory card reader
    * Firewire port
    * Two USB 2.0 ports
    * S-Video output


    Though I only have two USB ports...
     
  5. Feb 7, 2009 #4

    mgb_phys

    User Avatar
    Science Advisor
    Homework Helper

    Apparently you can get 7pin S-video ports on laptops that also have component built in.
    I have never seen an S-video to component adaptor.
    An s-video to composite is easy enough (it just connects chrome+lum)

    The laptop won't necessarily detect the presence of a-video source, make sure the driver is set to enable s-video, it's also worth checking that it is tunred on in the bios.
     
  6. Feb 7, 2009 #5
    It seems like everything is okay. I assumed that the laptop would detect the video-source because whenever I hook up my other monitor to it, it picks it up right away.

    I'm thinking of returning the hardware back to the store and getting a 7-pinned s-cable to component cable.

    Does the fact that the cable is 4 pinned and the port has 7 "holes" for the pins make a difference?
     
  7. Feb 7, 2009 #6

    mgb_phys

    User Avatar
    Science Advisor
    Homework Helper

    4pin s-video in the 7pin socket is no problem, the extra holes aren't used.
    Unless one came with your laptop you wouldn't find a 7pin svideo-comp, just a 4pin to single RCA jack.
    You can get one like this at a dollar store, and then use a regular comp cable

    7_Pin_S_Video_to_RCA_AC_Cable_Adapter_Converter.jpg

    There is a signal pin on a VGA cable so that the monitor can tell your computer things (power status and max res) there isn't any extra data on svideo
     
  8. Feb 7, 2009 #7
    "There is a signal pin on a VGA cable so that the monitor can tell your computer things (power status and max res) there isn't any extra data on svideo"

    Hmm...Maybe my TV isn't on the correct input either. The only thing is that there are 99 different channels to check and the channel up and down button doesn't scroll through the channels, you have to individually channel in each number. I can't find the manual for it and there exists no manual online.

    By the way, I have a satellite receiver plugged into the back of the TV (not using the component cable, using a another type of cable). Could this be causing a conflict? I haven't tried the setup with the satellite unplugged.
     
  9. Feb 7, 2009 #8
    Okay. Thinking this through more, whenever I plug component cables into the "Video In" part of my TV, the channel that it's displayed on is always channel 3. So I go to channel 3 and all I'm seeing is a black screen.

    I've also put on a setting on my computer that "forces" the detection of the TV. But, all I'm seeing is a black screen. Any ideas on how to fix this? I'm playin' around with the settings but no luck.

    EDIT: I have two settings, one where each monitor is displayed one at a time (the one not being displayed turns black) and one where both are displayed simultaneously. I put it on the one where each one is displayed one at a time and I set the television to be displayed. The laptop screen turned black but then after about 30 seconds without me touching anything, the laptop screen turned back on. Could this mean that it turned back on maybe because it wasn't outputting to the television properly?
     
    Last edited: Feb 7, 2009
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook