Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Crazy Problems

  1. Mar 12, 2008 #1
    I'm not really new to Digital Electronics, but this is confusing the crap out of me. My school's started a DE class and at the moment we're getting all our equipment worked out and stuff, but for some reason NONE of our IC's work. We're using a 9-volt batter with a 7805 regulator for 5 volts out (measures up to about 4.2). When we connect the chips to the power, they go haywire. I'm mainly using a 7408 (Quad 2-AND) to test with, and it doesn't matter if A and B are high or low, Y is always high. It doesn't even matter if the chip is grounded, as long as VCC is high, there is an output. What gives?

    We have two work-stations that have their own 5-25V power supplies in them, and they work fine. By now you've probably come to my conclusion that it's the 9 volt batteries or the 7805's. But here's the kicker, I've hooked the non-powered breadboards up to the supplies on the workstations, and it STILL has this problem. So the only other thing I see is that that breadboards are messed up...but All 20 of them??
     
  2. jcsd
  3. Mar 12, 2008 #2

    berkeman

    User Avatar

    Staff: Mentor

    When things get confusing like that, it's usually good to just start working your way through the whole circuit, probing the voltages on each of the pins with an oscilloscope. Your Vcc should absolutely not be 4.2V at the output of a 7805 linear regulator, so check that the pinout is being used correctly, and that the input-output voltage differential obeys the requirement for the 7805 (I think it requires at least 7V in to make 5V out, but I forget offhand).

    Once you get the correct 5V on the board, then check the Vcc, GND and inputs and outputs of some of the gates, with good solid inputs, and no floating inputs anywhere allowed. Check the pinout of the chips, and make sure that any bridging connections for Vdd and GND are not missing from the breadboard. Most plug-board type breadboards have subsections, with the need to bridge Vdd and GND over to each subsection.

    Finally, if Vdd and GND are correct, and you seem to still have some gates that are misbehaving, replace the gate ICs to see if that fixes the problem. It's likely that somebody hooked Vcc and GND up backwards or something to the now-failing boards, and blew up the logic chips.

    Let us know what you find.
     
  4. Mar 12, 2008 #3
    Why would it not be at around 4.2v if I'm using a 9v batter that's probably drained slightly? Or do you mean that it should be higher? I measured it with three different batteries, and the outputs never went above 4.5...the highest voltage from a battery was 8.08v, the lowest was 7.4 I believe, on the chip I mention below.

    But anyway, I've gone over the whole thing several times...there's no current going into the inputs, there's current coming Out of the outputs, and into an LED. There is no readable voltage leaking vertically (from Row A to B) on the board...and personally I've probably used 8 or 10 different 7408's and a few 32's from at least two different packages, on two or three different solderless breadboards, not to mention what the rest of the class has tried...

    I should also mention that I have an etched chip with a simple LED flasher on it that is powered by a 9v and a 7805, and has Vcc and GND pins that fit into a breadboard...while the LED on the green board works, the same problem occurs with the solderless circuit.

    When I test it with a multimeter there doesn't seem to be any problem at all with the breadboards...they come up with the same stats that the workstation boards have, but then this Only happens when we use them...hence my problem.

    I don't mean to bash your suggestions or anything but I've been working on this problem for about a week now, and I've just now gotten extremely frustrated. So...any other thoughts?
     
    Last edited: Mar 12, 2008
  5. Mar 12, 2008 #4

    berkeman

    User Avatar

    Staff: Mentor

    Just take it step by step. If you have a voltage source of over 7V, and you have that hooked to an LM7805 voltage regulator, and you are getting anything less than about 4.9V out, then there is a problem with the power supply connection. Disconnect the power supply circuit from the rest of the breadboard, and verify that you get 5V output like you are supposed to. If not, the LM7805 is blown, or plugged in backwards.

    Once you get the power supply sorted out, if the power supply is in current limit for some reason when connected to the circuit, you can feel around the board to find any hot components that may be dragging down the supply. Try starting with the power supply circuit, and then progressively hooking in more and more of the breadboard circuit....
     
  6. Mar 12, 2008 #5

    NoTime

    User Avatar
    Science Advisor
    Homework Helper

    The 7805 might be oscillating.
    Do you have the required capacitors in place?
     
  7. Mar 12, 2008 #6

    The instructions I had said the capacitor was optional for reducing noise, I'd forgotten about using any till now, I'll do that.
     
  8. Mar 14, 2008 #7
    Okay, here's exactly how I have it set up, just like is discribed on the datasheet. All components are placed nowhere near each other on the breadboard, but it STILL somehow lights up the LED. Brand new board, brand new 74LS08/74LS32.
     

    Attached Files:

    • meh.PNG
      meh.PNG
      File size:
      2.7 KB
      Views:
      52
  9. Mar 14, 2008 #8

    berkeman

    User Avatar

    Staff: Mentor

    Why do you have all those floating inputs? Ground pins 1 & 2 and the LED will go out. Has that been the problem all along? Unconnected inputs?
     
  10. Mar 14, 2008 #9
    Did you try just disconnecting everything and just put the 2 caps and LM7805 with Vin to get 5V out? If you can't even get 5V out then there must be something wrong with the breadboard, Vin supply not high enough, bad LM7805 chip or Vout is oscillating (average is lower DC output).

    Also how did you connect the wires on the breadboard? I'm assuming you know how a breadboard is wired internally so if you think 1 way but it connects internally differently then it can screw things up. Check with a DMM and just Ohm things out to see if there is a short
     
  11. Mar 14, 2008 #10
    I drew it like that to make the my point, but...this Sorta solves it...if I use switches ground the pins then yeah the light is only on when both switches are Off...but isn't that a NAND, not an AND? I was under the impression that you had to bring A and B high for Y to be high, not ground them.
     
    Last edited: Mar 14, 2008
  12. Mar 14, 2008 #11

    berkeman

    User Avatar

    Staff: Mentor

    Check the direction of your LED on the board, and whether it is tied up to 5V or down to ground. And yes, an '08 is a Quad AND, and an '00 is a Quad NAND. Check which you have on the board, and check the polarity of the output versus the inputs. They should match the functionality of the part.
     
  13. Mar 15, 2008 #12
    I've been working on this some more and I think that the problem Was that the pins weren't grounded. I went looking back through some learning books (which use 4000 series CMOS) I started out with, and they all use a Vcc PBNO Resistor Ground setup, with the A and B of the gate between the PB and resistor. This grounds the circuit if the button is open and provides current if not. This is something I never did when started using Multisim, because in its simulation, when the switch is open, it drops the voltage on the line to 0.

    It would seem that the SPST switches that are in the work-stations are grounded on the Open side. On the class worksheets that we do, there is no diagram on of the switch parts, it is only a box labeled "Trainer Switch" with a single pin connected to A or B on the gate. This doesn't translate over to a normal breadboard very well, hence this whole problem.

    But what I don't understand is what is the need of showing a DPST switch with one pole on Vcc, and one on Ground?

    Thanks for the help though, now we can finally move on.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Crazy Problems
  1. Problems in relay (Replies: 2)

  2. Capacitor problem? (Replies: 15)

Loading...