Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Does anyone have wireless with Fedora?

  1. Feb 2, 2005 #1
    I just installed Fedora on my laptop and it works pretty good, no major problems or anything like that. My only complaint is the lack of drivers for wireless cards. there is something called ndiswrap that can be used to make your window drivers work in linux but it is pretty complicated to do and I am a total novice. Have any of you gone through this process of installing a windows driver for your wireless card?

    If so maybe you could help me out with some advice on how this is done.

    Thanks
     
  2. jcsd
  3. Feb 2, 2005 #2
  4. Feb 2, 2005 #3

    dduardo

    User Avatar
    Staff Emeritus

    What wireless card are you using?
     
  5. Feb 2, 2005 #4
    Gigabyte GN-WPEAG wireless network PCI Adapter

    I have checked everywhere for drivers. The link you provided has some Ndis wrapper drivers there too but like I said they seem pretty complicated to install.


    I appreciate the help..
     
  6. Feb 3, 2005 #5
  7. Feb 3, 2005 #6

    dduardo

    User Avatar
    Staff Emeritus

    Installing a windows driver with ndiswrapper isn't that hard. Here is some simplified instructions:

    1. Make sure you have the kernel sources installed. On the fedora cd it is called the kernel development packages.

    2. Download ndiswrapper:
    http://prdownloads.sourceforge.net/ndiswrapper/ndiswrapper-1.0.tar.gz?download

    3. Extract ndiswrapper with the following command-line statement:

    tar -zxvf <whatever your file is called.tar.gz>

    Just put the filename.tar.gz of ndiswrapper after the -zxvf

    4. cd <ndiswrapper directory>

    When the files get extracted see which folder was created.

    5. su

    Enter your root password when prompted

    6. make

    7. make install

    8. Go to windows and download the driver for the the card:

    http://www.giga-byte.com/Download/D...ation/FileList/Driver/wpeag.v.3.1.2.21.02.zip

    9. Unzip the file.

    10. Find the .inf and .sys files and put them on a floppy or whatever to transfer them over to linux

    11. Go back to linux and copy over the files into a directory. You can create a directory by doing:

    mkdir <directory name>

    12. type:

    su

    enter root password when prompted

    12. Enter that directly and type the following:

    ndiswrapper -i <filename.inf>

    followed by

    ndiswrapper -l

    13. add the following lines to /etc/modprobe.conf

    options ndiswrapper if_name=eth0
    alias eth0 ndiswrapper

    13. type:

    modprobe ndiswrapper

    14. type:

    dhcpcd eth0

    15. At this time you should be able to connect to the internet. If not try adding eth0 in the fedora network configurations located in the systems menu or somewhere around there.

    16. If all is good run this command:

    ndiswrapper -m

    17. Finally add the following line in /etc/modules.conf (I think that's what it is called in fedora)

    ndiswrapper

    -----

    If you still have problems just ask
     
    Last edited: Feb 3, 2005
  8. Feb 4, 2005 #7
    Ok...It is working now. I guess there is just some syntax I am going to have to learn. It took me a while but now it is working very good.

    Now to my video card driver.....I have an ati 9700 mobility. I have not tried anything yet so it might not be too bad. If I have any more problems I will ask you guys.

    Thank you very much for all the help
     
  9. Feb 4, 2005 #8

    dduardo

    User Avatar
    Staff Emeritus

    Good to hear that. ATI doesn't have the greatest linux drivers but it should work. Nvidia, by far, has the best drivers.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Does anyone have wireless with Fedora?
  1. Does anyone know? (Replies: 6)

Loading...