Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Gtk+2 in RH9?

  1. Apr 16, 2005 #1
    I'm trying to install a package called pdfripimage in my RedHat9 system. When I try to compile it I get a series of errors saying:
    undefined reference to `GTK_COLOR_BUTTON'
    and similar messages relating to gtk functions.

    The README says "make sure you have the GNOME and GTK+2 libraries and headers..."
    I do have all the development tools installed, but I have Gimp 1.2.3. I think this means I have GTK+ and not GTK+2. Is that correct?
    I know at some point I have to migrate to a newer system, but right now I'd like to avoid any major changes unless absolutely necessary. I already have too much to do in the next few days. What's the best way to attack this?

    Or... do you know of another way to extract images (photos, diagrams, and graphs) from a .pdf file to paste them into an OpenOffice presentation?
  2. jcsd
  3. Apr 16, 2005 #2

    I seem to have solved the immediate problem. xpdf has no copy-to-clipboard capability, but I found I can open the .pdf with the linux version of Adobe's Acroread, copy the images I need into KPaint, and in KPaint I can save them as an image file in .png, .jpeg, .bmp & various other formats.
  4. Apr 16, 2005 #3
    I see you have solved the problem.. but i can't resist to post something to this topic ;-)

    Yes.. Does RH has header-packages?
    If yes, you should try them ;-)

    Can't you install it via yum or apt4rpm?
    I know that apt4rpm works great...

    Maybe pdf2html or something like that with an special option...

    or a Screenshot ;-)

Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Gtk+2 in RH9?
  1. Insight 2 (Replies: 2)

  2. Playstation 2 (Replies: 5)

  3. Crysis 2? (Replies: 5)

  4. 2 Wireless Routers? (Replies: 2)