Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

ICQ, problem about receiving files

  1. Jul 28, 2003 #1
    After reinstalled icq in my computer, I can't receive any files from friends. What should I do now ?

    I think some settings in Preferences need to be changed in order to solve the problem. Please help.
     
  2. jcsd
  3. Jul 28, 2003 #2
    My first guess would be are you behind a firewall? do you run zone alarm or sygate or anything else of the sort? You're going to have to disable protection for the port that ICQ transfers files on. I believe the ports are 1080-1802, but i'm not sure so there is probably an option to choose which port to use. Choose one above 1023 and enable outgoing and incoming access on your firewall for that port.
    My next guess is that you're behind a router or something similar like an external DSL modem. You might have to enable port forwarding for the file transfer port to your machine. most people use NAT for this (network address translation). If you really wanted you could also put yourself in the DMZ, but it dramatically lessens security, so i don't recommend it. The proceddure to set this up is different on every DSL modem/router so you'll have to look at the manual.

    if you specify which situation your in (or if it's neither) i could probably give you more help in configuring your router or firewall.
    -HBar
     
  4. Jul 28, 2003 #3
    thanks for your reply

    Well I don't think my pc is behind a firewall and I don't run zone alarm or sygate(I fact I don't know what they are). My computer is put in my room. The hard disk was formated about 2 to 3 weeks ago and I reinstalled icq after that. I am now using icq 2003a, which is the same version as the one before I formatted the harddisk. I could receive files without any problem before formatting harddisk.

    I am usuing broadband and have a LAN card. I think I don't use firewall/proxy. I think I need to change some settings in icq preferences. I remember last year when I first installed icq, my friend taught me to change something in the setting before I could receive files, but i forget what it was and couldn't find that person in these few days.

    In icq, Firewall IP setting, there are 3 options.
    1. Always use internal ip
    2. icq will determine ip automatically
    3. always use external ip (default)
    Which one should I choose ?

    In proxy setting, I choose Not Using FIrewall.
     
  5. Jul 28, 2003 #4
    It sounds like it's your broadband modem that is causing the trouble. What i would do is go to main->connections->user and choose the "Use the following TCP listen ports for incoming events". Enter a range of ports above 1023 like 1050-1055. Then configure NAT on your broadband router to forward all requests for port 1050-1055 to your computer.
    -HBar
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: ICQ, problem about receiving files
Loading...