Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

IIS configuration

  1. Jan 7, 2006 #1
    I would like to understand how I can configure IIS as my localhost, ISS doesn't have config file as does Apache ?
    After installing IIS, I tried accessing localhost but I was asked for username/password which I had never set up any,

    Thanks for any instructions you offer.
  2. jcsd
  3. Jan 7, 2006 #2
    yeh you will be unless you disable authentication from the mmc snap in for iis. The username and password will be your windows authentication, as far as I remember, not touched iis for a while..
  4. Jan 7, 2006 #3
    Sorry, I am completely new to iis, could you be more specific ?
  5. Jan 7, 2006 #4


    User Avatar
    Science Advisor

    With IIS you have to be careful about one thing, "permissions".
    Your website's root by default is in:
    You have the option of making files/folders in your web root either available to anyone on the internet (anonymous), or you can restrict them to local users.
    The account used by IIS for anonymous access is IUSR_<machinename>, where <machinename> is your machine's name. If your machine's name is MACH, then the account used is:
    In the IIS snap-in (which should be under Start Menu - Control panel - Administrative Tools - Internet information Services (IIS) Manager), on the left side, there is a tree which should look something like:
    Code (Text):
    Internet Information Services
      - MACH (Local Computer)
         + FTP Sites
         - Websites
            - Default Web Site
    For any file/folder displayed in this tree you can right-click on it, select properties, then in the directory security tab click "edit". Make sure to check the option "Enable anonymous access" if you don't want the log-in window to come up when you visit your site.
    Notice that when you do this IIS sets the folder/file security settings to allow the account IUSR_MACH to read/execute on that file/folder.
    What this means is that alternatively you can just right-click on the file/folder in the regular file browser, select properties, then in the security tab click "add", click "advanced", click "find now" (this shows all the user accounts in your computer), select the IUSR_MACH account, press OK. Now your file/folder can accessed anonymously.
    Keep in mind that it may not be enough to allow your default.html file to be accessible by anonymous access. What i mean is that if you have any images or files used inside default.html then those files will need to have the security settings set such that they can be accessed anonymously (again you can do this either through IIS or file browser), if not you'll still get the Log In Prompt.
    Last edited: Jan 7, 2006
  6. Jan 7, 2006 #5
    Thanks for your reply, I do as what you told:
    rightclick website->properties->DirectorySecurity->Edit->Check Anonymous Access -> Choose Browse Advance Find to bring up default account -> Check Allow IIS To Control Password.

    But when I call localhost at the browser, it says my default account is forbidden, the page called is like an normal error page.

    Second, if I tried not to choose default account but take one account appeared from Advance Find, and enter a password for this account, then Uncheck Allow IIS To Control Password, localhost when called would again ask for password but the password I entered isn't recognized, the prompt dialog therefore shows up, I really don't know what to do now.
  7. Jan 7, 2006 #6


    User Avatar
    Science Advisor

    What do you mean "default account"? The account that should be used for anonymous access is IUSR_<machinename>. IIS should control the password.
  8. Jan 8, 2006 #7
    Are you just playing with IIS?
  9. Jan 8, 2006 #8
  10. Jan 8, 2006 #9
    Pick up anyone found after the machine scans for accounts, let IIS control your password, open localhost again, it'll work, I am pretty sure.
    You seem to have gone so far in the way you tried to configure the server, although I believe it is one of many possible ways problem gets itself resolved. Other options have been clearly explained and apparent enough, nothing about them is to be changed.
    For you, I can just say something like that, :wink:
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: IIS configuration
  1. IIS problem (Replies: 1)