Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

JEdit compatability with f90

  1. May 28, 2012 #1
    I've been using jEdit for writing f90 programs. Win7. Although jEdit has been helpful, I see that with f90 it has limited indent features, and sometimes when I print I get odd indents. When moving the cursor on a line, sometimes odd things happen. For example, it appears that the cursor takes tab jumps. Tabs may be mixed among blanks spaces. Another editor for f90? Away to control it for f90?

    Here's a small example of indent problems.

    integer :: j
    real :: a
    do j=1,3
    write(*,*) j + a
    end do

    There is no clear way to line these up. Unseen tabs may be the problem in jEdit.
  2. jcsd
  3. May 28, 2012 #2
    Well, that didn't quite work. Consider _ as a space.

    integer :: j
    real :: a
    __do j=1,3
    _____write(*,*) j + a
    __end do

    I'd like to see:
    __integer :: j
    __real :: a
    __do j=1,3
    _____write(*,*) j + a
    __end do
  4. May 29, 2012 #3
    I stopped using jEdit a looooong time ago.

    One thing that is frown upon by many of us is the use of tabs, in the first place.

    So, see if you can go to Options or Settings and look for a way to emulate tabs with spaces...I think there might be an option where you tell the editor that every time you press the tab key, it should use a certain number (typically 4) of spaces, instead.

    Whenever I inherit a source, the first thing I do is a "search and replace" and get rid of the tabs...yes, it ends up misaligned and so I fix it.

    Other nice editors are Crimson and Notepad++.
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Similar Discussions: JEdit compatability with f90
  1. Oo f90 (Replies: 1)

  2. Largest number in f90 (Replies: 13)