Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Keyboard lock

  1. Aug 25, 2016 #1

    mathman

    User Avatar
    Science Advisor
    Gold Member

    On rare occasions, for no apparent reason, my keyboard (PC) locks - i.e. it won't respond. The only control I have then is via the mouse. To get back to normal I have to restart. Does anyone know what happened and is there a simpler way to get the keyboard back?
     
  2. jcsd
  3. Aug 25, 2016 #2
    Have you tried unplugging then inserting it back in ?
     
  4. Aug 25, 2016 #3

    berkeman

    User Avatar

    Staff: Mentor

    Sometimes for me my PC seems to go unresponsive, and it turns out that there is a small error dialog box from whatever I was just doing, but it's hidden behind other windows. The only way I find it is to look at the pop-up task bar at the bottom of my display (at least on Windows versions up to Vista or so), to look for an error item...

    Otherwise, as @Pepper Mint says, if your keyboard has a connector to your PC (USB or whatever), try just pulling it out for a few seconds and plugging it back in. :smile:
     
  5. Aug 25, 2016 #4

    RonL

    User Avatar
    Gold Member

    Have you watched the "IT Crowd" :biggrin:
     
  6. Aug 25, 2016 #5
    Only some of its episodes. And I like it a lot.:micoscope:
     
  7. Aug 25, 2016 #6

    RonL

    User Avatar
    Gold Member

    The one I find hilarious is, when the boys play the "internet in a box" prank on the girl. :biggrin: If I remember the episode was titled "The Speech"
     
  8. Aug 25, 2016 #7

    Fervent Freyja

    User Avatar
    Gold Member

    It would be helpful to know your operating system, whether or not your keyboard and mouse are wireless, and if you are using a touch pc! Anyway, check your ease of access settings for your keyboard, then find the keyboard shortcuts for enabling/disabling it (which edition you are using matters). You may find that you are hitting lock shortcuts without knowing it. This happened to me a few weeks ago, I simply disabled the option in ease of access and it stopped locking up/beeping on me! Like berkemen noted, something should pop-up on the task bar the instant this happens as a notification (right click it and disable if you can).
     
  9. Aug 26, 2016 #8

    mathman

    User Avatar
    Science Advisor
    Gold Member

    The computer is a notebook - IBM thinkpad. Nothing is wireless. Where do I find "ease of access"?
     
  10. Aug 26, 2016 #9

    berkeman

    User Avatar

    Staff: Mentor

    Probably depends on the OS you're running, but on my older OS its under Control Panel, Accessibility Options (wheelchair icon)...
     
  11. Aug 26, 2016 #10

    berkeman

    User Avatar

    Staff: Mentor

    Although I'm not seeing any enable/disable options on my ThinkPad under the Accessibility Options...
     
  12. Aug 26, 2016 #11

    OCR

    User Avatar

    Last edited: Aug 26, 2016
  13. Aug 27, 2016 #12

    mathman

    User Avatar
    Science Advisor
    Gold Member

    This as far as I got. What next? keyboardUntitled.png
     
  14. Aug 28, 2016 #13

    OCR

    User Avatar

    I'm not sure, I've never really messed (much) with the settings in "Ease of Access"... read post numbers, 2, 3, and 7 again, maybe?

    Looks like you did find it, though...[COLOR=#black].[/COLOR] :ok:


    Lol... for about the last ten years, I've actually been more interested in finding the answer to...

    If you're still having problems, you could try looking in the Device Manager... right click on the start button, look in the "drop-up", then left click Device Manager.
    If you get a User Account Control popup, click "Yes", and you should be there... look around, and at the top, click the icon that says Scan for hardware changes.

    If you don't see any ! , expand Keyboards and investigate what you can... here's a screen grab.

    Devices Manager.JPG
     
    Last edited: Aug 28, 2016
  15. Aug 29, 2016 #14

    mathman

    User Avatar
    Science Advisor
    Gold Member

    I got what you show. So what? I see noting to correct. As you can see from my previous post, there does not appear to be anything to do. I am just assuming a computer glitch.
     
  16. Aug 29, 2016 #15

    OCR

    User Avatar

    :ok:
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted



Similar Discussions: Keyboard lock
  1. Keyboard mapping (Replies: 1)

  2. Keyboard Problems (Replies: 6)

Loading...