Laptop battery not detected?

  1. Hi,

    So I have a Sony VAIO laptop, and recently the batterys decided to stop being recognised by the computer (if I go to the power meter in the control panel, it reads the battery as "not present"), so I run off of AC power and disconnect the lead, the laptop just turns off. The problem is sony want £139 for a new battery, which is a little steep, and the last thing I want to do is replace the battery when thats not the issue. So I suppose my question is, is there anything else that could be causing the battery to not be recognised like this, other than the battery itself being faulty? Thanks for any help!

  2. jcsd
  3. berkeman

    Staff: Mentor

    Do you know anybody else with a Vaio? You could swap batteries to see if the problem follows the battery or the laptop. If it stays with your laptop, it should be a pretty easy fix for a repair place familiar with Vaios. If the problem follows the battery, then a new battery would probably be the cheapest fix.
  4. There was a huge recall of Sony batteries last year (or was it 2 years ago), is it possible you might have one of these batteries? If the machine is a couple of years old then you might want to check out the serial numbers against those of recalled batteries.
  5. My Acer Timeline laptop battery stopped being recognized after I pulled it out while on AC power. It may be that your battery or the measuring circuit of the battery needs some kind of a reset.

    I solved my problem by shutting down the laptop, then I pulled out the AC power cord AND the battery. Then I put the battery back in and rebooted. Now the battery was recognized.
  6. ok so i have a similar problem. my vaio laptop (about 2.5 years old) recently froze while it was shutting off, so i pulled out both the battery and the ac adaptor and it shut down. i then put both back in and it turned back on, but in the bottom right corner it said änd still says "No battery is detected." i tried smallphi's solution, turning the computer off, taking both out, then putting both back in, but the same problem occurred. i know that the battery cant be the problem, because it has had no problems at all up until i did this. is there any other quick fixes to this?
Know someone interested in this topic? Share this thead via email, Google+, Twitter, or Facebook

Have something to add?