LaTeX Latex - graphs closer together

  • Thread starter lavster
  • Start date
217
0
There was not enough room to fit my graphs in the text where they were supposed to go so latex put them in the next page. This meant that this page only has these two graphs and the text begins again on the page after that. There is a lot of space between (see attached). How do i make it take up less room and have text on that page too?

Thanks
 

Attachments

kreil

Insights Author
Gold Member
667
66
217
0
Hi thanks for your response.

However my graphs have to be this size. and they dont go side by side unless smaller. Its the vertical space inbetween them I dont want. so instead of having 6cm between them on the page i want only one cm. if tried eg \vspace{-50mm} but that doesnt shift it.

Thanks
 

kreil

Insights Author
Gold Member
667
66
It could be that the images themselves have a lot of whitespace and need to be cropped.

If you put the \includegraphics command inside of \fbox, i.e.

Code:
\fbox{\includegraphics[options]{filename}}
it will draw a box around the figures and let you see if this is the case. If so, you can crop the image files manually, or (if you like trial/error) within your editor with the trim option of the graphicx package (example numbers):

Code:
\includegraphics[trim = 10mm 80mm 20mm 5mm, clip, width=3cm]{filename}
trim = l b r t (left bottom right top)
 
217
0
the graphics size is fine, and the white box is too. i have know idea why this is happening! :(
 

kreil

Insights Author
Gold Member
667
66
Sounds to me like you'll have to compromise on the size a bit and just adjust the caption font size so it's still readable. Play around with the scale and try to find the threshold where it allows the text on the same page.
 
1,065
53
You could also attempt to change the margin of THAT particular page to fit your figures.

By the way...why do you say your pictures HAVE to be that size? A bit smaller may not hurt and, for as long as you have imported your figures in pdf format, they should be nicely zoomable...remember, by now, most of us have pretty good monitors and will make the page pretty wide...so, at the end, the size of you picture does not matter that much.
 
217
0
ive got to give a hard copy... They have lots of rules incl fig size, margin size, font size etc etc :(

thanks ill have a play!
 
1,065
53
Well, the whole point of LaTeX is to meet publishing standards...if what they are asking you does not fit into the normal document, maybe they are not following publishing standards and all bets are off...you can go ahead and start modifying the page margin and all that stuff, as suggested before.
 

robphy

Science Advisor
Homework Helper
Insights Author
Gold Member
5,398
670
Did you try \vspace*{-50mm} ?
 

AlephZero

Science Advisor
Homework Helper
6,953
291
There was not enough room to fit my graphs in the text where they were supposed to go so latex put them in the next page.
When you say "latex put them on the next page", do you mean each graph is inside
Code:
\begin{figure} ... \end{figure}
and the figures didn't end up where you hoped they would?

If so, try tweaking the parameters that LaTeX uses to control the page layout. The defaults are fairly conservative and won't put just a "few" lines of text on a page that contains mostly figures.

See http://mintaka.sdsu.edu/GF/bibliog/latex/floats.html, or google for more informatikon, now you know what the parameter names are.
 

jhae2.718

Gold Member
1,110
20
You can use the float package with
Code:
\usepackage{float}
and then force figures to appear where you place them using
Code:
\begin{figure}[H]
    % figure stuff
\end{figure}
 

Related Threads for: Latex - graphs closer together

  • Last Post
Replies
3
Views
4K
Replies
7
Views
759
Replies
11
Views
8K
Replies
16
Views
15K
Replies
5
Views
4K
  • Last Post
Replies
2
Views
3K
Replies
1
Views
2K
Replies
9
Views
3K
Top