Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Latex wide check symbol

  1. Oct 9, 2008 #1
    How do I do a wide check symbol in latex?

    A wide hat or wide tilde is easy, it is simply \widehat{long expression} or \widetilde{longexpression}

    There is no command for wide check, i.e an upside down hat.
  2. jcsd
  3. Oct 10, 2008 #2


    User Avatar
    Homework Helper

    Hi bartadam,

    You can install the mathabx fonts found here:


    which contain a widecheck. Once they are installed, you can use them with the regular \usepackage command:

    Code (Text):




    \[ \widecheck{asdf} \]


  4. Oct 10, 2008 #3
    I'm a bit of a latex novice I know enough to get by. I downloaded the thing, how to I install the package?
  5. Oct 10, 2008 #4


    User Avatar
    Homework Helper

    I am using miktex on windows, so I can tell you how I did it for that.

    Downloaded mathabx.zip from the website and unzipped it.

    Inside there were about 54 files in a folder named 'source'; all 54 of those files had the extension .mf; in a folder named 'texinputs' there were four files: mathabx.dcl, mathabx.sty, mathabx.tex, testmac.tex

    I went to where my miktex distribution is located and went in the folder:

    c:\Program Files\MikTeX 2.7\fonts\source\public

    In there I created a new folder called mathabx and put all 54 of the .mf files in there.

    I then went to the folder

    c:\Program Files\MikTeX 2.7\tex\generic\misc

    I created a new folder called mathabx and put the other four files (mathabx.dcl, mathabx.sty, mathabx.tex, testmac.tex) in there.

    (In other words when I was re done I had all of the .mf files in:

    c:\Program Files\MikTeX 2.7\fonts\source\public\mathabx

    and the four files mathabx.dcl, mathabx.sty, mathabx.tex, testmac.tex in:

    c:\Program Files\MikTeX 2.7\tex\generic\misc\mathabx


    Then on the start menu I went to Miktex2.7 --> Settings. On the window that comes up, I clicked the buttons "Refresh FNDB" and then "Update Formats".

    After that all was ready. Hope this helps.
  6. Oct 12, 2008 #5
    Thanks very much. I am using miktex too so I shall do that.
  7. Oct 20, 2008 #6
    This is all working fine now.

    Couple of questions

    a) When I compile this as latex>ps>pdf it misses out some of the mathematical symbols such as arrows and lines. It has diagrams in the document as ps files so has to compile as a ps first.

    b) I have done this on my computer at home, are the uni computers likely to have the same package

    c) This is a document I shall be submitting to the physics arxiv and admitting for being published in a journal, will the package mathabx be available to them also?
  8. Oct 21, 2008 #7


    User Avatar
    Homework Helper

    I've never seen this happen to me; is there a short sample tex file you can show that reproduces this behavior?

    I think this would be completely up to the system admins, so would be different from place to place.

    I seem to recall (for the last article I submitted) a caution on the journal's website about using what they called "non-standard" packages. I would send an email to the journal about it. Even if they don't want to accept this particular package, they might have their own way to create the widecheck symbol.
  9. Oct 22, 2008 #8



    The above code compiles as a pdf. My document imports diagrams as ps files. That won't compile as a pdf so it has to compile as latex>ps>pdf. Without the mathabx package it works fine. with the mathabx package it does the same as the above code, some of the symbols vanish.

    Can I write some code within the text of my latex file to generate widechecks? Somehow farm it from the package itself, I do not know what I'm doing with Latex enough.
  10. Oct 24, 2008 #9


    User Avatar
    Homework Helper


    Sorry, but I did not see your post here until now.

    Here's what you can do (if you don't want to change settings in TexnicCenter):

    Use the option "latex=>ps" to build the ps file "filename.ps".

    Open a command prompt window, go to the folder with the file, and run the command
    "ps2pdf filename.ps"

    (Is the appropritate Miktex folder in your path so the system can find ps2pdf?)

    That should create filename.pdf with the symbols in it.


    The unexpected thing to me is that the ps file created by the "latex=>ps" option and the intermediate ps file created by "latex=>ps=>pdf" are different! (Because the commands that create the ps files in each case are different, as you can see by looking at the output profile settings.)

    I'm glad you brought this up; it's nice to know what choices are being made by default. I had always assumed that texniccenter just directly called ps2pdf to create the pdf, but they have a different route.

    You could always modify the Texniccenter settings to do the above process automatically. But are you getting the correct pdf file now?
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Latex wide check symbol
  1. Spell check latex (Replies: 2)