Linux 7.0 install problem

  1. I have problem when installing Linux Red hat 7, my keyboard becomes inactive/dead. I tried changing to another keyboard, I've got the same problem. What is the reason ?
    Thanks in advance
    Last edited: Sep 30, 2004
  2. jcsd
  3. NateTG

    NateTG 2,514
    Science Advisor
    Homework Helper

    I'm guessing that you've got a USB keyboard, and that Linux isn't recognizing it. Regardless, you should look at the Fedora support stuff (Google for it) or at Red Hat for support, they'll be able to give you more specific help.
  4. graphic7

    graphic7 557
    Gold Member

    Red Hat Linux 7 is a *very* old distribution of Red Hat. If I recall correcty, v7 uses a 2.2.x series kernel (in fact, I believe USB support could only be added via a kernel patch while 2.3.x was maturing). In the 2.2.x days, USB support was very primitive. You'd be better using Fedora, for instance, where USB support has since matured.
    Last edited: Sep 30, 2004
  5. Thank you NateGT and graphic7, thats the only version my friend lent me. he is so selfish, I intend to download but dunno where to do that, Red-hat asks downloaders to pay :redface:
  6. dduardo

    dduardo 1,895
    Staff Emeritus

  7. I checked out that site, they asked me to pay if I'd like to use redhat, do you know any other sites ?
  8. NateTG

    NateTG 2,514
    Science Advisor
    Homework Helper

  9. dduardo

    dduardo 1,895
    Staff Emeritus

    Hbaw, where the heck are you looking? -> Fedora -> Fedora Core 3 Test(2.90)

    CD 1:
    CD 2:
    CD 3:
    CD 4:

    If those links are too slow or they don't work, try the handful of mirrors associated with each cd. Just click on the cd-folder to see all the links.
  10. i would try a newer version of redhat.. (FC2 is very good, too)
    They added a lot of ps2/aux supports for newer controllers..

  11. I've seen this problem last night.

    I had the same issue, and quickly resolved it by checking a couple of places.
    The linux software (fedora) doesn't seem to make the USB native connections.

    Try going into your CMOS/BIOS as the system is booting up, and Look for something like "integrated peripherals" or "advanced settings", and look for enable legacy USB devices. Make sure its set to enabled.

    Mine resolved instantly, yours may take a reboot, or re-install.:eek:
Know someone interested in this topic? Share this thead via email, Google+, Twitter, or Facebook

Have something to add?