Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Linux doesn't start anymore

  1. Feb 20, 2005 #1
    Hello all,

    I wanted to boot my Linux, login and use KDE.
    But Linux (SuSE) didn't boot as usual. I can't get to the screen where I can choose between KDE, window maker, etc. :bugeye:

    It says:

    Starting service kdm/opt/kde3/bin/kdm: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory

    startproc: exit status of parent of /opt/kde3/bin/kdm: 127 failed

    Failed services in runlevel 5: xdm

    Welcome to SuSE Linux 8.0 (i386) - Kernel 2.4.18-64 GB-SMP (tty1)

    linux login:

    :confused:


    I logged in but I can't start any applications (like kwrite or kedit).
    It's like console mode (similar to tty2 if you press Ctrl+Alt+F2)
    Now what's wrong with my Linux and how can I fix it?

    :grumpy:
     
  2. jcsd
  3. Feb 20, 2005 #2

    dduardo

    User Avatar
    Staff Emeritus

    When it gives you the console login, enter as root. Then do the following:

    cd /etc/X11/Sessions
    ls

    There should be a file called kde-<version number>. Write this down. Then do this:

    pico /etc/rc.conf

    I don't know if you have the pico text editor. If you don't you can try and use emacs or vim. Vim is a little different than other editors and requires you to do :i before entering any text. You can then save your work and quit by doing :wq

    Once you open the file with a text editor change the following lines to this:

    DISPLAYMANAGER="xdm"

    XSESSION="kde-<version-number>"

    There should be instructions within the file so if you get confused refer to them.

    After you save the file and quit the text editor start the xserver run the following command:

    startx

    You should be presented with a login. Enter your infomation and it should take you to kde.

    From there go to Yast and reinstall kdm. When your done reinstalling edit rc.conf again and change this line:

    DISPLAYMANAGER="kdm"
     
  4. Feb 20, 2005 #3
    Sounds more like his X is borked, not that kdm isn't trying to start up. :confused:

    Edgardo, did you make any changes recently? Settings, software, drivers, kernel, hard disks, hardware?
     
  5. Feb 21, 2005 #4
    There is no folder called Sessions. All I see in the X11 folder is:

    XF86Config
    XF86Config.YaST2save
    XF86Config.saxsave
    XF86Config~
    Xmodmap
    Xmodmap.remote
    fs
    kde3
    lbxproxy
    proxymngr
    qtrc
    rstart
    susewm
    twm
    xdm
    xinit
    xkb
    xsm

    The blue words are folders.
     
  6. Feb 21, 2005 #5
    Did you edit your XF86Config recently?
     
  7. Feb 21, 2005 #6
    Hmm...I tried to install the beamer class for latex (didn't work properly).
    I also played a little bit with the online update, but recognized that the
    links were old (I have SuSE Linux 8.0), so I didn't update.
    I once tried to install nvidia driver, didn't work.
    I tried to get the mouse wheel to work, but didn't manage to do so.
    Experimenting with the mouse-setting was quite annoying. I once changed
    to ExplorerPS2 and afterwards the mouse-pointer was jumping around the screen. I had to restart and I was happy that I had the texteditor opened, so I could change it back to the original setting.
     
  8. Feb 21, 2005 #7
    Oh yes, I once changed it in order to make the mouse-wheel working.
    As that didn't work, I changed it back, and everything was fine.
    But that was some weeks ago. I worked with SuSE-Linux and had no problems.
    Except that for the DHCP, I always had to change it in YaST2 in order to
    get internet-access.

    As for the XF86Config-file, I left some things changed like mouse wheel buttons 5 (or something like that), although in my case this didn't have any effect on my mouse wheel (still doesn't work).
     
  9. Feb 21, 2005 #8
    Perhaps you left a typo or something in the file. Can you post your XF86Config somewhere so we can check it? :cool:

    Alternately, backup your current XF86Config and revert to one of the backups already there. (Have you already tried this?)

    I presume you tried the nvidia driver long ago too. What changes did you make between now and when X last worked?

    Incidentally, do a search for libX11.so.6, see if it exists. :cool:
     
  10. Feb 21, 2005 #9
    Here's my XF86 Configuration:


    # /.../
    # SaX generated XFree86 config file
    # Created on: 2005-01-07.
    #
    # Version: 4.3
    # Contact: Marcus Schaefer <sax@suse.de>, 2001
    #
    # Automatically generated by [SaX2] (4.3)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/local"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/URW"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath "/usr/X11R6/lib/X11/fonts/PEX"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/kwintv:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/CID"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/xtest"
    ModulePath "/usr/X11R6/lib/modules"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail"
    EndSection

    Section "Module"
    Load "type1"
    Load "speedo"
    Load "extmod"
    Load "freetype"
    EndSection

    Section "InputDevice"
    Driver "Keyboard"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "de"
    Option "XkbModel" "pc104"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "nodeadkeys"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Device" "/dev/mouse"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    # Option "Emulate3Buttons" "on"
    # Option "Emulate3Timeout" "50"
    Option "InputFashion" "Mouse"
    Option "Name" "Autodetection"
    Option "Protocol" "ps/2"
    Option "Vendor" "Sysp"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "CheckDesktopGeometry"
    DisplaySize 330 240
    HorizSync 24-68.7
    Identifier "Monitor[0]"
    ModelName "1024X768@85HZ"
    VendorName "--> VESA"
    VertRefresh 50-85
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 110.76 1280 1296 1552 1736 1024 1024 1034 1070
    Modeline "1280x1024" 114.32 1280 1296 1552 1736 1024 1024 1034 1070
    Modeline "1152x864" 84.02 1152 1168 1384 1568 864 864 872 902
    Modeline "1152x864" 96.94 1152 1168 1384 1568 864 864 874 902
    Modeline "1152x864" 102.78 1152 1168 1384 1568 864 864 874 902
    Modeline "832x624" 43.80 832 848 968 1112 624 624 630 652
    Modeline "832x624" 50.54 832 848 968 1112 624 624 634 652
    Modeline "832x624" 57.28 832 848 968 1112 624 624 634 652
    Modeline "800x600" 40.56 800 816 928 1072 600 600 606 626
    Modeline "800x600" 46.80 800 816 928 1072 600 600 610 626
    Modeline "800x600" 53.04 800 816 928 1072 600 600 610 626
    Modeline "640x480" 25.96 640 656 720 864 480 480 484 501
    Modeline "640x480" 29.95 640 656 720 864 480 480 490 501
    Modeline "640x480" 33.95 640 656 720 864 480 480 490 501
    Modeline "720x400" 24.34 720 736 824 1008 400 400 403 417
    Modeline "720x400" 28.08 720 736 824 1008 400 400 410 417
    Modeline "720x400" 31.82 720 736 824 1064 400 400 410 417
    Modeline "1024x768" 94.5 1024 1088 1184 1376 768 769 772 808
    EndSection


    Section "Screen"
    DefaultDepth 16
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1152x864" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "720x400"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1152x864" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "720x400"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "1280x1024" "1152x864" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "720x400"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1152x864" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "720x400"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "GeForce4 MX 440"
    BusID "1:0:0"
    Driver "nv"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection


    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection
     
  11. Feb 22, 2005 #10
    Can't see any errors. Did you search for the filename that it says is missing?
     
  12. Feb 22, 2005 #11
    I'd like to try what dduardo advised me to do. But I can't find the folder cd /etc/X11/Sessions. As for the kde version number, is it maybe kde3
    because there's a folder called kde3?
     
  13. Feb 22, 2005 #12

    dduardo

    User Avatar
    Staff Emeritus

    Try looking in xinit
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Linux doesn't start anymore
  1. Running Linux (Replies: 9)

  2. Highlighting in linux (Replies: 4)

  3. Linux or Windows? (Replies: 54)

  4. Linux in Physics (Replies: 4)

Loading...