Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Linux drivers for ATI chipset

  1. Jan 6, 2008 #1
    ATI mobility RV250 FireGL 9000 chipset

    Ive tried envy, i've tried the opensource ones, nothing works, this all got messed up when i did a apt-get dist-upgrade from7.04 to 7.10

    So i need to reinstall the drivers, but don't know where to get them nor install them.

    i've posted in ubuntuforums.org and not one single bit of help. so this is my last chance.

    i'm willing to allow someone to SSH into my system do them for me, all i want to do is play urban Terror 4 on this laptop.


    Either that or i'm going back to Windows...
     
  2. jcsd
  3. Jan 7, 2008 #2
    Let me see if i got it right:
    You had it all working correctly, then you made the upgrade from 7.04 to 7.10, and the graphic acceleration stopped working?

    how did you install the drivers last time?
    did you use the restricted driver module, the installer from ATI's site, envy...?

    what exactly have you tried up until now?
    what do you get from this command:
    lsmod
    (try filtering it using | grep <the word you're looking for> - look for fglrx, ati, fireGL... i don't know how the module for FireGL is called...)

    dmesg
    (look for these words here too)

    fglrxinfo
    (if you got fglrx installed...)

    glxinfo

    I have only installed a Radeon x1950 pro, and it was pretty easy... I don't know how much supported is your chipset... from the looks of ATI's page - it's not supported by them... and i have no experience with the open source drivers... so, I'll do my best to give you Ideas, but you will have to do some detective work too and post all the information you can put your hands on...
    maybe the xorg.conf file can help us too...
     
  4. Jan 7, 2008 #3
    I've since installed the

    xorg-xserver-fglrx-ati ( cant remember the exact name, im here at work)

    package, after completely removing everything fglrx from synaptic, then reconfiguring my xorg.conf and choose 'ati'.

    the problem lied in fglrx conflicting with compiz so i've uninstalled that, and performed the above step and it seems to be ok now, i've not tried to reinstall compiz or anything yet.
     
    Last edited: Jan 7, 2008
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Linux drivers for ATI chipset
  1. GeForce vs ATI (Replies: 3)

  2. AMD/ATI merger (Replies: 3)

  3. ATI All-In-Wonder (Replies: 1)

Loading...