Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Linux help

  1. Jan 31, 2006 #1
    Linux help!!!

    OK, I finally got my wireless working last night, but when i went to school today, I tried to connect there, no luck.

    and when i got home tonight and reset all my settings to what they were when i was connected, i got nothing!!!

    anyone know what i can do? i already uninstalled and reinstalled the drivers. I am afraid I will need to do a system restore of some type.

    This is irritating me!!! no wonder windows is used on most of the worlds computers!!! it just works!!!
     
  2. jcsd
  3. Jan 31, 2006 #2

    dduardo

    User Avatar
    Staff Emeritus

    Are you using the ndiswrapper? If you are did you remember to do:

    modprobe ndiswrapper

    If you don't want to do this every reboot you should add ndiswrapper to /etc/modules.d/kernel-<whatever version you have>
     
  4. Jan 31, 2006 #3
    I did that, it says its loaded, then i try

    ifup wlan0

    but i get the message that there is no IP address. I mean, i did the exact same steps last night, and it worked fine.

    I might have to do a system restore (?) to last night.

    I might have to reinstall, i didn't realize i needed to make a backup file. Unless I can get some tips on what to do here, I am kinda screwed. this is seriously making me wanna quit linux forever if its this hard to use.
     
    Last edited: Jan 31, 2006
  5. Feb 10, 2006 #4
    Hey dont give up on Linux. It has come a long in just the past couple years. Every day it gets better and better. I would strongly urge to use the most user friendly disto of all. Try Mandriva (formerly known as Mandrake) I absolutely love Mandrake. It's so simple and easy to use. I haven't tried Kubunto. But I have had used Redhat 9, Suse 9, Slackware, Knoppix, Debian, Phlack, plus a few others and I must say that I had the easiest time with Mandrake. I know that there are a lot of Mandrake haters out there who complain about Mandrake being for noobies but I really like it and it's always been friendly for me. You can get iso from http://linuxiso.org <---- My fav site
     
  6. Feb 10, 2006 #5
  7. Feb 10, 2006 #6

    do the commands following and post the output:

    lsmod

    iwconfig

    iwlist wlan0 scan

    ifconfig

    edit: Do them as root, not as regular user.
     
  8. Feb 11, 2006 #7
  9. Feb 11, 2006 #8

    From a cursory glance, looks like signal issues. But I'm not sure. Thats not all the commands I asked you to run though.
     
  10. Feb 12, 2006 #9
    really? which ones did i miss?

    I can run those for you then.

    its not a signal issue, I think its an issue within linux, I can't even see my MAC address in linux.
     
  11. Feb 13, 2006 #10

    Well, from the output you gave me (which was not eveyrthing I asked for) thats what came to mind. To repeat the list of commands (points at previous post as well):

    lsmod

    iwconfig

    iwlist wlan0 scan

    ifconfig

    Just run them all and post the output.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Linux help
  1. Linux help (Replies: 2)

  2. Linux Help (Replies: 8)

  3. [HELP] XP/Linux again! (Replies: 2)

Loading...