Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Linux/java vm plugins

  1. Oct 16, 2003 #1
    (I recently installed Red Hat 9 with Mozilla on my desktop AND notebook pcs)

    When I tried to load various web pages I was getting an error: This page contains information of a type (application/x-java-vm) that can only be viewed with the appropriate Plug-in.

    So I went to the Netscape Browser plugin finder site and found the appropriate plugin for java-vm and "successfully" installed it on both machines. (In both cases I had to su to root in order to do this installation. If not logged in as root, I got "access denied" when it tried to install.) Now, these java applications run fine on my desktop pc for ANY user. But on my notebook, they only work if I'm logged in as root. As a normal user, I still get that "This page contains information ... bla bla bla" error message.

    Any ideas? I'm guessing there's just a problem with file permissions, but I don't know what file to look for.
  2. jcsd
  3. Oct 16, 2003 #2
    I'm not sure about Moz regular, but here's what you'd do for Moz Firebird... it probably will work for regular.

    Create a soft link in your ~/.mozilla/plugins/ dir to the libjavaplugin_oji.so file which is wherever you installed Java. For me it's:
    Code (Text):
    ln -s /usr/java/j2re1.4.2_01/plugin/i386/ns610-gcc32/libjavaplugin_oji.so ~/.mozilla/plugins/libjavaplugin_oji.so
    Make sure you link to the appropriate libjavaplugin_oji.so (there should be another in /i386/ns610/). I think for Moz regular v1.5+ and for Moz Firebird 0.6.1+ you'll want to link to the ns610-gcc32 one.

    Last edited: Oct 16, 2003
  4. Oct 16, 2003 #3
    Thanks, but that doesn't seem right. There is no .mozilla subdirectory in my home directory, so I don't know where I would put that link. And anyway, its working fine on my desktop machine without it. the problem is only on the notebook.

    Anyway, I found the directory tree where the plugins were installed, & for some reason, on the desktop, all the directories in that tree have global read-execute permission, but on the laptop they were set to give permissions only to root. So I went through the tree & changed the permissions; I believe they are now all the same on the laptop as on the desktop.

    Now, the java applets still work for root, but if I go as an ordinary user to a webpage that tries to open a java applet, instead of giving the plugin message, it instantly closes the browser. So I just made things worse.
  5. Oct 16, 2003 #4
    Oh, make the folder then. :wink:
  6. Oct 16, 2003 #5
    Didn't work. I made the link but it didn't help.

    Guess I'll play around with it some more tomorrow.

    Thanks anyway.
  7. Oct 16, 2003 #6


    User Avatar
    Staff Emeritus

    if you just going to the home directory folder on your desktop your not going to see the folder.

    a DOTfoldername is the equivalent to a hidden folder in windows. To see it go to the console and type "ls -a" in you home directory.

    You also shouldn't be "chmod'ing" every file. It is dangerous!!

    I recommend that you upgrade to the lastest mozilla,firebird, whatever, and use the lastest java vm. Then make the link as abhishek said, but to the place where you installed the new mozilla, firebird program.

    If you want to try to get your current mozilla to work, then try the link to "ns610" java version as abhishek said.
  8. Oct 17, 2003 #7
    Thanks, dduardo, but the problem was not that I didn't see the .mozilla; it was there but it was empty. It's the /plugins that wasn't there. But that wasn't the problem either, 'cause after that I mkdir'd a .mozilla/plugins directory & put the link there, but Mozilla wasn't looking there anyway.

    But that's OK too. I just got disgusted & said why am I wasting time on this old Mo 1.2.1 so I just uninstalled it completely & installed Firebird instead, and that's working just fine.

    And I realized I didn't have to bother installing the java j2re package either. I just made a link like abishek described to the plugin folder of my j2sdk directory, so Firebird looks there & runs the java applets perfectly.

    All's well that ends well. Thanks both of you.
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Linux/java vm plugins
  1. Firefox Plugins (Replies: 6)

  2. Linux or Windows? (Replies: 54)

  3. Linux in Physics (Replies: 4)