1. Not finding help here? Sign up for a free 30min tutor trial with Chegg Tutors
    Dismiss Notice
Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Linux PASSWD

  1. Sep 29, 2005 #1
    In a HOWTO page, I'm told to define a new user this way:
    (I'm using Debian Sarge 3.1 Official)
    1. Create new group ppp, for this you need to edit file /etc/group and add this line on the end of file:

    ppp:x:1001:

    2. Create new system user for dialin connection pppuser: Simple create new system user and when using shell command vipw change line of user pppuser to this:

    pppuser:x:1001:1001:,,,:/home/pppuser:/usr/sbin/ppplogin

    3. Use Passwd command to change the password to whatever you want.

    When I typed
    passwd pppuser (return)
    I got the following error:
    passwd Authentication service cannot retrive authentication.

    What's wrong?

    I don't why but, when I emailed the auther and asked to use "adduser". He told me not to !! And told me again to follow those steps:
    follow 1 and 2 step, not using adduser and then change password using
    command passwd to whatever you want.

    Thanks
     
  2. jcsd
  3. Sep 29, 2005 #2

    dduardo

    User Avatar
    Staff Emeritus

    The line should read:

    pppuser::1001:1001:,,,:/home/pppuser:/usr/sbin/ppplogin

    I got rid of the x after "pppuser:"

    Where you have x that is where the md5 hashed password goes. You might be confusing the authenication to thinking you actually have a nonstandard password.
     
  4. Sep 29, 2005 #3
    As always you'r right dduardo :D
    The problem solved but still I can't login.
    I followed the structions on the page:
    http://tvilda.stilius.net/callback_en.php
    But when I want to dial from a win box, I get Access denied, the user or pass is unknown on the domain.
     
  5. Sep 29, 2005 #4

    dduardo

    User Avatar
    Staff Emeritus

    Did you restart pppd when you changed the password?

    /etc/init.d/pppd restart

    Also, I would try from another linux box to try to dial into the server using kppp or something similar. Windows can be funny with authentication.
     
  6. Sep 30, 2005 #5
    You know, I think one of the most important tasks of a good programmer is to restart his machine at least once in a hour :D Whenever I changed the configurations I either typed "init q" or restarted the machine.

    You know when I set the pppd without "login" option. It works well. It shows that I'm very close to it. But without authentication all that I've done in last 3 days is nothing :((
     
  7. Sep 30, 2005 #6
    I tried to connect via a linux box as ddura told me. The authentication failed again :((
     
  8. Sep 30, 2005 #7

    dduardo

    User Avatar
    Staff Emeritus

    Can you login to pppuser from the server directly?

    su pppuser
     
  9. Sep 30, 2005 #8
    Tomorrow I'll check it with "su". But I tried to login in a terminal directly, I don't remember exactly but it was something like this:

    Debianserver $: login: pppuser
    Debianserver $: password: 123
    Debianserver $: pppd: the remoet client must athenticate itself
    Debianserver $: pppd: but I can't find any secret(password) for it


    Debianserver: login:
     
    Last edited: Sep 30, 2005
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Linux PASSWD
  1. Installing linux (Replies: 3)

  2. Running Linux (Replies: 9)

  3. Highlighting in linux (Replies: 4)

  4. Linux or Windows? (Replies: 54)

  5. Linux in Physics (Replies: 4)

Loading...