Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

MCNPX do not finish a simulation possible bug in the code

Tags:
  1. Aug 11, 2016 #1
    I am testing the MCNPX plugging MCUNED to make calculations with neutron generators. After the compilation many examples to test the installation are provided. But one of them (I attached the code below) starts but it never finish. Just keeps in the first rendezvous. I first though in a problem in the compilation to do parallel calculations, but I realized that I had the same problem when I tried to run the input in serial or with MCNP6 or MCNPX without MCUNED. Any idea where the problem may be? I also tried reducing the initial number of particles (from 1E5 to 10) to see if was only a matter of time. But it keeps always at the first rendezvous. The programm is perfectly running with other imputs (for example the same one give it below but changing the par=a to par=h)

    The code is the following.

    test light ion table: a on Cu63
    1 1 -8.94 -1 imp:n,p,h,d,t,s,a=1
    2 0 1 imp:n,p,h,d,t,s,a=0

    1 so 1

    mode n h d t s a
    cut:n,p,h,d,t,s,a J .001 0 0 $ Force analog capture
    m1 29063 1
    lca 7j -2
    sdef par=a erg=10 vec 0 0 1 dir=1
    c
    e0 .001 99i 10.1
    c0 -.9 8i 0 8i .9 .95 .97 .99 .995 1 T
    fq0 e c
    c
    f011:n 1
    ft011 frv 0 0 1
    c
    f021:p 1
    ft021 frv 0 0 1
    c
    f091:h 1
    ft091 frv 0 0 1
    c
    f311:d 1
    ft311 frv 0 0 1
    c
    f321:t 1
    ft321 frv 0 0 1
    c
    f331:s 1
    ft331 frv 0 0 1
    c
    f341:a 1
    ft341 frv 0 0 1
    c
    nps 100000
    c prdmp 2J -1
    print
     
  2. jcsd
  3. Aug 16, 2016 #2
    Thanks for the thread! This is an automated courtesy bump. Sorry you aren't generating responses at the moment. Do you have any further information, come to any new conclusions or is it possible to reword the post? The more details the better.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted



Similar Discussions: MCNPX do not finish a simulation possible bug in the code
  1. Fatal Error in MCNPX (Replies: 2)

  2. MCNP5 Versus MCNPX (Replies: 6)

  3. MCNPX input (Replies: 2)

  4. MCNPX Lattice (Replies: 1)

Loading...