Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Network troubleshoot

  1. Jun 15, 2004 #1
    HIe!
    I am conected to the LAN network with 13 nodes connected via router hub,and switch.O/S is Win 98 in all computer. The thing is one of this computer comp1 can access the internate but can not browse the LAN. The strange thing Is I can ping all aother computer from comp1 in this LAN and get the replied back but can't see them dislayed in the network neighbouhood. There is no access when i try to connect to comp1 from other computer. I also tried to check up with the network configuration and it all seem to be fine. Any suggestion could be great appriciate.
     
  2. jcsd
  3. Jun 15, 2004 #2

    Integral

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    Tell us more about your network config on the troublesome system.

    What protocols are installed?
    What is your primary protocol?
    What is your primary network logon set to?

    Are all systems the same?

    The more info you provide the easier it will be to help you.

    I have had this problem in the past. Sometimes simply logging off then back on will will fix it.
     
  4. Jun 15, 2004 #3
    TCP/IP seems to be isntalled and working (ping is an TCP/IP utility)

    -Check to see if “File and Print sharing for Microsoft Networks” is checked on \\comp1 (You will find this setting on the network properties dialog box) (This is most likely the problem)

    -Also check to see if the workgroup name is the same on \\comp1 as it is on the other PCs.

    -If you are still not able to resolve UNC names from \\comp1 then resolve their names using the LMHOST file... its been awhile since I have worked with Win98 but its either directly under the windows directory or under windows\system32. Open that file using notepad and type the IP address followed by a space and then a computer name of another node on the network. You will have to bounce the machine after the change (unless you have edited this file before.) Also make sure the LMHOST file doesn’t have an extension...It needs to be LMHOST with no extension. Do not proceed the entry with the # character.... the # character is used just to show examples of the file and windows will not do anything with the entry if there is a # character in front.

    Test the connection out after the change by clicking "start" "run" type "\\comp2" (if \\comp2 is the name you entered in the LMHOST file proceeded with its IP address. Do that instead of using network neighborhood so you don’t have to worry about the master browser having time to update.

    HTH,

    P.S. TCP/IP is installed and working fine cause you mention you are browsing the Internet. FQDN name resolution is working fine again because you are browsing the internet. UNC name resolution is not working fine cause you are not opening nodes using the UNC naming convention. LMHOST and WINS helps resolve this.
     
    Last edited: Jun 16, 2004
  5. Jun 16, 2004 #4

    Thanks Syano for your good reponce! I realy appriciate you help. It is realy that I use TCP/IP protocal and Primary window logon is set to Cliant for microsoft Networks. File and printer sharing for microsoft netwoks is checked on on comp1 and also the workgroup name is correct as it is supposed to be.
    All other configuration seems to be set properly eg. IP address, Subnetmask, Gateway and DNS.

    I follow the procedure of using the LMHOST file as you direct me but found problems on where exactly to type the IP Address and the computer name. The view of LMHOST as follow:-

    # Copyright (c) 1998 Microsoft Corp.
    #
    # This is a sample LMHOSTS file used by the Microsoft Wins Client (NetBios
    # over TCP/IP) stack for Windows98
    #
    # This file contains the mappings of IP addresses to NT computernames
    # (NetBIOS) names. Each entry should be kept on an individual line.
    # The IP address should be placed in the first column followed by the
    # corresponding computername. The address and the comptername
    # should be separated by at least one space or tab. The "#" character
    # is generally used to denote the start of a comment (see the exceptions
    # below).
    #
    # This file is compatible with Microsoft LAN Manager 2.x TCP/IP lmhosts
    # files and offers the following extensions:
    #
    # #PRE
    # #DOM:<domain>
    # #INCLUDE <filename>
    # #BEGIN_ALTERNATE
    # #END_ALTERNATE
    # \0xnn (non-printing character support)
    #
    # Following any entry in the file with the characters "#PRE" will cause
    # the entry to be preloaded into the name cache. By default, entries are
    # not preloaded, but are parsed only after dynamic name resolution fails.
    #
    # Following an entry with the "#DOM:<domain>" tag will associate the
    # entry with the domain specified by <domain>. This affects how the
    # browser and logon services behave in TCP/IP environments. To preload
    # the host name associated with #DOM entry, it is necessary to also add a
    # #PRE to the line. The <domain> is always preloaded although it will not
    # be shown when the name cache is viewed.
    #
    # Specifying "#INCLUDE <filename>" will force the RFC NetBIOS (NBT)
    # software to seek the specified <filename> and parse it as if it were
    # local. <filename> is generally a UNC-based name, allowing a
    # centralized lmhosts file to be maintained on a server.
    # It is ALWAYS necessary to provide a mapping for the IP address of the
    # server prior to the #INCLUDE. This mapping must use the #PRE directive.
    # In addtion the share "public" in the example below must be in the
    # LanManServer list of "NullSessionShares" in order for client machines to
    # be able to read the lmhosts file successfully. This key is under
    # \machine\system\currentcontrolset\services\lanmanserver\parameters\nullsessionshares
    # in the registry. Simply add "public" to the list found there.
    #
    # The #BEGIN_ and #END_ALTERNATE keywords allow multiple #INCLUDE
    # statements to be grouped together. Any single successful include
    # will cause the group to succeed.
    #
    # Finally, non-printing characters can be embedded in mappings by
    # first surrounding the NetBIOS name in quotations, then using the
    # \0xnn notation to specify a hex value for a non-printing character.
    #
    # The following example illustrates all of these extensions:
    #
    # 102.54.94.97 rhino #PRE #DOM:networking #net group's DC
    # 102.54.94.102 "appname \0x14" #special app server
    # 102.54.94.123 popular #PRE #source server
    # 102.54.94.117 localsrv #PRE #needed for the include
    #
    # #BEGIN_ALTERNATE
    # #INCLUDE \\localsrv\public\lmhosts
    # #INCLUDE \\rhino\public\lmhosts
    # #END_ALTERNATE
    #
    # In the above example, the "appname" server contains a special
    # character in its name, the "popular" and "localsrv" server names are
    # preloaded, and the "rhino" server name is specified so it can be used
    # to later #INCLUDE a centrally maintained lmhosts file if the "localsrv"
    # system is unavailable.
    #
    # Note that the whole file is parsed including comments on each lookup,
    # so keeping the number of comments to a minimum will improve performance.
    # Therefore it is not advisable to simply add lmhosts file entries onto the
    # end of this file.



    The LMHOST file in my computer contain hiden file extansion sam Do I have to remove the file extansion? Also which IP address I suppose to type? Is it the IP address of another node which I should type its name? Thank you guys again and sorry if i am a trouble maker! It have been two days now without working in this node please help me!!!
     
  6. Jun 16, 2004 #5
    No problem Emanueli.

    opps.. I just looked… the file is called LMHOSTS not LMHOST… I guess you already know that though.

    You can delete everything that is currently in the LMHOSTS file. You don’t have to but if you do then windows will have less to parse to get to the “real” entry that you are about to make in it.

    Do this… go to another PC and find its computer name and IP address. (Right click on Network Neighborhood, then properties to find computer name) (start, run, winipcfg to find IP address)

    Let’s say computer name is comp3 and IP is 10.0.0.30. Go back to \\comp1’s LMHOSTS file and add this “10.0.0.30 comp3” without the quotations. Close and save the file and remove the .sam extension. Reboot \\comp1 then from \\comp1 click start, run, type \\comp3 and hit enter and see if you hit it. Go ahead and share a directory on \\comp3 before hand.

    Note: Do not use the double back slashes (\\) in the LMHOSTS file entry. But do use it when you test the connection by start, run, \\comp3.

    Also… there is another file named HOSTS in the same directory.. go ahead an add the identical entry to this file as well and remove the .sam extension.

    If this does not resolve the issue it will get more complex to troubleshoot having to look at things like winsocks, bindings and other settings.

    Also... under “Client for Microsoft Networks” make sure “Log on to Microsoft NT Domain” is not checked.

    One more thing.. if the LMHOSTS and HOSTS entries work it will become a real pain in the neck if your clients are using DHCP… but still do it for troubleshooting purposes.

    You could install NetBEUI on all client machines to resolve the problem as well. But that protocol is extremely outdated. But it would work.

    HTH

    P.S. One more thing on what I thought the problem originally was… There are two places you will see something like File and Print Sharing for Microsoft Networks. One is the same area as you see the protocols, adapters, and clients, and the other is below there… It looks like a button… called this exactly “File and Print Sharing…” click on that button and there are two check boxes… one for files and the other for printers… make sure both of those are checked…
     
  7. Jun 25, 2004 #6
    One Thought

    Sooooo not trying to be a PITA and unhelpful, but the reality of Win98 is that it does not network very well. Mapped share drives disappearing, shared printers not working and general network access issues plague Win98.

    The OS is now 6+ years old. Have you considered upgrading to (at least) Win2000? Very stable and with a simple Win2k server to authenticate to (can be as little as a P3 500 box) you will eliminate most of these problems.

    Also, it is generally a good practice to use switches instead of hubs. You mentioned both so I am not sure what you are using, but I thought it was worth mentioning.

    Either way, Syano makes great reccommendations and I wish you luck. Issues like this are not fun to deal with.
     
  8. Jun 25, 2004 #7
    Thanks you all for your recommandation and good advice. Althogh win 98 does not working very well in most networking issue I am sure their is a number of people still using the O/S and they will get a very helpful hint by reading this thread! The thing is I manage to solve the problem by click on start menu,control panel,network, click on configaration tab and remove ethernet adapter driver,clients for microsoft network,TCPIP,file and printer sharing for microsoft networks, After doing this I reboot the system to make changes and went back again to add what I had removed. Doing this solved the problem and now I am able to access the network. I Will take your advice of upgrading the O/S as it seems it will eliminate a lot of problem. Thanks SYANO and BIG HAM for your good recommendations. GOOD LUCK. CIAO!!!
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Network troubleshoot
  1. Digital Networks (Replies: 2)

  2. Network motifs? (Replies: 2)

Loading...