Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

New and old LaTeX problems.

  1. Mar 8, 2008 #1

    Hurkyl

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    Someone sent me a private message with LaTeX in it. The images are never of the formula that the messanger wrote, but instead of a formula I've recently seen. Reloading the image doesn't help (that works for images in the main forums) -- and the image I actually see has changed over time.



    If the LaTeX has errors in it, the parser doesn't always generate an error. For example,

    [tex]\red 5[/tex]
     
  2. jcsd
  3. Mar 8, 2008 #2

    Moonbear

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    That's because LaTeX isn't enabled in PMs. It would be nice if the person writing it simply got an error message telling them it's not enabled rather than letting them think it's working and sending you nothing of use.
     
  4. Mar 8, 2008 #3

    robphy

    User Avatar
    Science Advisor
    Homework Helper
    Gold Member

    If I recall correctly, if you REPLY to the message and PREVIEW, you'd see the intended message. If you send a reply with LaTeX, you could give these instructions to the recipient.

    I've tried LaTeX in the blogs and in PMs... no luck.
    I think LaTeX on the PF-blog has been broken as well.
     
  5. Mar 8, 2008 #4

    Kurdt

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    Latex in blogs and Pm's are not enabled. Perhaps a note in the general rules might be prudent.
     
  6. Mar 8, 2008 #5

    Hurkyl

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    The main thing I'm worried about is that the forum software handles these cases incorrectly.
     
  7. May 7, 2008 #6
    As it stands, this is a great website and a good place to search for and share information but is there any chance you could enable latex in the blogs? I recently posted a couple of blogs that included latex and immediately noticed a problem (interestingly, if you click on the latex image in the blog, the correct information in text is shown in the pop-up box so it still has some use). I did a search in this forum and it appears a number of people would like to use latex in blogs so are there any plans for it to be implemented into blogs in the near future?

    regards
    Steve
     
    Last edited: May 7, 2008
  8. May 7, 2008 #7

    -Job-

    User Avatar
    Science Advisor

    I have a forum plugin that parses LaTeX everywhere, including:
    - posts
    - blogs/comments
    - messages
    - previews
    - signatures
    - events
    - notes
    - announcements

    It's not finished yet, but it's getting there. Here's a demo: http://www.bloo.us/forums

    There's some technical details in parsing each content type, but otherwise it's done in the same place and the same way as forum posts.
     
    Last edited: May 7, 2008
  9. May 7, 2008 #8
    Keep me updated -Job-
     
  10. May 20, 2008 #9
    Looks interesting -Job-. In the meantime, does anyone know of a decent blog website that supports LaTeX? I tried WordPress but kept getting a load of error messages when I tried to preview, I think there is a slight variation in how you organise the text.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: New and old LaTeX problems.
  1. New Latex Format (Replies: 2)

  2. For those new in Latex (Replies: 2)

Loading...