Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

New hard drive setup

  1. Feb 6, 2005 #1
    I just got a second hard drive so that i could install FreeBSD and slackware onto it for my computer. (got it because i was out of partitions on the first drive).

    The first drive is a serial ATA WD drive, the second drive is an IDE WD drive. I just want to set the system up so that it will basically startup with grub bootloader, and then let me pick which OS to boot from, listing them from either drive.

    This is my first system with multiple hard drives, so my question is simply, how do i do this?
  2. jcsd
  3. Feb 8, 2005 #2
    Well i've managed to set everything up, almost.

    I'm having trouble booting up slackware on the second drive, all the other OSs boot up fine, including FreeBSD on the same drive as slackware. THe problem is i don't know how to set grub.conf for slackware.

    First drive: SATA, /dev/sda1 = WinXP
    /dev/sda2 = /boot (fedora)
    /dev/sda3 = / (fedora)
    /dev/sda5 = swap
    /dev/sda6 = /home

    Second Drive: IDE /dev/hdb1 = FreeBSD
    /dev/hdb2 = / (Slackware)
    /dev/hdb4 = /home (slackware)
    /dev/hdb5 = /boot (slackware
    /dev/hdb6 = swap (slacware)

    I have grub installed on the MBR of the IDE disk, which is set to slave (the SATA disk does not have master/slave settings, it autoselects, i think)

    I can boot into WinXP, FreeBSD, and Fedora all fine. However i cannot boot into slackware for some reason, and i can't seem to get the settings in /boot/grub/grub.conf (on fedora's partition) correct to boot in to it.

    vmlinuz-ide-2.4.29 is the kernel for slack in /boot (slackware) (i have all the slack ware partitions mounted in fedora under /slack/, so i can access them, i just can't seem to boot slack)

    So my question is simply, what should i have in grub.conf to get slackware to boot correctly?
  4. Feb 8, 2005 #3


    User Avatar
    Staff Emeritus

    I would think the slackware entry should be like this:

    root (hd1,4)
    kernel (hd1,4)/{kernel-name} root=/dev/hdb2
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: New hard drive setup
  1. Hard Drive (Replies: 12)