Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

New Here and Thanks!

Tags:
  1. Aug 13, 2015 #1
    I actually registered primarily to thank another user (lordloss). My TI-89 Titanium wasn't responding to anything. Putting in batteries turned it on, but then it'd be locked up. I tried all the tips and tricks (key combinations, etc.), but it wasn't recognized by Windows to send new firmware and generally seemed unresponsive after initially turning on.

    Google brought me to this thread:

    https://www.physicsforums.com/threads/frozen-ti-89.410702/

    I had tried everything else, so I figured why not? It's a hot day (around 91 f), so I took out all of the batteries and left it in my car for about 2 hours. I just got it out. It was hot, but not too hot to touch. I waited a couple of minutes for it to cool down and gave it a try. It works! Seems good as new. I would assume the chances of it croaking on me are higher than with a brand new one, but hey, I already owned this one.

    Anyway, as for me otherwise, finding this forum is timely. I'm taking engineering physics labs to supplement AP Physics C exam credits. I work for an electrical engineering company and want to eventually be an EE myself (currently a tech).
     
  2. jcsd
  3. Aug 13, 2015 #2
    Welcome to PF!
     
  4. Aug 13, 2015 #3
    I should add: the USB port did not work at all when it was in that frozen condition. Even if I used the "insert battery while holding down APPS" shortcut to get to the "Waiting to receive." Nothing would happen when I inserted the USB port. After doing the reflow with my hot car (haha), it worked immediately. I was able to upgrade the firmware to the current version.

    So, I guess I'm posting this for anyone else out there trying to figure out what to do with their frozen TI-89 Titanium. If none of the shortcut key combinations work to reset it, and your computer doesn't recognize anything's even attached, it's probably hardware. In which case, a hot car might do the trick. I guess I never tried leaving all batteries out for 2 hours at normal temperatures, so I suppose technically that could have been what fixed it, but I doubt it. I had left them out for probably half an hour at one point, so that should have reset it if 2 hours was going to.
     
  5. Aug 13, 2015 #4

    berkeman

    User Avatar

    Staff: Mentor

    Welcome to the PF, Jake.

    Since this forum is for New Member Introductions only, I'd recommend that you start a new thread in the appropriate forum here with your tips and experiences. :smile:
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: New Here and Thanks!
  1. New here! (Replies: 2)

  2. New here (Replies: 1)

  3. New here! (Replies: 1)

  4. New here (Replies: 1)

  5. New here (Replies: 1)

Loading...