Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Plot problem with Mathmatica

  1. May 15, 2006 #1

    I've done the following but the plot that I get is not what it has to be at the big values of the frequency f. The graph should be smooth but isn't..


    Does somebody know where the problem is?!
    The nb file is attached.



    Attached Files:

  2. jcsd
  3. May 17, 2006 #2
    Hmmm. Strange - I ran your notebook, and I get a smooth curve. Perhaps your computer is having some pretty severe rounding errors. Kind of strange...
  4. May 17, 2006 #3
    well, today it works fine over here too..but I didn't change anything..I think it simply depends of the Mathematica's mood..couldn't find any other reason :wink:

    thanks for running the file,

  5. May 17, 2006 #4


    User Avatar

    Look at your y-axis!

    Check to make sure your values aren't close to machine precision.
  6. May 17, 2006 #5
    As J77 said, look at that y axis, the actual variations in your graph are so small that you can't actually tell what the difference between them is. Looks more like a scale problem, than any problem with mathematica.
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Plot problem with Mathmatica
  1. Mathcad Plot Problem (Replies: 0)

  2. Plotting in gnuplot (Replies: 2)

  3. Can Excel plot graph? (Replies: 9)