Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Plotting and graphics in C++

  1. Jan 5, 2015 #1
    Hi All,

    Not sure if this is the right place for this thread but it seemed like it was.

    I have been trying for two whole days to get some plotting tools up and running that will work with my:
    OSX 10.8.5, Xcode 5.1.

    I have tried MathGL, Plplot, Gnuplot, Chplot, matplotpp, etc.

    I get errors that I can't seem to fix when installing and/or running these. There's either missing files, linker errors, etc
    I think my main issue is upon install when I am supposed to run 'make' in the active directory it does nothing on my machine. I have looked up all my errors, including the build errors, and tried valiantly to get just ONE of these working. I don't think it should be this hard?

    Does anyone have any suggestions as to an easy install of a C++ plot library?

    I also have an Ubuntu machine which I may just switch to, but I was really hoping to use Xcode being that my thesis work will be on a Mac/Xcode platform.

    Thanks in advance, any help is appreciated.
     
  2. jcsd
  3. Jan 5, 2015 #2
    OK, so, VTK seems to be installing... I got through the build and configure... fingers crossed
     
  4. Jan 5, 2015 #3
    And it errors out at 45% during install...... If anyone can help I'd appreciate it, this is becoming frustrating
     
  5. Jan 5, 2015 #4

    phinds

    User Avatar
    Gold Member
    2016 Award

    One thing you might look at if you are having trouble running a make file is to see if your PATH declaration has all the directories in it that are required.
     
  6. Jan 5, 2015 #5
    I've noticed that some of these builds have a cMakeList.txt file and if I run: cmake . command it will carry out the list. I've gotten past this just now in VTK but the error and an internet search is telling me that I must "simply remove the -fobjc-gc flag from VTK_REQUIRED_OBJCXX_FLAGS" . I'm trying to do this now I guess.
     
  7. Jan 5, 2015 #6
    So I've tried to update my CMakeList.txt to fix this error but to no avail: still getting this: error: garbage collection is no longer supported. I was told to "
    simply remove the -fobjc-gc flag from VTK_REQUIRED_OBJCXX_FLAGS." , which I did, and it does not fix the error
     
  8. Jan 13, 2015 #7

    chiro

    User Avatar
    Science Advisor

    When I did a data mining class the lecturer used GNUplot.

    If your make command doesn't do anything you need to make sure the programming tools are setup in your distribution and your user account.

    I would get the make issue fixed before anything else is done.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Plotting and graphics in C++
Loading...