1. Not finding help here? Sign up for a free 30min tutor trial with Chegg Tutors
    Dismiss Notice
Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Printer dilemma

  1. Oct 5, 2006 #1
    Hello,

    I just posted another topic on a brightess problem when viewing videos and I thought that while I was at it, I might as well ask someone for some advice about another problem I'm having. A few months ago I had an old printer, (which really wasn't very old, but I print so little with it I think the ink might have dried up and caused the initial problem). When I tried to print, it would go throught the motions, but I would get a blank page. I took that printer apart, cleaned all the jets in alchohol, basically tried to get all the old ink that might have been clogging the jets. I'm talking, I broke it down to its basic components here. I even spent close to $100 dollars on the 7 ink cartidges. Same problem. So now I bought a Epson Stylus Photo RX620. It's doing the same thing!!!!:cry: :cry:

    Now this was bought at a discount because it was a display model (and I went for it because I was already out $100 on the previous printers ink). I don't feel like taking this one apart. Could it be a software problem? Or is it me???o:)
     
  2. jcsd
  3. Oct 5, 2006 #2

    DaveC426913

    User Avatar
    Gold Member

    You're peeling the sticker off the ink cartridges before installing them, right? :biggrin:
     
  4. Oct 5, 2006 #3
    :rofl: :rofl: Yes. <got me>
     
  5. Oct 5, 2006 #4

    NoTime

    User Avatar
    Science Advisor
    Homework Helper

    Have you installed the correct printer drivers?
     
  6. Oct 5, 2006 #5
    Did you actually not do that or was it sarcasm?
     
  7. Oct 6, 2006 #6
    I installed whatever was included on the installation disk, which I assume is compatible with windows XP. The first printer worked fine the last time I had used it. It had just been so long in between uses I figured that the ink probably just dried up in the jets or something. Running the nozzle cleaners and such didn't work either.
     
  8. Oct 6, 2006 #7
    Extreme sarcasm. DaveC426913 is just a funny guy and getting me back for something I said in another thread.
     
  9. Oct 6, 2006 #8

    NoTime

    User Avatar
    Science Advisor
    Homework Helper

    Is it a parallel or serial printer?
    Did you make the new printer the default printer or is the old printer still the default?

    If the thing is a USB printer you may have a USB conflict. Try unpluging all other USB devices. Had one of mine do the blank page thing for this reason. Got it to work with a driver update, but only when I was in admin mode.
     
  10. Oct 7, 2006 #9
    I don't know the difference between the two (parallel/serial) but it is my default printer.
    I think you might have hit the nail on the head with the USB thing. I tried plugging it into another port and this icon popped up in my task bar at the bottom-rt corner of my screen. I clicked on this and it said the device would perform better if connected to a high speed USB port. A quick system check confirms I don't have a high speed USB port.
    I was able to perform a nozzle check using the LED display and the functions built into the printer itself and it printer the test pattern just fine. F-ing computers!!
    I remember after I bought it and it didn't work right off the bat I just was too frustrated with it to mess around.....and there it sat.
    Thanks buddy. You've been a tremendous help NoTime.:smile:
     
  11. Oct 7, 2006 #10
    That was it! Thanks again for your help.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Printer dilemma
  1. Printers on UNIX (Replies: 2)

  2. Printer Garbage (Replies: 16)

  3. Printer misbehaving (Replies: 5)

  4. Printer alignment? (Replies: 1)

Loading...