Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Problem installing Java

  1. Jun 25, 2012 #1
    I have been trying to install Java and failed. After installation completed and close the installation window, an error message popped up saying:

    "Wrapper.CreateFile failed with error 5: access denied."

    The java don't work. I tried reinstalled a few times and still failed. Please help.

    Thanks

    Alan
     
  2. jcsd
  3. Jun 25, 2012 #2
    Google for exactly this

    java "Wrapper.CreateFile failed with error 5: access denied."

    finds a few suggestions, but none of them give me a really good confident feeling.

    Perhaps the one Microsoft fix-it suggestion might be worth a try.
     
  4. Jun 25, 2012 #3
    Thanks
    I already tried the ones posted. I tried the 64bit version as my computer runs Window 7 professional 64 bit. It didn't even work. So I am back to the normal version.

    I tried uninstalling, then installed under Administrator and still no go.

    I download from Java again and still no luck. I have Norton and I did a full scan and even download the special program to clean the computer already.

    Lastly, I actually went on:

    http://www.java.com/en/download/testjava.jsp

    To check and verify my Java is running ok and it came back and said everything is fine. I am at a lost.
     
  5. Jun 26, 2012 #4
    Anyone please?

    I confirmed it's my computer. I pulled out my older laptop and did the same and it's all good.
     
  6. Jun 27, 2012 #5

    Borg

    User Avatar
    Gold Member

    What is the name of the installation file that you are using and where did you get it from? Are you trying to install the runtime version (JRE) or do you plan to use it for programming(JDK)? Also, please go into the control panel, open the Add or Remove Software Programs section and list all of the Java versions that it says that you have.

    The only place that I would install Java from is Oracle's web site. Other vendors can add on their own code that may or may not work. The official place to get it from is here - Java downloads. I haven't worked with version 7 but I know that the Java SE 6 Update 33 version about halfway down the page is very stable.

    Once you've reported what's loaded, we can go from there.
     
  7. Jun 27, 2012 #6
    I got it from www.java.com [Broken]. It is version 7.

    I loaded onto another computer and it works perfect. Just the one I am using all the time. I even want on Java site and test the program and it said everything is ok. I just have problem log on to the USPTO site. I have to use the other computer to do that. I would like to fix this computer if possible.
     
    Last edited by a moderator: May 6, 2017
  8. Jun 27, 2012 #7

    Borg

    User Avatar
    Gold Member

    It could be different browser settings, conflicting Java versions, or any number of other possibilities. Could you at least go into the Control Panel to verify what is installed?
     
    Last edited by a moderator: May 6, 2017
  9. Jun 27, 2012 #8

    chiro

    User Avatar
    Science Advisor

    Hey yungman.

    This looks like a typical permissions problem.

    I would check the settings for Java with regard to permissions. If Java is allowed to read and write a file, and its the OS, then you need to make sure your drive doesn't have weird permissions to stop the program from creating a file.

    The other thing I would check is that you have cookies enabled. If you don't have these enabled and the program is trying to create one then nothing will work, so make sure you enable them.

    Make sure the temp directory and your other directories for things like cookies are not write protected and allow the ability to create and modify files.

    Also check that you have enough disk space (it happens) on the drive that the internet browser is working in.
     
  10. Jun 29, 2012 #9
    "access denied" is the hint. Take a look at your Norton configuration to be sure you don't have some component blocked from the days before you used Java. I block all kinds of garbage I don't want running on my system. Perhaps there is something you have blocked from days gone by.
     
  11. Jul 3, 2012 #10
    Thanks everyone, my friend came over and fixed it for me.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Problem installing Java
  1. Java problem (Replies: 4)

  2. Installing java 1.5 (Replies: 1)

  3. Java problem. (Replies: 4)

Loading...