Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Problem with flash memory

  1. Jan 23, 2009 #1
    It is a Veritech 2GB flash memory.. I tried it on some computers.. they recognize it, but when I double click it to open it, it doesn't open and a message box says that it's not formatted, do you want to format it?... I tried to scan it by antivirus but nothing appeared... I tried to format it by right clicking it.. it didn't work.. I tried formatting it from the command prompt but it even didn't work...

    As you can see in the attached picture, the disk is shown full and it says 0 bytes used!! also it shows no file system! I think a virus corrupted the file system FAT32. What do you think and how could I fix this flash memory?? any help?
     

    Attached Files:

  2. jcsd
  3. Jan 23, 2009 #2
    If it came with a disk you could format it from that. You might be able to download a program to format it. I doubt that it has a virus.
    Are you sure that you are looking at the right removable disk, because F: could be a card slot or something else that is empty. What is MR Hazim?
     
  4. Jan 24, 2009 #3
    It's me Mr. Hazim :)... this is my flash not anything else. No disk came with it.. Could you please give me a link for a program to format the flash memory?
     
  5. Jan 24, 2009 #4

    mgb_phys

    User Avatar
    Science Advisor
    Homework Helper

    Just right click on it and select format.
    make sure it says fat32 and uncheck the quick format box.

    The problem is likely to be due to either damage to the stick or to poor software in the controller chip on the stick. These devices are built to very low margins and the implementation of the disk emulator in them isn't always perfect, often they will wokr on one machine and not another or only on one type of windows
     
  6. Jan 25, 2009 #5
  7. Jan 26, 2009 #6
    It didn't work...format failed... I think the memory is broken.. It doesn't matter, here 2GB flash memory costs only 5$... 4GB 7$ with warranty.. Anyway thank you all very much
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Problem with flash memory
  1. Memory address problem (Replies: 6)

Loading...