Regarding LM324OP-AMP output

  1. At output of LM324, 50 mV low frequency (Around 5 to 10 Hz) oscillations were observed when it was used as attenuator for pure DC application........what could be the reason?
  2. jcsd
  3. berkeman

    Staff: Mentor

    Welcome to the PF.

    Could you please post your schematic showing all connections and power supplies, and describe how you made this measurement?
  4. it is just difference amplifier with gain of 1/5

    Attached Files:

  5. You have not post the value of the components. BUT LM324 is unity gain stable, your circuit cannot cause oscillation. It must be something else. For low frequency oscillation, most likely is power supply. Do you have by pass cap on the power supply?

    Take a picture of your circuit. Layout is everything, circuit is always very simple. Your circuit has no problem on the schematic.
    Last edited: Apr 12, 2012
  6. Value of components are R119 =R110=99k , R112=R117=499k....gain is 1/5 is atteneuator...and input is 3.2 V DC
  7. Your resistor value is a little high for my taste unless it is necessary.

    this is just a simple differential amp. You have a cap C93 that make the circuit unbalance, take it off and see whether the noise goes away. If you need the cap, you have to put one across R110 to balance to get common mode cancellation. But this is only affecting high frequency end, I don't think this is a problem. But worth a try.

    If that don't solve the problem, take a picture. With such high resistance, layout is very critical, long leads in the wrong spot can pick up all sort of noise.
  8. Capacitor is Not connected(NC) that noise?
    what it should be called? I have attached o/p waveform ....Each division is 50 that noise? what it should be called?

    Attached Files:

  9. Waveform is captured in CRO AC coupling mode...Even in multimeter oscillation was clearly visible as digits kept on changing...
  10. AlephZero

    AlephZero 7,248
    Science Advisor
    Homework Helper

    Have you tried swapping the op-amp? Occasionally you get a defective one that "works" but has a high noise level.
  11. I need a picture of your physical circuit. I want to see your layout. The waveform don't look oscillation, it is some noise you pickup.

    I also need a scope picture with longer time scale to see the repetition. Tell me the time scale as I can't see it. It looks like some periodic signal from the picture, but need wider time scale to tell.

    Picture first, talk is cheap at this point, if you did it right, the circuit should work, no if and buts about it.
Know someone interested in this topic? Share this thead via email, Google+, Twitter, or Facebook

Have something to add?