Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Solidworks installation help

Tags:
  1. Jul 26, 2011 #1

    Femme_physics

    User Avatar
    Gold Member

    Last edited by a moderator: May 5, 2017
  2. jcsd
  3. Jul 26, 2011 #2

    Astronuc

    User Avatar

    Staff: Mentor

    Is that your computer or the university's or department's computer? If the latter, perhaps you have a restricted user account rather than an administrator account. I believe an admin account is necessary in order to install the software, otherwise an admin must set the permissions.

    By student account, I'm guessing it's a Win7 user or guest account with limited permissions.

    Talk to the university's or department's IT person(s).
     
  4. Jul 26, 2011 #3

    chiro

    User Avatar
    Science Advisor

    It sounds like you are trying to install on a uni computer.

    The problem is with your account rights (computer account).

    You won't have the privileges most likely to change what you need to.

    My advice is to contact your IT support for your university and tell them the exact message you get and they will either probably a) update the privileges so you can install it or b) Install the program for you on your profile and your login script will be updated so that when you log in you will see the program and can use it.

    If this is on a computer at your uni see the above.

    If its on your own computer, then go to the folder its talking about, click on properties and make sure all the accounts have "write" access. In other words open up my computer, go to the folder, write click on folder, go to properties, go to security, and make sure all the users (especially Administrator and SYSTEM) have write properties allowed.

    Hopefully this helps you.
     
  5. Jul 26, 2011 #4

    Femme_physics

    User Avatar
    Gold Member

    I'm trying to install it in my computer, not the college's. The college already have the solidworks installed. Why should I be doing their work for them?

    Trying to do what you told me chiro...sec
     
  6. Jul 26, 2011 #5

    Femme_physics

    User Avatar
    Gold Member

    Last edited by a moderator: May 5, 2017
  7. Jul 26, 2011 #6

    chiro

    User Avatar
    Science Advisor

    You have an older version of windows than me.

    Look into advanced or in sharing. It has to be in one of those. As soon as you see things with security and privileges, that's what you need to update.
     
  8. Jul 26, 2011 #7

    Femme_physics

    User Avatar
    Gold Member

    I genuinely see nothing that even resembles security. I tried removing the "Read-only" tab but it didn't help.

    I don't know why it gave me an error to begin with since I always work as admin with max privileges with my laptop

    And I have XP pro (IIRC it's pro and not home if it matters)
     
  9. Jul 26, 2011 #8

    Astronuc

    User Avatar

    Staff: Mentor

    Be careful about what you show on the screen post.

    If it's read-only, one needs to change the permission. I think all one needs to click the read-only box off, so that it allows read-write.

    If that doesn't work, look under Advanced.
     
  10. Jul 26, 2011 #9

    jhae2.718

    User Avatar
    Gold Member

    It looks to me that you need to make that directory writable, i.e. uncheck Read Only. Since you're running a personal copy of Windows XP, your account should have administrator privileges, which would be the other concern. I would go ahead and make sure the entire "C:\SolidWorks Admin" directory is writable.

    To access the advanced security permissions for directories in Windows XP, follow this KB article: http://support.microsoft.com/kb/307874. By default, Windows XP uses something called "Simple file Sharing", which is a watered down version of the actual NT access control features.
     
    Last edited: Jul 26, 2011
  11. Jul 26, 2011 #10

    I like Serena

    User Avatar
    Homework Helper

    Hi Fp! :smile:

    It seems unlikely that you wouldn't be able to write in the directory, since you were apparently able to create the directories in the first place.
    The fact that you could create the directories also shows that you have admin privilege (assuming you have not fiddled with permissions).

    Looking at the directory name "Solidworks 2011 SP2.0 (2)" suggests that you tried it before already. Did you? Or is there another explanation for the "(2)" in the directory name.
    It's probably a good idea to uninstall what you have installed, and afterward delete these directories before trying again.

    It's a known issue with Windows XP that the Read only check box on a folder does not work the way you would expect it to (read: it doesn't work). This is not something to be concerned about though.


    Imho the most likely problem is that your disk is full.
    Is it?
    It's typical for software to give the wrong error message in such a case. :wink:
     
  12. Jul 28, 2011 #11

    Femme_physics

    User Avatar
    Gold Member

    After much debugging turns out the problem was is that I installed the 64bit version on my 32bit windows.... *smacks forehead*

    Thanks though for all the replies!
     
  13. Jul 28, 2011 #12

    jhae2.718

    User Avatar
    Gold Member

    That would do it. Architecture is important. :wink:

    (On another note, I should have noticed the x64 in the installer title and the fact you're using XP, where the x86_64 version is a rarity.)
     
  14. Jul 28, 2011 #13

    I like Serena

    User Avatar
    Homework Helper

    I'm glad the error message put us on the right track! (NOT!!!) :tongue2:
     
  15. Jul 28, 2011 #14

    jhae2.718

    User Avatar
    Gold Member

    I've seen worse error messages (and, TBH, probably written them myself...). :biggrin:
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Solidworks installation help
  1. Install Help (Replies: 1)

  2. Win7 install (Replies: 8)

Loading...