Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Table error in latex

  1. Mar 15, 2010 #1
    dear all..
    I use the following code to generate a table...to my eyes i think no error..but still i get error..
    Code (Text):

    \begin{table}[h]
    \caption{some fitting.}\label{tab:fit}
    \vspace{3mm}
    \centering
    \begin{tabular}[width=1\linewidth]{llll}
    \hline\hline
    Wavenumber & FWHM        & Area        & Force constant\\
    [cm$^{-1}$]  & [cm$^{-1}$] & [cm$^{-2}$] &   [N~m$^{-1}$]\\
    \hline
    19 & 1   & 1 & 5.9 \\
    230 & 3 & 17 & 57.2 \\
    2 & 1    & 23 & 7.8 \\
    35 & 15 & 37 & 12.4 \\
    314 & 30 & 3 & 121.2 \\
    43 & 13.9 & 1  & 4.2 \\
    \hline\hline
    \end{tabular}
    \end{table}
     
    But i can get the table only if i dont use the box brackets [ ] for the unit just below wavelength..when i make box bracket around the unit i always get error..
    thanks
     
  2. jcsd
  3. Mar 15, 2010 #2

    alphysicist

    User Avatar
    Homework Helper

    Hi Rajini,

    Take a look at the output from this table, that has [5ex] at the end of the first line of the table:


    Code (Text):

    \begin{table}[h]
    \centering
    \begin{tabular}[width=1\linewidth]{llll}
    \hline\hline
    19 & 1   & 1 & 5.9 \\[5ex]
    230 & 3 & 17 & 57.2 \\
    2 & 1    & 23 & 7.8 \\
    35 & 15 & 37 & 12.4 \\
    314 & 30 & 3 & 121.2 \\
    43 & 13.9 & 1  & 4.2 \\
    \hline\hline
    \end{tabular}
    \end{table}
     
    When an expression in square brackets is at the end of a line, it is a way of telling LaTeX that you want extra spacing before the next line. But since your next line begins with square brackets, LaTeX thinks you are trying to do the same thing and gives an error. There are several things you can do, but probably the easiest is just put [0ex] at the end of the first line of your table like this:

    Code (Text):

    \begin{table}[h]
    \caption{some fitting.}\label{tab:fit}
    \vspace{3mm}
    \centering
    \begin{tabular}[width=1\linewidth]{llll}
    \hline\hline
    Wavenumber & FWHM        & Area        & Force constant\\[0ex]
    [cm$^{-1}$]  & [cm$^{-1}$] & [cm$^{-2}$] &   [N~m$^{-1}$]\\
    \hline
    19 & 1   & 1 & 5.9 \\
    230 & 3 & 17 & 57.2 \\
    2 & 1    & 23 & 7.8 \\
    35 & 15 & 37 & 12.4 \\
    314 & 30 & 3 & 121.2 \\
    43 & 13.9 & 1  & 4.2 \\
    \hline\hline
    \end{tabular}
    \end{table}
     
     
  4. Mar 15, 2010 #3
    Hi thanks for your reply!.
    actually i made some tables successfully...but for units i use the same as above..but first cell in unit row will be empty so i was fine with my table...but this is my first time making a table with units start from the first cell of the row..so i got this peculiar error...
    anyway i will correct according to your idea..
    thanks again
     
  5. Mar 15, 2010 #4

    D H

    User Avatar
    Staff Emeritus
    Science Advisor

    Getting special symbols in your generated document can be nasty in LaTeX.

    Solution #1: Do it in math mode.
    Code (Text):
    ...
    \begin{tabular}[width=1\linewidth]{llll}
    \hline\hline
    Wavenumber & FWHM        & Area        & Force constant\\
    $[\text{cm}^{-1}]$  & $[\text{cm}^{-1}]$ & $[\text{cm}^{-2}]$ & $[\text{N~m}^{-1}]$ \\
    \hline
    ...
    Solution #2: Use curly braces to escape the square brackets (backslash square bracket doesn't work):
    Code (Text):
    ...
    \begin{tabular}[width=1\linewidth]{llll}
    \hline\hline
    Wavenumber & FWHM        & Area        & Force constant\\
    {[}cm$^{-1}${]}  & {[}cm$^{-1}${]} & {[}cm$^{-2}${]} &   {[}N~m$^{-1}${]}\\
    \hline
    ...
     
     
  6. Mar 15, 2010 #5
    Yes DH..
    seems like latex provides several options...!!
    will try them
    thanks
     
  7. Mar 16, 2010 #6
    Hi both of you,
    [0ex] is simple to use..
    It worked well..
    thanks
     
Share this great discussion with others via Reddit, Google+, Twitter, or Facebook