Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Trouble with LAMMPS

  1. Jun 25, 2008 #1
    I am an undergrad researcher trying to study the melting temperature of gold using an MD simulation with LAMMPS.
    I'm trying to do some preliminary exercises to make sure that I understand how the program works. I'm working on finding the thermal expansion coefficient by heating up a 5 by 5 by 5 block of FCC gold (using the gold eam potential that came with LAMMPS) and measuring the lattice parameter at each temperature. Unfortunately, my sample seems to be melting at 100K :confused:. My units are set to real, which should mean that everything is measured in K. I've tried using nph and temp/rescale, npt, nve with press/brendensen and temp/rescale. All of these result in a complete loss of all crystal structure. I even tried just leaving the sample on NVT without modifying the pressure and it still melted. Any ideas as to why this is happening? Please help!
  2. jcsd
  3. Jul 1, 2008 #2
    Not sure... I also use LAMMPS, though I don't have experience with the problem you're doing. I would suggest posting to the LAMMPS mailing list. It's really active, and the creators of lammps will help you out there. The link is on the main page.
  4. Jul 2, 2008 #3


    User Avatar
    Science Advisor
    Gold Member

    Yeah, the LAMMPS mailing list is an active source for everything related. Since my problems are too cheap to use gold and haven't used it in anything, are you sure your system of units is selected appropriately with respect to the EAM potential (i.e. that it isn't given in metal units)?
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?