Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Usb help

  1. Jun 8, 2012 #1
    I have win7. premiume 64 Bit and a Canan SD1,000 camara.

    The first time I pluged my Camara in win7. gave me a window on the system tray asking me how I want to import the photos.

    So I set it up to Automaticly import all photos to a Folder on the Desktop.

    So now whenever I plug the Camara in it automaticly imported all photos to a Folder on my Desktop.

    It worked for a long time now when I plug my Camara in nothing happens I have to go into Computer then Right click the Camara icone the click Import photos and then it works.

    It does not do it automaticly like I set it up to so I Plug the Camara in and bring up the Auto Play windows and at the bottom of the window were is says Removable Devices nothing is there. I thought if my Camara was there I could reset everything.

    But I did see a Tab that says Reset everything to Default so I click it and then restart the system.

    And when I plug the Camara in nothing comes up asking me how I want to import photos.

    Please help the Camara had no Drivers it never ghad any?

    And when I plug the Camara in and anyother USB device I do hear the Ding Ding sound it is two Dings and they are the same sound?
     
  2. jcsd
  3. Jun 8, 2012 #2

    phinds

    User Avatar
    Gold Member
    2016 Award

    search the internet for driver software for the camera. Just because Windows has a default driver doesn't mean the manufacturer didn't also create a downloadable driver.
     
  4. Jun 8, 2012 #3
    The Camara did not come with a Driver and Canan tells me it does not need one???
     
  5. Jun 8, 2012 #4

    phinds

    User Avatar
    Gold Member
    2016 Award

    you've probably got a registry problem and I have no idea how you might fix it.
     
  6. Jun 10, 2012 #5
    most of these settings are in the registry like phinds said. I would suggest you do a system restore to date BEFORE the problem started.
    Start>All programs>Accessories>System Tools>System Restore

    see if that fixes the problem for you.

    P.S. System restore only deals with system settings not data. So stuff like you documents, music, pictures will be safe.
     
  7. Jun 11, 2012 #6
    Go Control Panel->Device Manager

    In Device Manager if you find Canon Sd1000 camera , click on its properties.
    Try un-installing the default driver and disabling the device.

    Disconnect the camera.

    Download CC Cleaner or any other similiar registry cleaner application ,(most of them are freewares , including CC Cleaner ).
    Clean the registry , temporary files and all the unnecessary stuffs.

    Reboot the system.

    Plug in the Camera and it will automatically re-install the driver for your camera.
    In case it doesn't , then goto device manaager and enable the device and search for driver in" C:\ "

    After its successfully installed , follow the steps you normally do to import the pictures automatically from it to desktop.


    ---------------------
    Lt us know if this works for you.

    Rishi.
     
  8. Jun 11, 2012 #7
    Whenever I do a system Restore any Files on my Desktop go away and thing I was working on change. And it sould not but it always does?
     
  9. Jun 11, 2012 #8
    Thank you for the help but how do you Disable the Camara in Device Manager after I un install the Driver??

    And how do I look for the Driver in C:\ I only know how to just have Device Manager install Drivers by itself by clicking on Install Driver Tab?
     
  10. Jun 12, 2012 #9
    I plug CAM. in and in device manager I Disable it and un install it.

    Then I ran CCleaner and got rid off all tem and old files and had it fix Registray errors.

    Save and reboot and then plug CAM. back in it loaded drivers and I did an Update that it told me the Best driver was installed.

    It does the same thing I have to go to Cam icone and right click it and click import photos.

    I can not get windows to ask me where do I want to import the photos anymore.
    And I go into Autoplay screen and for Picture and Photos I have import Ask Me Every Tims.

    What now
    PS thank you for all the help
     
  11. Jun 12, 2012 #10
  12. Jun 12, 2012 #11
    I do not have PIcasa installed or anything lioke this for photos.
    But does win7. need a progrtam like this becaue I did un install a lot of win7. programs I did not need?

    Does win7. have a default program that it needs to open Autoplay window when a CAM. is connected?
     
  13. Jun 13, 2012 #12
    No , its not necessary.
    Default programms can not be uninstalled or removed as such , so don't worry.



    I am not sure but I think windows photo viewer is the defualt tool for picture viewing in windows 7.

    Btw , have you tried the links I mentioned in my previous post. ? Those links describe the procedure for auto import of pictures from any external imaging device. Please try reading them thoroughly.

    Rishi.
     
  14. Jun 13, 2012 #13
    I did go into the setting to have a program set for diferant things. And I set VLC for everything but this sould just be for Music Videos and so on do I have to check in here and I am not sure were I was to do this?

    And I do have my win7. set to Clasic Look does this tell you anything?
     
  15. Jun 13, 2012 #14
    Try This,

    Goto Control Panel-> AutoPlay

    In AutoPlay mark the following option ,

    "Choose what happens when you insert each type of media or device."
    -Click on the CheckBox that says : "Use autoplay for all media and devices."

    Scroll down to bottom and select your device.
    Select "Import pictures and videos using Windows", from dropdown list.

    click on save.
    .

    I have provided some screenshots for your ease that I took today.
    check the attached files.
    ,
     

    Attached Files:

  16. Jun 14, 2012 #15
    My Autoplay window does not open like this my window says
    Use Autoplay For All Devices. And I put a check mark in the Box to Enable it.

    Then down the page on the left side has a list of all the things you will need Autoplay for.
    CD
    DVD
    Pictures
    Enhanhanced Audio CD

    And so on.

    So next to Pictures is the Dropdown Box and I pick Import Pictures useing Windows.

    Then all the way at the Bottom of the page on the right is SAVE Tab and I click this.

    These things are the only things on the page.
    And it does not help I did it and I whent to the links you posted to no go.

    I called Canan and they told me I do not have to re set the PTP Mode and I can not. And it happens with Vista and win7. in the Registry but they are no help. They can not help me
     
  17. Jun 16, 2012 #16
    I did go into Regedit and whent to

    HKEY LOCALE MACHINE/SOFTWARE/MICROSOFT/WINDOWS/CURRENT VERSON/POLICES/EXPLORE

    Then I right click on Explorer in the Tree and click Dword32 Bit.

    Then it puts the new item on the right side window so I go to that and give it the name NoDriveTypeAutoRun

    And then I give the Value of HEX 0x00000091

    Now I go to do the same thing for
    HKEY CURRENT USER/SOFTWARE/MICROSOFT/WINDOWS/CURRENT VERSON/POLICES/EXPLORER

    But when I click the + nexto Current Verson the Polices folder and Explorer folder both drop down under it.

    There is no + next to Polices folder and explorer folder is right there under the Polices folder not in the Polices folder.?
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Usb help
  1. Usb security (Replies: 1)

  2. USB Programming (Replies: 3)

  3. Wireless usb (Replies: 3)

  4. Stolen USB (Replies: 5)

  5. Mini USB to Micro USB (Replies: 9)

Loading...