Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Calculators Weird TI-89 Lockup Behavior

  1. Aug 18, 2015 #1
    So, I foolishly bought a TI-89 Titanium on Ebay that was known to be in a locked up state. I've fixed locked up things before and figured I could here, too. Bad move.

    A thread here indicated that the hot car trick might fix it. I thought it had, but basically I think that was just due to removing all batteries for a sufficient amount of time.

    As far as I can tell, basically here's what it does: You remove one of the AAA batteries and the backup and let it sit for a while (maybe 5 minutes or so). Power it on and it works normally for a few seconds to a few minutes. Then it locks up completely. No button input works. Remove all batteries for a little while and it works again.

    If I insert a battery while holding down the (-) and ) keys plus ON, it'll go to the "Installation in progress. Please do not interrupt" screen. But then it comes up immediately locked up again on the main screen.

    If I insert a battery while holding down APPS and ON, it goes to the "Waiting to receive" screen, but is locked up. It isn't recognized by my computer or anything with a working USB cable.

    I DID, however, get to upgrade the software one time while it was in its temporarily working stage, so it's on the latest build (3.10).

    I just tried starting it up and immediately clearing the flash. No good. Locked up after getting back to the main screen. Did the same with the other ram later. Same result.

    Any other bright ideas? I'm kind of at a loss. I have no idea what would cause this sort of issue other than guessing it's a hardware issue. I've already ordered another one, but it'd be nice to not have this one be a total loss.
     
    Last edited: Aug 18, 2015
  2. jcsd
  3. Aug 18, 2015 #2
  4. Aug 19, 2015 #3

    CalcNerd

    User Avatar
    Education Advisor
    Gold Member

    I didn't respond because it sounds like jakej has tried nearly everything without resorting to a soldering iron and chip replacement.
    .
    My last suggestion is to buy top notch batteries and try to reload the OS. Perhaps the OS is corrupted (if due to bad eprom, no hope) and the new OS isn't loading possibly due to low voltage on older or lower quality batteries. Reloading the OS is the most draining and demanding battery load on these re-flashable calcs.
    .
    Good luck.
     
  5. Aug 19, 2015 #4
    Thanks, @CalcNerd. Interesting, too. I just checked the batteries I had been using (Duracell Duralock alkaline) with a calibrated Fluke DMM and they were each at around 1.45 volts. I got a new set and they were around 1.61. Given that TI's site ( https://epsstore.ti.com/OA_HTML/csksxvm.jsp?nSetId=90610 ) seems to indicate that voltage needs to be around 6 volts, is ~5.785 close enough? Seems pretty close.
     
  6. Aug 20, 2015 #5

    CalcNerd

    User Avatar
    Education Advisor
    Gold Member

    The Ti instructions call out for FRESH NEW BATTERIES for an OS upgrade. I suspect they need to be at a full 1.5-1.6 Volts on each cell. And batteries are not a linear curve for capacity. Your 1.45 Volts could be 70% depleted. For general calculator use, your batteries are fine, but they probably won't reliably do a flash upgrade. If you do some web browsing you will find many people who bricked their calculators by not using fresh batteries.
     
  7. Aug 21, 2015 #6
    Wow. Thanks. I didn't realize that. If I can get it to stay awake long enough I'll hopefully give it a try this weekend.
     
  8. Apr 7, 2016 #7
    I never ended up trying this until just now. Alas, no dice. Downloaded the OS without issue with fresh batteries (each at 1.6 volts). It installed, rebooted, and worked fine at first. Then I powered it off, then back on and it was frozen again. Seems like it's got to be hardware.

    Oh well. Thanks anyway, @CalcNerd !
     
  9. Apr 7, 2016 #8

    ProfuselyQuarky

    User Avatar
    Gold Member
    2016 Award

    Are you going to get a new calculator or you already have another?
     
  10. Apr 7, 2016 #9
    My TI-84 Plus works fine for my current needs, so I'll probably stick with it for now.
     
  11. Apr 7, 2016 #10

    ProfuselyQuarky

    User Avatar
    Gold Member
    2016 Award

    Alright, but if you want to invest in a new one, I highly recommend the TI Nspire CX. The thing is a killer.

    Anyhow, food for thought :)
     
  12. Apr 7, 2016 #11
    Thanks! I'll look into it when I feel the need to upgrade.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted



Similar Discussions: Weird TI-89 Lockup Behavior
  1. TI-89 Trig (Replies: 1)

  2. TI-89 Emulator (Replies: 1)

  3. Ti-89 help (Replies: 1)

  4. ODE's on the TI-89 (Replies: 5)

  5. Ti-89 Question (Replies: 1)

Loading...