Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Why doesn't my new RAM work?

  1. Sep 11, 2012 #1
    My motherboard is the ASUS M4A785TD-V EVO. I decided to get som more RAM for it, and went for 16 GB (4x4) by Crucial:

    http://www.crucial.com/uk/store/mpartspecs.aspx?mtbpoid=E8F809A0A5CA7304 [Broken]

    After installing it my PC didn't want to boot. It revs up and all, but the screen never gets a signal. I thought I might have missed something regarding compatibility, but from what I can find it should work with my board. I tried it a couple of times, but to no evail. Finally I put back my old ones (also by Crucial (2x2), and everything worked great.

    Ideas anyone?
     
    Last edited by a moderator: May 6, 2017
  2. jcsd
  3. Sep 11, 2012 #2

    Evo

    User Avatar

    Staff: Mentor

    Their customer support couldn't help? They even have live chat available for support by a tech.

    http://www.crucial.com/contact/

    If they figure out the problem, it would be great if you'd post the solution here for others.
     
    Last edited by a moderator: May 6, 2017
  4. Sep 11, 2012 #3

    AlephZero

    User Avatar
    Science Advisor
    Homework Helper

    Try installing just one memory module at a time (in the correct slot, of course - see the motherboard documentation).

    Ir could be one of the four modules is faulty and is stopping everything from working when you install all four of them.
     
  5. Sep 11, 2012 #4
    http://www.asus.com.au/Motherboards/AMD_AM3/M4A785TDV_EVO/#MSL
    Memory Support List.

    The BLT4CP4G3D1608DT1TX0BEU 16gb kit is not supported by the motherboard.

    BL25664TB1608.K16SF(XMP) only supports one Module at a time, the others in the same brand support upto 4.

    By chance you may have purchased the only ram on the market not to work with your computer or as stated above you may have one or two dodgey sticks that you need to return.

    Really comes down to testing the ram sticks one by one, Boot the pc with one stick at a time, going through them to find if it doesnt boot up with one of them, narrow your search down and you may be able to get 3 of them working (single channel) until you get a replacement.

    You can use windows 7's built in memory test by spamming F8 while your computer is turning on and selecting diagnostics i think, there should be a mem test type program in there that tests your ram, judging by whats happening though you will only need to go through them one by one to find the faulty one, as its stopping the rest from working.
     
  6. Sep 12, 2012 #5
    No success with the stick as of yet :(
    I see that my sticks aren't on the list (it's from 2009), but why is it that when using the system scan feature on Crucial's site, it finds that my sticks should work fine with my motherboard?

    How come you commented on the BL25664TB1608.K16SF(XMP)? Is it the "closest" to what I have bought?
     
  7. Sep 14, 2012 #6
    Latest news: Sticks are working :)

    Turns out I had to update my BIOS to the latest version. After doing so I installed the new sticks again, but the PC still wouldn't boot. I removed one, and then another, and when attempting to boot with only two sticks, it suddenly worked. I then put back the first stick I removed next to the other two, and it still booted. So I put the fourth one back as well, and everything was still good. Why it didn't work at first I have no idea, just thought I'd post the happy ending here :)
     
  8. Sep 14, 2012 #7
    I was tempted to offer that as a solution, but figured you get there anyway. In general, if something fails to work first close all programs and try again. If that doesn't do it, reboot. If that doesn't do it, disconnect all usb ports and reboot. If that doesn't do it, contact the manufacturer and go back to step one. For ram, that means adding the additional step of removing ram sticks one at a time until it does work.
     
  9. Sep 16, 2012 #8
    Yes they are the closest to the ram you purchased that existed on the day of release of your motherboard, from seeing your other comments good job on updating your bios, that was also my next point of call.

    I have had issues with Kingston Hyper X ddr2 ram before, all other ram had just worked perfectly, updating the bios did not fix the issues i was having and turned out the series was just faulty to begin with. went back to generic ram and everything just worked. it overclocked better aswell sadly.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Why doesn't my new RAM work?
Loading...