Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Xmms problem

  1. Jul 26, 2006 #1
    My problem is sorta hard to describe (but easy to understand), but the point is it is difficult to find solution on Google.

    When I play an mp3 file using xmms, the progress bar moves very fast (for example, I timed a 5 min song and the slider bar moved across in 11secs and no sound was heard).
    I am using RH9(can't get better, system will overload).
    I know that RH9 does not support mp3 so I had installed the mp3 plugin, but it is still giving problems. Help in any form will be appreciated.
     
  2. jcsd
  3. Jul 26, 2006 #2

    Curious3141

    User Avatar
    Homework Helper

    Just a guess but is the player using the correct output codec (as in an audible output codec)? Sounds a bit like it's wavewriting (making a .wav file out of the .mp3), which happens at high speed. If this is the case, you will get no sound output.

    In any case, I've found xmms to be one of the buggiest apps that come with most modern distros.
     
  4. Jul 26, 2006 #3
    I tried disabling all the other plugins and keeping only the mp3 plugin enabled, but the problem persists.

    PS: What should be the ideal buffer size and prebuffer size, maybe these settings are wrong.

    And I would appreciate if you could tell me a mp3 player that I might be able to use given my old OS. I have tried many mp3 players - Amarok, Xmms, Real 10, mpg123, mpg321, bob, audioplayer, and maybe 10 more, but all give errors. Of these Real Player works but it does not support playlists. mpg321 works but everytime I boot up the system I have to install a rpm libmad. I want the rpm files not the compile files, which usually fail. :cry:
     
  5. Jul 26, 2006 #4
    try beep-media-player (or BMP), i use it with Gstreamer output (and have the mp3 plugin for Gstreamer), though the xine engine is good too.

    btw, BMP has been discontinued, BMPx is the new verion, i haven't used it yet though... BMP works fine for me.

    by the way, whats your computer specs?
    have you tried xubuntu, vector-linux, puppy-linux, or damn-small-linux?
    they were created with weaker computers in mind - i know that atleast on xubuntu it's a child's play to make mp3, java, flash and win32 codecs work... (not that it's so hard on other distro's, but on this one it's VERY easy)
     
    Last edited: Jul 26, 2006
  6. Jul 27, 2006 #5
    I can't get bmp to ./configure. It gave an error message that so and so libraries were missing, so I downloaded them but the two libraries are interdependent upon one another. I asked a senior and he told me that last year he had spent whole night installing a player. Maybe he will be able to help me, but for the time being any more suggestions are most welcome.
     
    Last edited: Jul 27, 2006
  7. Jul 27, 2006 #6
    well, if you want help with installing it, you can post here the exact messages you get..

    i think you'd get better support here - just type mp3 in the search field to find the expert in this field (tried it, there are some).

    and the good ol' linux forums in linuxquestions...
     
  8. Jul 27, 2006 #7
    Thanks for the help. I finally found SnackAmp and it is working fine. No need to install it, it just runs. :!!)
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Xmms problem
  1. Yahoo problems. (Replies: 2)

  2. Download problem (Replies: 4)

  3. Problems with Chrome (Replies: 19)

  4. Java problem. (Replies: 4)

  5. Keyboard Problems (Replies: 6)

Loading...