View Single Post
0rthodontist
0rthodontist is offline
#14
Jul7-06, 03:44 PM
Sci Advisor
P: 1,253
Regarding that error about java.library.path I'm getting when I try to test the lwjgl libraries, I wrote a program consisting of
System.out.println(System.getProperty("java.library.path"));
and ran it in my lwjgl directory. It turned up some stuff--directories containing .dll files that various programs I have apparently use--but sure enough the lwjgl\native\win32 directory which appears to contain the .dll files for lwjgl was not one of them. I tried to set the property on the command line using
java -D java.library.path=native\win32
and various variations on that theme, but no luck--every time I tried that it turned up a NoClassDefFoundError and spit back whatever I had put after the -D, and turning all periods into forward slashes for some reason. For example, in response to the previous attempt, it said
Exception in thread "main" java.lang.NoClassDefFoundError: java/library/path=native\win32
Also, a web site I read said that the -D command will only temporarily set properties, not permanently.

So how do I get the java.library.path property to include the lwjgl\native\win32 directory?