Register to reply

High pass filter, output has negative voltage level

by d.arbitman
Tags: high-pass filter
Share this thread:
d.arbitman
#1
Apr28-12, 10:48 PM
P: 103
I built a clock generator using a 555 and I fed the output to a high pass filter. It works for the most part, BUT the input voltage ranges from 0 to 5V while the output is -5 to 0 V. I can't figure out why this is happening. I'm new to EE, so bear with me.
Phys.Org News Partner Engineering news on Phys.org
Greater safety and security at Europe's train stations
Fingerprints for freight items
On the way to a safe and secure smart home
davenn
#2
Apr28-12, 11:08 PM
Sci Advisor
PF Gold
davenn's Avatar
P: 2,666
you havent given too much to go on...

my first Q is is your filter an active one or a passive one ?
if its an active filter its quite probable you are getting an inverted output

how about some circuit diags of what you are doing :)

Dave
d.arbitman
#3
Apr28-12, 11:21 PM
P: 103
Sorry, I realized I left out a bit of detail.
It's an RC high pass filter. It should let frequencies ~2.2Hz and above pass, while the output from the 555 is roughly 16Hz, so there should be no problem there. Active/Passive :O? Time to go read.
http://i49.tinypic.com/dq62rc.jpg
http://i46.tinypic.com/i2inpw.jpg

davenn
#4
Apr28-12, 11:31 PM
Sci Advisor
PF Gold
davenn's Avatar
P: 2,666
High pass filter, output has negative voltage level

hi there

ok active filter will contain transistors and or IC's often active filters will be made using an Op-amp

in your second pic link it just shows a resistor and a capacitor on the output so it would be deemed to be a passive filter.

Dave
d.arbitman
#5
Apr28-12, 11:33 PM
P: 103
Ok, I just read about that too, but I'm still confused why my output is inverted.
Thank you.
davenn
#6
Apr28-12, 11:41 PM
Sci Advisor
PF Gold
davenn's Avatar
P: 2,666
Quote Quote by d.arbitman View Post
Ok, I just read about that too, but I'm still confused why my output is inverted.
Thank you.
I cant answer that straight off ( bit ashamed about that haha I should be able to)
if I cant find an answer some one else may chip in.
what i have read so far is that a passive RC filter shouldnt invert the signal

D
d.arbitman
#7
Apr28-12, 11:43 PM
P: 103
Thank you Dave.
Well, earlier I had a similar setup, but different values and frequencies and my output from the RC filter, was ranging from -2.5 to 2.5, which if I'm not mistaken is normal as power is cut in half.
d.arbitman
#8
Apr28-12, 11:48 PM
P: 103
Wait, I figured it out. The circuit was fine, it's the oscilloscope that was wrong. :(
davenn
#9
Apr29-12, 12:01 AM
Sci Advisor
PF Gold
davenn's Avatar
P: 2,666
Quote Quote by d.arbitman View Post
Wait, I figured it out. The circuit was fine, it's the oscilloscope that was wrong. :(
ohhh ? leads connected around the wrong way ? :)


Some stuff I was reading and would need clarified to me, was about the change in signal phase. hopefully VK6KRO or some one will chime in....

hi pass RC filters

Dave
d.arbitman
#10
Apr29-12, 12:16 AM
P: 103
No, the input had a LOW offset at 0v, while the output had a HIGH offset at 0V. I don't know the fancy terms for that, hopefully that made sense.
yungman
#11
Apr29-12, 03:56 AM
P: 3,898
Quote Quote by d.arbitman View Post
Sorry, I realized I left out a bit of detail.
It's an RC high pass filter. It should let frequencies ~2.2Hz and above pass, while the output from the 555 is roughly 16Hz, so there should be no problem there. Active/Passive :O? Time to go read.
http://i49.tinypic.com/dq62rc.jpg
http://i46.tinypic.com/i2inpw.jpg
Let me make a wild guess. You use the /Q output of the 555 which normally stay high and pulse low. So it goes from +5V to 0V when triggered and stay for a short time and goes back high again until the next trigger.

With the RC filter, you see the output normally stay close to 0V, then the pulse goes to -5V and come back to 0V. Am I right so far?

If so. It is a duty cycle effect since you have a capacitor to block the DC. The reason you see the output goes from about 0V to -5V is because at the rest condition, the output is at 0V. But when you pulse low, the output goes from 0V to -5V due to the AC couple. Any signal that is AC coupled, the average of the signal has to be 0V. Because output at the 555 only goes low for a very short period of time, the output after the cap sit mostly at 0V. From the scope picture, your duty cycle is only about 20%( 20% low and 80% high). With AC couple, the average has to be at about 0V. With 80% high and 20% low, the voltage at the output should be +1V to -4V. Double check you scope again, find the 0V level, it cannot be from 0V to -5V. Double check and you'll find it is from +1V to -4V if it is 20% duty cycle.

But you should get what I am trying to say. Because of the duty cycle, the AC signal seems to cocked to the negative side. If you have a square wave at 50% duty cycle, you'll see it goes from +2.5V to -2.5V after the cap.
d.arbitman
#12
Apr29-12, 09:32 AM
P: 103
Quote Quote by yungman View Post
Let me make a wild guess. You use the /Q output of the 555 which normally stay high and pulse low. So it goes from +5V to 0V when triggered and stay for a short time and goes back high again until the next trigger.

With the RC filter, you see the output normally stay close to 0V, then the pulse goes to -5V and come back to 0V. Am I right so far?

If so. It is a duty cycle effect since you have a capacitor to block the DC. The reason you see the output goes from about 0V to -5V is because at the rest condition, the output is at 0V. But when you pulse low, the output goes from 0V to -5V due to the AC couple. Any signal that is AC coupled, the average of the signal has to be 0V. Because output at the 555 only goes low for a very short period of time, the output after the cap sit mostly at 0V. From the scope picture, your duty cycle is only about 20%( 20% low and 80% high). With AC couple, the average has to be at about 0V. With 80% high and 20% low, the voltage at the output should be +1V to -4V. Double check you scope again, find the 0V level, it cannot be from 0V to -5V. Double check and you'll find it is from +1V to -4V if it is 20% duty cycle.

But you should get what I am trying to say. Because of the duty cycle, the AC signal seems to cocked to the negative side. If you have a square wave at 50% duty cycle, you'll see it goes from +2.5V to -2.5V after the cap.
I checked the calculations on the scope and you are absolutely correct about it being from +1V to -4V but I am using the Q output according to one of my textbooks.
http://i45.tinypic.com/2uszejd.png
The Vmax of the output is 5V, so it really is high for 80%.

EDIT:
I rebuilt the 555 such that it's roughly 50% duty cycle. Now the output from the RC filter is roughly 3.8V to -3.8V which coincides with the theory that AC coupling results in an average of 0V. But why the 3.8 is where I'm lost. Also, I noticed there is an option on the scope to choose between DC and AC coupling. The measurement above had both channels on DC coupling.
After switching CH2(output from filter) to AC coupling, the signals jump to 4.4V and -4.4V.
NascentOxygen
#13
Apr29-12, 10:02 AM
HW Helper
Thanks
P: 5,361
AC coupling involves including a series capacitor to block the DC component but allow the AC to pass. The average voltage on the blocked side will automatically adjust itself to be zero. The CRO has this option at its input. This is useful for times when you might be interested in examining a few mV of ripple on a large DC level. You can extract the ripple and amplify it without also amplifying the DC component and causing a baseline shift that pushes the waveform off the display.
d.arbitman
#14
Apr29-12, 10:16 AM
P: 103
Two things are confusing me at the moment:
1. Why is the output whether i'm using AC/DC coupling option on the scope not 5V to -5, but it's less than that?
2. Why the jump from 3.8 to 4.4 when switching from DC to AC?

EDIT:
That voltage seems to depend on the capacitor I use for the filter from my observations, which is confusing the crap out of me, is it dependent on the how much charge can be stored on the capacitor? I'm assuming that the more charge the capacitor can store, the longer it will take to reach Vs, so if the frequency in which that voltage changes is much faster than 5TC then the capacitor will not reach that voltage level.
NascentOxygen
#15
Apr29-12, 11:06 AM
HW Helper
Thanks
P: 5,361
I have been wondering whether you know what to expect from a high pass filter? It is also known as a differentiator. Are you sure you weren't wanting a low pass filter?
Quote Quote by d.arbitman View Post
Two things are confusing me at the moment:
1. Why is the output whether i'm using AC/DC coupling option on the scope not 5V to -5, but it's less than that?
The average voltage cannot be anything but 0 at the output of your high pass filter.
2. Why the jump from 3.8 to 4.4 when switching from DC to AC?
That jump is a perfect means for measuring the average value of the waveform. It indicates the DC or average value of the waveform. Switching the CRO input from AC to DC will have no effect when you are displaying the output of your high pass filter as it is already 0V DC.
yungman
#16
Apr29-12, 12:38 PM
P: 3,898
Quote Quote by d.arbitman View Post
I checked the calculations on the scope and you are absolutely correct about it being from +1V to -4V but I am using the Q output according to one of my textbooks.
http://i45.tinypic.com/2uszejd.png
The Vmax of the output is 5V, so it really is high for 80%.

EDIT:
I rebuilt the 555 such that it's roughly 50% duty cycle. Now the output from the RC filter is roughly 3.8V to -3.8V which coincides with the theory that AC coupling results in an average of 0V. But why the 3.8 is where I'm lost. Also, I noticed there is an option on the scope to choose between DC and AC coupling. The measurement above had both channels on DC coupling.
After switching CH2(output from filter) to AC coupling, the signals jump to 4.4V and -4.4V.
I was going to post again about the possibility of using Q output, but it was too late last night. You can make the Q output look like this if you have a long pulse width. So the 555 only goes low for a short period of time before it gets re-triggered again. So you see 80% high( pulse) and 20% low( after the pulse before the second pulse).

I cannot explain your observation on -3.8 to +3.8. It is not possible unless the layout of the circuit is very wrong and it start ringing really bad. You only have RC in the circuit, there is no resonance to increase the voltage. Again, check you scope setting, make sure the channel switch is on calibrate, not in variable gain. Check over the way you measure. At this low frequency, you really cannot do so wrong to make the circuit like this.

If the same channel and scope probe measure +5V to 0V at the output of 555, then you move the same scope probe without touching the scope setting, you see +3.8V to -3.8V at the final output, you can write to Mulder in X-File!!!!
yungman
#17
Apr29-12, 12:45 PM
P: 3,898
Quote Quote by d.arbitman View Post
Two things are confusing me at the moment:
1. Why is the output whether i'm using AC/DC coupling option on the scope not 5V to -5, but it's less than that?
2. Why the jump from 3.8 to 4.4 when switching from DC to AC?

EDIT:
That voltage seems to depend on the capacitor I use for the filter from my observations, which is confusing the crap out of me, is it dependent on the how much charge can be stored on the capacitor? I'm assuming that the more charge the capacitor can store, the longer it will take to reach Vs, so if the frequency in which that voltage changes is much faster than 5TC then the capacitor will not reach that voltage level.
From the waveform you posted in the first post, it look perfectly straight, I assume you have a very big cap so charge and discharge is not a problem. If you see decade of the top and bottom of the pulse, then you can have different peak voltage. Usually if the cap is too small, you see the pulse shoot to one or the other extreme, then it starts to return back in exponential way. Say if you first pulse from 0 to -5, it will start slanting up to about -3 before it change state and shoot back up. But if you shoot back up 5V, you will see it goes all the way to +2V as you are going from -3V to +2V. If you follow this logic, you can see the peak is -5 to +2V and you apparently increase the swing from 5V to 7V.

But as I repeat, draw the Mulder conclusion based on the picture you showed that there is no decay on the waveform. That is not possible.

Regarding to the two channel seeing different swing. You are running at too long a frequency, the AC couple in the scope has a high pass limit also, there is no difference the RC circuit you are playing and the scope, you hit the lower limit and it will give you funny result.

Shorten the pulse width, work in 1 or 2 KHz range and you'll see much better result.
d.arbitman
#18
Apr29-12, 04:33 PM
P: 103
I rebuilt the 555 circuit to generate an 11kHz wave. Now the output of the filter is more of what I'd like to see.
http://i50.tinypic.com/2j2t7b8.jpg

I can see that the area under the HIGH curve is roughly equal to the area above the LOW curve, thus the average being 0V.


Register to reply

Related Discussions
Low-pass filter with no inductance, and voltage output over a resistor Engineering, Comp Sci, & Technology Homework 3
High pass filter and low pass filter question? Engineering, Comp Sci, & Technology Homework 6
Transforming a low pass filer to a high pass filter Engineering, Comp Sci, & Technology Homework 0
High Pass filter & Low Pass Filters features Engineering, Comp Sci, & Technology Homework 1