Special characters and editing


by Hurkyl
Tags: characters, editing, special
Hurkyl
Hurkyl is offline
#1
Dec14-04, 09:32 PM
Emeritus
Sci Advisor
PF Gold
Hurkyl's Avatar
P: 16,101
Ok, this is bugging me again, so I'll say something!


Procedure (on WinXP and Opera7):

(1) Write a post with a special character, like θ.

The character displays fine on the page.

(2) Edit that post.

The character appears fine in my text box.

(3) Save changes.

The character appears as a '?' on the page.


Suggested solution: if possible, replace the special characters with their original incantation, I.E. θ with & theta ;, when you populate the "Edit Post" page.
Phys.Org News Partner Science news on Phys.org
Internet co-creator Cerf debunks 'myth' that US runs it
Astronomical forensics uncover planetary disks in Hubble archive
Solar-powered two-seat Sunseeker airplane has progress report
chroot
chroot is offline
#2
Dec15-04, 02:19 PM
Emeritus
Sci Advisor
PF Gold
chroot's Avatar
P: 10,424
Ah, yes, this is the same problem we had back in an earlier version of PF. The edits I made to the code to fix this problem were overwritten when we upgraded to 3.03. I have a number of bug fixes I need to do, I'll add this to the list.

- Warren


Register to reply

Related Discussions
Characters needed General Discussion 52
solved, and some characters Forum Feedback & Announcements 0
Recalling alphanumerical characters Social Sciences 2
range of characters in C++ Introductory Physics Homework 2
VB program and 56 characters Computing & Technology 2