1. Not finding help here? Sign up for a free 30min tutor trial with Chegg Tutors
    Dismiss Notice
Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Unusual Compiler Error (using Dev-C++ Mingw)

  1. Jan 13, 2009 #1
    I find myself with an unexpected error that I can't seem to resolve. When trying to compile and run even a simple program, I receive the following error (the directory path for the project file is C:\unisa\Assignments, the project is Assignment1 and source file is Question1):

    mingw32-make.exe (in the "Line" columnn of compiler tab in DevC++ window) C:\unisa\Assignment1\mingw32-make.exe (in "File" column) Circular Question1 <- Question1.o dependency dropped (in "Message column)

    next line:

    C:\unisa\Assignment1\Makefile.win ('File" column) [Build Error] exe: *** [Question1] Error 1 ("Message" column)

    I have double checked that my compiler settings are correct and have even uninstalled and re-installed both the IDE as well as the compiler, but to no avail.

    Any ideas?
     
  2. jcsd
  3. Jan 13, 2009 #2

    mgb_phys

    User Avatar
    Science Advisor
    Homework Helper

    It looks like there is an error in the Makefile = the equivalent of a project file
    Is there an option to rebuild the makefile?
     
  4. Jan 13, 2009 #3
    I'm not sure, but I have deleted the makefile to see if a new attempt at getting it to run works, but no luck. However, I'm on a different machine at the moment and thought I'd try the exact same code on a computer where the combination of Dev-C++ and Mingw has NEVER given me any problems and now I have the same issue (having said that, I've never tried creating projects on this machine, purely single source files).

    If I simply use the option to open a new source file (independent of a project) everything works. As soon as I try to create a project, including the code in an underlying source file, then no go...

    Perhaps I should just find myself another IDE/compiler combo?
     
  5. Jan 14, 2009 #4
    Problem solved!

    When creating the project, I made the mistake of not saving the source file with a .cpp extension, so make was looking for an extension and finding none, ended up in a loop.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Unusual Compiler Error (using Dev-C++ Mingw)
Loading...