Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Bug in Maxima or I'm missing something?

  1. Oct 3, 2014 #1

    fluidistic

    User Avatar
    Gold Member

    I am clueless. Here's the model I tried to follow:
    Code (Text):
    g(a):=a^2-1;
    Code (Text):
    f(a,b):=a+g(a)-b;
    Code (Text):
    f(a,b);
    With output
    Code (Text):
    −b+a^2+a−1
    Which is 1)Define a function in terms of some variable(s).
    2)Define another function in terms of some variable(s) and in terms of the function defined in 1).
    3)Evaluate the function in 2) to see the explicit and eventually simplified form of that function.

    I tried this with a more complicated function but the output is troublesome:
    1)
    Code (Text):
    Z(beta, delta, hbar, omega):=exp(-beta*hbar*omega)*((exp(-beta*delta)-1)/(1-exp(-2*beta*hbar*omega))+1/(1-exp(-beta*hbar*omega))^2);
    2)
    Code (Text):
    P_n(beta, delta, hbar, omega,n):=(exp(-beta*(hbar*omega*(1+2*n)+delta)))/Z(beta, delta, hbar, omega);
    3)
    Code (Text):
    P_n(beta, delta, hbar, omega,n);
    with output
    Code (Text):
    e^(beta*hbar*omega−beta*(hbar*(2*n+1)*omega+delta))
    which reduces to
    Code (Text):
    e^(−2*beta*hbar*n*omega−beta*delta)
    which is way too simple.
    On my draft I've got a more "complex" function than this ultra reduction and there's absolutely no way to get what Maxima got. It's almost as if Maxima did not divide by Z(beta, etc) when evaluating 3).

    Am I missing something? Or Maxima is bugged?
     
  2. jcsd
  3. Oct 4, 2014 #2

    fluidistic

    User Avatar
    Gold Member

    Sorry guys, I am unable to reproduce this behavior anymore, I now get the correct result.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Bug in Maxima or I'm missing something?
  1. Manual of Maxima (Replies: 11)

  2. Bug with mathematica (Replies: 1)

  3. LaTeX bug? (Replies: 10)

  4. Bug in Octave? (Replies: 1)

  5. Integrating in Maxima (Replies: 1)

Loading...