Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Comsol w/Matlab: CLI vs GUI issues

  1. Sep 8, 2009 #1
    Hi all - I've been working on some code in Comsol w/ Matlab that works fine on any machine I run it on - so long as I run it through the Comsol w/ Matlab GUI.

    No matter which machine I run it on, the program fails if I run Comsol w/ Matlab through a CLI. Specifically, the geominport() function fails to import my geom.mphbin file with the following error (gap is the name of my model m-file):

    Code (Text):
    >> gap
    ??? Java exception occurred:
    java.lang.NullPointerException
            at com.femlab.server.MlProgressDlg.runAndWait(Unknown Source)
            at com.femlab.server.FlRunnable.a(Unknown Source)
            at com.femlab.server.FlRunnable.smartRunner(Unknown Source)

    Error in ==> geomimport at 208
    glr.jptr.smartRunner(report, 500);

    Error in ==> gap at 23
    garr = geomimport('./geom.mphbin');
    I am planning to submit this code as a job on a computer cluster where any kind of GUI interface will be out of the question. Has anyone using Comsol/Matlab encountered this problem before, and do you know any workarounds that will let me get my code running without a GUI?

    Thanks much!
     
  2. jcsd
  3. Oct 1, 2009 #2
    Hi,

    Can it be that you try to use the function geomimport() but misspelled it to geominport() ?

    Good luck
    / T

     
  4. Oct 1, 2009 #3
    Good eye. I didn't notice that. Unfortunately, the typo is only in my post, not in the code. Right now I'm running the job on a cluster with X11 forwarding for the GUI and hoping that I don't lose my connection to the cluster for about a week's worth of computation. ;-)
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Comsol w/Matlab: CLI vs GUI issues
  1. Airstream Comsol (Replies: 5)

  2. Convection in Comsol (Replies: 1)

  3. Comsol help (Replies: 2)

  4. Comsol problem (Replies: 1)

Loading...