Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Wireless cardbus adapter drivers

  1. Feb 16, 2008 #1
    [SOLVED] wireless cardbus adapter drivers

    Yesterday I bought a D-link DWA-645 wireless cardbus adapter and having troubles getting the drivers sorted out. My machine is a portable with ubuntu 7.10 on it (dual boot with XP)

    I used madwifi but got stuck in the "Loading the MadWifi Module" part of the following link:


    It does not seem to do anything. In the next step I get "No such device"

    So, I tried to use something different, ndiswrapper. This was a complete failure because after the installation using synaptic I got a complete freezing of my system when I tried to point to the windows driver. A manual reboot was necessary.

    I think there is no problem with the device itself, it is recognised in the device manager. Also it works on XP. I assume it is an installation issue of the drivers?

    Any help on this is appreciated. Please explain everything in detail because I'm not a linux expert and networks are difficult for me.
  2. jcsd
  3. Feb 24, 2008 #2
    Can you do a
    Code (Text):
    In terminal, and post the output? Also what information did ndiswrapper give?

    Here's a chart showing which chipsets are compatible with which Operating Systems.
  4. Feb 24, 2008 #3
    The output of lspci was:

    00:00.0 Host bridge: Silicon Integrated Systems [SiS] 645xx (rev 11)
    00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
    00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
    00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
    00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
    00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
    00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
    00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
    00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
    00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
    00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
    00:08.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
    00:09.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
    01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)] (rev 01)

    The installation of ndiswrapper was originally done in a terminal as:
    $ sudo m-a a-i ndiswrapper
    Updated infos about 1 packages
    Getting source for kernel version: 2.6.22-14-generic
    Kernel headers available in /usr/src/linux
    Creating symlink...
    Couldn't create the /usr/src/linux symlink!
    apt-get install build-essential
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    build-essential is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package ndiswrapper-source is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package ndiswrapper-source has no installation candidate

    Updated infos about 1 packages

    The error: Couldn't create the /usr/src/linux symlink! seems now to be solved
    because I installed it via synaptic after a search on ndisgtk instead of ndiswrapper.

    Now in the Windows Wireless Drivers I see that I can load the driver. It states that no hardware is found, after putting the adapter in and restarting windows wireless drivers it sees indeed the hardware. However, the next step is to configure the network and this new window that pops up does not have a wireless network visible.

    If I type in a terminal $sudo modprobe ndiswrapper I get a very nasty system hang. I need to shut it down via the hardware button.

    Is this OK to start with? Many thanks for your help, I am at the point of throwing the brandnew damn thing (85 euro) away.
  5. Mar 4, 2008 #4
    I bought a new cardbus adapter, this worked within 10 minutes.
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Wireless cardbus adapter drivers
  1. Driver Software (Replies: 1)

  2. PCMCIA Cardbus? (Replies: 0)

  3. Wireless Mice (Replies: 10)

  4. Video Drivers (Replies: 4)